Help - Search - Members - Calendar
Full Version: Dlink Dcf-650w; Can't Change Mac Address
OESF Forums > General Forums > General Support and Discussion > Security and Networking
conn-fused
I've read that it is possible to alter your MAC address with the following command, so I tried it with my D-Link DCF-650W card (SL5500 with SharpRom 2.38):

ifconfig eth0 hw ether 00:00:00:00:00:00

Didn't work. Returned:

SIOCSIFHWADDR: Device or resource busy

So I thought:

ifconfig eth0 down
ifconfig eth0 hw ether 00:00...
ifconfig eth0 up

No. So:

ifconfig eth0 down
ifconfig eth0 hw ether 00:00... up

Well, you get the idea. I also tried editting /etc/pcmcia/network; changing the HWADDR=`whatever ...` to HWADDR="00:00:00:...", but that didn't work either.

Maybe my drivers can't handle it, but I don't know how to diagnose that. I'd welcome advice. Has anyone got this card? Have you ever changed your MAC? Thanks.
lardman
That should work. I presume you're trying to use a valid MAC id though and not all 0s (I'm doubtful that's a valid one)?


Si
conn-fused
Yes, odd isn't it? That's why I wonder if it's my drivers. With this ROM I'm using prism2_legacy... perhaps I'll have to make the move to OZ if I want to be able to do this ...

BTW, I did try several presumably valid MAC addresses (modifying my hardware MAC by +/- 1 or 2) ... good guess though.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.