Help - Search - Members - Calendar
Full Version: all i want in my zaurus
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
Anonymous
my z is great! i'm running the OZ 3.3.5 rom on a CL700. i have an ambicom wl1100c cf wireless card, and a sandisk 512 sd card. everything works great, but.....

i have a few beefs with the OZ rom. the OZ rom doesn't import a couple of the nifty features of the cl700, namely the auto-rotation feature on screen flip, the zoom in/zoom out function to zoom in and out on text for any app, the konqorer web browser has a tendency to crash about half the time that i use it, and the missing functionality of the handcom mobile suite.

also, i've tried to port over the handcom suite, as well as opera 6, with no luck. they seem to install, but when i run the apps, it starts to load, but never completes, and there is no error message, so i don't know what is going on there.

i'm also experiencing what seems like slower load times for the apps. i've tried a couple of the fixes (ie making the themes very simple and easy for loading, and creating a swapfile on the sd card) without much speed increase.

i would really like to see the above features fixed/implimented/availible or what-have-you, and if they are, i would like to be able to find them.

now, the reason for switching over to OZ in the first place, is that i couldn't get my ambicom wifi card anywhere near recognized with the sharp rom. i also like the fact that OZ has ssh, less, fdisk, that autocomplete thing when you press tab(what is that feature called anyway?), and i'm sure other useful utilities that i've gotten used to, built right in.

so, in a nutshell, does anyone know where i can find the speed and slickness of the sharp rom, with the wireless support and extra goodies of the OZ rom, all in one? or, are some of these features slated for implimentation under OZ? or, has anyone gotten handcom suite and opera funtioning on OZ?

a little help in this would be wonderful.

and keep up the good work
lardman
QUOTE
also, i've tried to port over the handcom suite, as well as opera 6, with no luck. they seem to install, but when i run the apps, it starts to load, but never completes, and there is no error message, so i don't know what is going on there.


What is the error? I presume it's fixable with enough info....

QUOTE
i'm also experiencing what seems like slower load times for the apps. i've tried a couple of the fixes (ie making the themes very simple and easy for loading, and creating a swapfile on the sd card) without much speed increase. 


Is this because OPIE doesn't fastload the apps by default?

QUOTE
autocomplete thing when you press tab(what is that feature called anyway?), 


laugh.gif tab completion

QUOTE
i have a few beefs with the OZ rom. the OZ rom doesn't import a couple of the nifty features of the cl700, namely the auto-rotation feature on screen flip, the zoom in/zoom out function to zoom in and out on text for any app


I don't have one of these so I can't really help here, but user participation is the thing that counts with OZ. Talk to Mickeyl (or any of the other core OZ developers) about what you can do to help.

QUOTE
has anyone gotten handcom suite and opera funtioning on OZ? 


I have on my 5500, and am quite willing to help you try to get it all working.


Si
Anonymous
QUOTE
What is the error? I presume it's fixable with enough info.... 

that's the thing, i'm not getting any error message. with hancom word, opera 6, and one of the media players (i can't remember which one offhand) i click, it launches, the hourglass appears, then dissappears quickly, the app doesn't load, and there isn't an error message.

is there i way i can launch these from command line and generate/view any errors?


QUOTE
Is this because OPIE doesn't fastload the apps by default? 

i don't know. is it? how would i fastload? is there a way to increase app launch speed, or is the slower load time something that just is, and i'll have to accept it?


QUOTE
Talk to Mickeyl (or any of the other core OZ developers) about what you can do to help. 

ok, how do i help? in my limited, non-developer way, what can i do?

QUOTE
I have on my 5500, and am quite willing to help you try to get it all working.

ok, how did you do it? i've downloaded the packeges, installed them via the package manager, and i'm having the aforementioned problems (click, hourglass, not loading). i got them from the applications section of the download section of this site. i've installed them to my SD (vfat) card.

thanks
avel
have ypu done any soft boots since you installed all this? simple; but it worked for me.
lardman
QUOTE
is there i way i can launch these from command line and generate/view any errors?


Yes do exactly that. The apps are in /opt/QtPalmtop/bin

I have a feeling your ROM might be a gcc 3.x one (look in /lib and see whether you have a libc2.3 or 2.2; 2.3 = gcc3.x afaict) so you'll need to use compat libs. There are a few recent threads about this (look for titles with '3.3.6pre1' in them).

QUOTE
i don't know. is it? how would i fastload? is there a way to increase app launch speed, or is the slower load time something that just is, and i'll have to accept it?


Hold down your stylus on the icon, a window will pop up, choose fastload. I think this works, but as I don't have my Z in front of me I can't check right now.

QUOTE
i've installed them to my SD (vfat) card. 


This can sometimes cause troubles as VFAT doesn't support symlinks. That said, I don't think that's the cause of your current troubles.


Si
numenor_j
QUOTE
have ypu done any soft boots since you installed all this? simple; but it worked for me

yes, softboots as well as various shutdowns, and the same thing.

now, i've reflashed the rom, and at this point i cannot get the handcom suite to properly install. here is the ipkg output
CODE
Dealing with package /mnt/card/apps/hancommobileword_1.5.0_arm.ipk

Package hancommobileword has no Architecture defined.

hash_table[pkg-hash] n_buckets=1423 n_elements=538 max_conflicts=4 n_conflicts=72

hash_table[file-hash] n_buckets=1423 n_elements=0 max_conflicts=0 n_conflicts=0

hash_table[obs-file-hash] n_buckets=1423 n_elements=0 max_conflicts=0 n_conflicts=0



Creating symbolic links for /mnt/card/apps/hancommobileword_1.5.0_arm.ipk.

Could not open :/usr/lib/ipkg/info/hancommobileword.list

Finished


i'm not sure what those conflicts are, or how to resolve them
any suggestions?
numenor_j
QUOTE
(look in /lib and see whether you have a libc2.3 or 2.2; 2.3 = gcc3.x afaict)

libc-2.3.2.so so, i guess yes.

QUOTE
The apps are in /opt/QtPalmtop/bin

will they be there if i installed to the SD, or would they be in /mnt/card/opt/QtPalmtop/bin instead?

QUOTE
so you'll need to use compat libs

i'm assuming that the threads will point me to where i need to d/l and install process??? i will go find them

QUOTE
Hold down your stylus on the icon, a window will pop up, choose fastload.

yes, this does work, thanks

QUOTE
VFAT doesn't support symlinks. That said, I don't think that's the cause of your current troubles.

lets hope its not, cause i also use my card for my digital camera, and it only likes the vfat format

on a side note, is there a way to d/l straight to the Z using the konq web browser or some other app? i've tried, but can't seem to get it. right now, i'm d/l to my desktop, using a card reader to transfer files, then popping it into my Z and going from there. its a slight bit of hassel, and i'd love to d/l straight to the Z.

thanks still
lardman
I may have been wrong about VFAT not causing your problems. Try creating the symlink which it's looking for:

ln -s /mnt/card/usr/lib/ipkg/info/hancommobileword.list /usr/lib/ipkg/info/hancommobileword.list

Personally I'd just install it by hand, or try formatting the SD card as ext2.
Anonymous
[quote="numenor_j"][quote]
on a side note, is there a way to d/l straight to the Z using the konq web browser or some other app? i've tried, but can't seem to get it. right now, i'm d/l to my desktop, using a card reader to transfer files, then popping it into my Z and going from there. its a slight bit of hassel, and i'd love to d/l straight to the Z.
[/quote]

wget <url>
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.