Help - Search - Members - Calendar
Full Version: Dev_img-1.5 : Block Device Required
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
Still willing to compile natively on sl-5500, OZ-3.5.2 and OPEI-1.2 ! I haven't be successfull with using gcc-2.95; so I would like to test this dev_img-1.5 . But the begining is still puzzling : I flash a new rom to start from scratch, dl the dev_img-1.5 from :
When I run script, I get :
mount: Mounting /...../dev_img-1.5 on /home/zaurus/develop failed: Block device required.
It did not had cramfs in the ipkg list so I installed it, but same error.
Something to do with fstab, cramfs, my file tree ?
I have no insight...except maybe you need to make another loop device? (your post wasn't clear to me on that issue, )
I think, though that dev_img 1.5 is not going to work well with oz, being based on older software than OZ is.

The idea behind OE, anyway is to make software that can be easily brought to a variety of handhelds. Compiling natively won't really do this.... That is part of the big deal w/.bb files (which I haven't exactly mastered).

I beleive OE is using gcc3.4.... isn't there one available through OpenZaurus? Unless you are compiling kernels on your Z you should use the version OE uses, I think.
This is what is going on :

I flash a fresh rom, then follow the instructions :

Setup instructions:

--------1. Unzip and copy contents of the file onto CF or SD card.
done :
#ls /mnt/card

--------2. Run script as root: full_path_to_dev_image mount_point
where "mount_point" is any folder, for exmaple /mnt/dev
( I change the first line of /mnt/card/ from #!/bin/bash to #!/bin/sh )
#cd /mnt/card
#./ /mnt/card/dev_img-1.5 /mnt/dev
Setting mount point /mnt/dev...
Mounting image /mnt/card/dev_img-1.5...
mount: Mounting /mnt/card/dev_img-1.5 on /mnt/dev failed: No such file or directory
Failed to mount /mnt/card/dev_img-1.5 on /mnt/dev

A link has been created in /mnt :
#ls -l /mnt
dev -> /home/zaurus/develop
but /home is empty. (new flashed rom ?)
I add a new "zaurus" user :
#adduser zaurus
Then, delete the last line added in /etc/fstab by the preceeding aborted install.
Then try to install again :
#cd /mnt/card
#./ /mnt/card/dev_img-1.5 /mnt/dev
Setting mount point /mnt/dev...
Mounting image /mnt/card/dev_img-1.5...
mount: Mounting /mnt/card/dev_img-1.5 on /mnt/dev failed: Block device required
Failed to mount /mnt/card/dev_img-1.5 on /mnt/dev

----------3. When script finishes, relogin as zaurus
--> :-[

This is the last line of /etc/fstab :
/mnt/card/dev_img-1.5 /mnt/dev cramfs loop,noauto 0 0
Any idea ?
well..., now I'm trying zgcc and I had the same "Block device required" error when mounting cramfs part. Finaly, I found the solution in this thread :
Cramfs No Supported in OZ 3.5.2 :5
Thanks Hrw, now I can mount cramfs part with OZ-3.5.2.
I'll go on with zgcc see if I can have it work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2016 Invision Power Services, Inc.