Help - Search - Members - Calendar
Full Version: Cf Card Problem Under Win After Reformat
OESF Portables Forum > General Forums > General Discussion
xjqian
Lexar 4x 1G CF card. Formated to ext2 before. Today I used fdisk to format it to fat16 (used both 4 and 6 in the format id HEX list). Everything looks fine under my zaurus. dmesg looks normal. And I plugged it in my digicam. it took pictures just fine.

But under windows xp home, it's not recognized. It's going an endless loop "Found New Hardware: PCMCIA IDE/ATAPI Controller"->pop up a window "there's a problem installing this hardware"....never ends

Anybody had this problem before and how to fix it? TIA

edit: same thing with my Kingston elite pro CF card. I must miss something there.
xjqian
Ok, The problem is associated with using the PCMCIA CF card adaptor. It's always working fine before. Strange unsure.gif

I can use an USB card reader without problem. I even formated under windows from the usb card reader. But the problem is still there when using the pcmcia adaptor to read the card.
V-Man
I had the same problem with a CompUSA PCMCIA CF card reader. Part number ADT-N-FS. It works just fine on some machines and not on others. I have never gotten it to work with linux. I gave it to my wife since it worked perfectly on her laptop (until she broke her laptop). Now I have it back. It seems to work about 80% of the time on my laptop. Anyone else had something like this happen to them too?
xjqian
My concern is wether formating to ext2 causes info. loss (maybe something like pcmcia standard card id, etc.) on the CF card, since my cards all worked fine in the stock fat form. Seems to me even though i formatted the card back to vfat later, that info is lost or written wrong somehow, anybody knows? Or maybe the problem is associated with certain version of fdisk or mkfs.msdos/mkfs.vfat? Somebody more tech savvy on the pcmcia stuff, please enlighten me.

btw, pcmcia cf adaptor is more convenient than the usb card reader for me because of the small footprint. i can toss it into my shirtpocket without any bulge. my adaptor is from Viking components, if it matters, which I used for years without a glitch. However, I think it's just a dummy pin converter. The real problem is associated with the pcmcia controller on the motherboard of my laptop, which was unable to read the card after formating.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.