Help - Search - Members - Calendar
Full Version: Cacko 1.22 Problems
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Sharp ROMs
rikiya
Hi, I use the Cacko 1.22 on my 860, and I have 2 problems. First is that the battery doesn't charge fully, or something and my zaurus shuts down automatically even after charging for a whole night. Second, I cannot install any packages and get the error "ipkg says something went wrong. Sorry".

Any help?
wmadan
QUOTE(rikiya @ Mar 29 2005, 03:02 PM)
Hi, I use the Cacko 1.22 on my 860, and I have 2 problems. First is that the battery doesn't charge fully, or something and my zaurus shuts down automatically even after charging for a whole night. Second, I cannot install any packages and get the error "ipkg says something went wrong. Sorry".

Any help?
*


Go to the cacko web site at cacko.biz and look at the FAQ with regard to your ipkg problem.
waalkman
As for the battery:

http://www.oesf.org/forums/index.php?showt...ce+menu+battery

Beware, there be dragons there...


As for your ipkg problems:

go to /usr/lib/ipkg and find the status file. Open it in an editor and remove the line near the end that is causing all of the trouble.

Actually, it would be a good idea to run ipkg from the command line to see exactly what the problem is, but I'm guessing that it is getting hung up on an incompletely installed package.

The command line for ipkg should be:

"ipkg install package"

Where "package" would be the name of the actual package.

You might need to either elevate yourself to root or return to user depending on what package you are installing.

"su" takes you to root (look for the "#" prompt)
"su zaurus" makes you a regular user ("$" prompt)
pelrun
The "premature shutdown" issue may just be that the Z is turning off the screen - the SharpROM(and Cacko by extension) has a bug in it that shuts off the screen if the backlight is on minimum and auto-dim is on. I've also had it happen the instant I've hit a key after leaving it alone for a short while.

Next time it occurs don't hit the power button, try hitting Fn+4 instead to turn up the backlight. This usually turns the screen back on immediately for me.
rikiya
Yes, pelrun I think thats it, and thanks to wmadan and waalkman for the help, I will go and try now.
rikiya
xlibs_4.3.0-3_arm.ipk, returning
ipkg_get_install: Perhaps you need to run `ipkg update'?



Any ideas?
matrix
QUOTE(rikiya @ Mar 31 2005, 03:06 AM)
xlibs_4.3.0-3_arm.ipk, returning
ipkg_get_install: Perhaps you need to run `ipkg update'?



Any ideas?
*



this happens when ipkg is trying to install a package it can't find, which often happens if you tagged a package to install in add/remove programs and something stopped it (user cancel, crash, etc)

you can try an ipkg update followed by an ipkg upgrade while the network is up to see if it can grab the package, or grab that xlibs package and install it manually.

if you don't care about xlibs or still have issues, run from the command line:
ipkg remove xlibs

that may remove xqt or any other packages you may have installed which depend on xlibs. you can always reinstall them later. this tells ipkg to remove xlibs which is in a bad state and forget about it
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.