Help - Search - Members - Calendar
Full Version: Ipkg-utils-native-1.6 Build Failed!
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Open Embedded
lixiaosan
when I use "bitbake bootstrap-image", I get error like this:

NOTE: package ipkg-utils-native-1.6cvs20050330: started
NOTE: package ipkg-utils-native-1.6cvs20050330-r4: task do_fetch: started
NOTE: package ipkg-utils-native-1.6cvs20050330-r4: task do_fetch: completed
NOTE: package ipkg-utils-native-1.6cvs20050330-r4: task do_patch: started
NOTE: Applying patch 'fix-ipkg-link'
ERROR: function do_patchcmd failed
ERROR: log data follows (/stuff/openembedded/tmp/work/ipkg-utils-native-1.6cvs20050330-r4/temp/log.do_patchcmd.20338)
| Replacing patch fix-ipkg-link with new version
| Applying patch fix-ipkg-link
| patching file ipkg-link
| Hunk #1 FAILED at 18.
| Hunk #2 FAILED at 48.
| Hunk #3 FAILED at 57.
| 3 out of 3 hunks FAILED -- rejects in file ipkg-link
| Patch fix-ipkg-link does not apply (enforce with -f)
NOTE: Task failed:
NOTE: package ipkg-utils-native-1.6cvs20050330-r4: task do_patch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package ipkg-utils-native-1.6cvs20050330: failed
ERROR: Build of bootstrap-image failed

what 's wrong with the patch file or some other error ?
lardman
When did you last update your openembedded repository - perhaps ipkg-link has been changed in CVS and the patch is no longer required.

Other than that I'd post to the mailing list,


Si
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.