Help - Search - Members - Calendar
Full Version: Kapm-idled
OESF Forums > General Forums > Desktop Operating Systems Issues > Linux Issues
Meanie
I just installed top and was really surprised to find kapm-idled sitting at the top of the list chewing up 11% CPU when the system is idle (which I think is bad enough), however, when I use musicplayer it goes up to 74% sad.gif
Anyone know why this is happening? Is this normal? This is on a C3000
Mickeyl
Yeah, this is a 2.4-(embedix) kernel issue. Can't really do anything about it, but upgrade to a better kernel, i.e. 2.6.
Stubear
Actually kapm-idled should be using around 98% when you system is idle and this should drop when your apps start using cpu cycles.

I think you must have gotten the figures mixed up (unless your version of top is showing something weird).

kapm-idled is the idle time daemon in kernel 2.4.x. It runs when the processor is not doing anything and calls the idle/call instructions to cool the processor/slow the processor/save battery. (XP and possibly W2K also have a similiar process running)

So the less work your system is doing the higher the value of kapm-idle should be. The 2.6 kernels have hidden this away so that it doesn't show up in top or other cpu% programs and alarm people.

Don't worry about kapm-idled - it's not eating your cpu cylces, its helping cool the Z when its resting. You can't get rid of it (except by changing kernels, which I don't think is an option yet for the C3k)

Stu
Meanie
Your explaination makes a lot of sense. Thanks a lot. I will try another version of top to see if it gets better output or just don't look at it anymore smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.