Help - Search - Members - Calendar
Full Version: Compiling Xmms?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
emjaybee
So I've been tinkering with compiling software on my 860 yesterday. I thought I'd start with xmms since the install is a basic ./configure && make && make install. I started out by removing the xmms-related ipks so ./configure wouldn't complain that I have a version installed. make worked fine with no errors, but make install compiles a few more things and fails:

CODE
 -c -o controlsocket.o `test -f 'controlsocket.c' || echo './'`controlsocket.c; \
then mv -f ".deps/controlsocket.Tpo" ".deps/controlsocket.Po"; \
else rm -f ".deps/controlsocket.Tpo"; exit 1; \
fi
gcc: Internal error: Terminated (program cc1)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[3]: *** [controlsocket.o] Error 1
make[3]: Leaving directory `/mnt/card/home/root/xmms-1.2.10/xmms'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/mnt/card/home/root/xmms-1.2.10/xmms'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/mnt/card/home/root/xmms-1.2.10/xmms'
make: *** [install-recursive] Error 1


df -h says I have plenty of free space left on my internal flash as well as on my sd card, I have gcc.img mounted as the documentation said, and I know I'll have to install xmms-mad to play mp3s, but I don't know why ./configure ran just fine as well as make and make install wants to be stubborn. Anything I'm missing when trying to compile source right on the Z?
pgas
maybe you run out of ram (try it again in the console without X)?
maybe your cf is formatted as fat and this causes problem?
maybe there was a reading/writing problem with the card?
maybe there is a bug in gcc wink.gif ?
emjaybee
I tried it without having X running and it worked just fine. Thanks pgas!
omega
good stuff. What you need is a swap file...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.