Help - Search - Members - Calendar
Full Version: The Qt Included In Kopsis Python Is Out Of Date
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Python
jeffbarish
The version of Qt included in the kopsis package is 2.3.2. The current version is 3. I am trying to get a multithreaded PyQt application to work, but it seems that support in 2.3.2 for what I need to do (involving custom events) is deficient. Would it be possible for kopsis to release a new python image with a current version of Qt? Would it work for me simply to replace the Qt libraries (qt.so, qtcanvas.so, qtnetwork.so, qtpe.so, qttable.so) and perhaps also pyqtconfig.py in the ext2 image? If so, where do I find the necessary files?

Another approach might be to switch to the Python for arm feed, but people seem to be having trouble getting it to work on the Sharp ROM. In any case, I don't know that it includes a current version of Qt.
iamasmith
QUOTE(jeffbarish @ Apr 7 2005, 04:10 PM)
The version of Qt included in the kopsis package is 2.3.2.  The current version is 3.  I am trying to get a multithreaded PyQt application to work, but it seems that support in 2.3.2 for what I need to do (involving custom events) is deficient.  Would it be possible for kopsis to release a new python image with a current version of Qt?  Would it work for me simply to replace the Qt libraries (qt.so, qtcanvas.so, qtnetwork.so, qtpe.so, qttable.so) and perhaps also pyqtconfig.py in the ext2 image?  If so, where do I find the necessary files?
*


That's because libqte on the Zaurus is v2 and not v3.... and no don't replace the qt libraries.. you WILL break Qtopia.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.