Help - Search - Members - Calendar
Full Version: Note: Task Failed: Fetch Failed: Quilt
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Open Embedded
noha
I started yesterday to install openembedded according to the Wiki::GettingStarted.

When I try to build anything with bitbake it doesn't succeed. If I try to build nano I get the following:
(using bitbake -D -D -D nano)

NOTE: fetch http://www.treke.net/oe/source/quilt_savan...ER_0_39_.tar.gz
DEBUG: Fetch: checking for module directory
NOTE: Fetch cvs://anoncvs:@savannah.nongnu.org/cvsroot/quilt;method=ext;rsh=ssh;module=quilt;tag=VER_0_39
DEBUG: mkdirhier(/home/slug/sources/cvs/quilt-native)
DEBUG: created /home/slug/sources/cvs/quilt-native
DEBUG: Running CVS_RSH="ssh" /usr/bin/env cvs -d:ext:anoncvs@savannah.nongnu.org:/cvsroot/quilt co -r VER_0_39 quilt
NOTE: Task failed: Fetch failed: quilt
NOTE: package quilt-native-0.39-r0: task do_fetch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package quilt-native-0.39: failed
ERROR: Build of nano failed

It don'tt know where the problem could be. Invoking the command

CVS_RSH="ssh" /usr/bin/env cvs -d:ext:anoncvs@savannah.nongnu.org:/cvsroot/quilt co -r VER_0_39 quilt

succeeds. Afterward I can retry building bitbake -D -D -D nano. Then I get the following.

NOTE: fetch http://www.treke.net/oe/source/quilt_savan...ER_0_39_.tar.gz
DEBUG: Fetch: checking for module directory
NOTE: Update cvs://anoncvs:@savannah.nongnu.org/cvsroot/quilt;method=ext;rsh=ssh;module=quilt;tag=VER_0_39
NOTE: Task failed: Fetch failed: quilt
NOTE: package quilt-native-0.39-r0: task do_fetch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package quilt-native-0.39: failed
ERROR: Build of nano failed

It doesn't depend on the package I try to build. I assume that it isn't the cvs task which fails. As I am knew to openembedded I have no idea what is going wrong. Is there chance to debug even more?


I am using an up to date gentoo ~x86 system.

thanks,

Norbert
spongeman66
I seem to be having exactly the same problem.
Anybody have any suggestions?

I also have a fresh copy of Gentoo...

Thanks!
Sponge
lardman
Quilt is a patch manager iirc, it's required by OE (so will be downloaded & built much like the toolchain is).

Not sure why you can't get it atm, but perhaps the server is busy?


Si
Mickeyl
FWIW, I like patcher better and always suggest

echo 'INHERIT += patcher' >>conf/local.conf

This also "fixes" the quilt problem biggrin.gif
koen
QUOTE(Mickeyl @ Aug 31 2005, 10:20 AM)
FWIW, I like patcher better and always suggest

echo 'INHERIT += patcher' >>conf/local.conf

This also "fixes" the quilt problem biggrin.gif
*


I'd appreciate someone looking in to this problem instead of using nondefault hacks (enabling patcher)

/me also hints at http://bugs.openembedded.org
spongeman66
QUOTE(Mickeyl @ Aug 31 2005, 05:20 AM)
FWIW, I like patcher better and always suggest

echo 'INHERIT += patcher' >>conf/local.conf

This also "fixes" the quilt problem biggrin.gif
*


I tried this inside the firewall where I work, and I now get a similar problem retrieving patcher...
It may be a firewall issue, or more likely, I have something setup wrong....
I will try from home soon...

Is there any specific setup I need for BitBake? It 'says' it completes the download, but complains about null.
Here is the original Quilt failure (outside the firewall):
CODE
OE Build Configuration:
TARGET_ARCH   = "arm"
TARGET_OS     = "linux"
MACHINE       = "collie"
DISTRO        = "openzaurus"
TARGET_FPU    = "soft"

DEBUG: providers for update-modules are: ['update-modules']
DEBUG: selecting /zaurus/openembedded-oz3.5.3/packages/update-modules/update-modules_1.0.bb to satisfy update-modules
NOTE: current path: update-modules (update-modules)
NOTE: dependencies for update-modules are: ipkg-utils-native quilt-native virtual/arm-linux-gcc virtual/libc
DEBUG: providers for ipkg-utils-native are: ['ipkg-utils-native']
DEBUG: selecting /zaurus/openembedded-oz3.5.3/packages/ipkg-utils/ipkg-utils-native_1.6cvs.bb to satisfy
ipkg-utils-native
NOTE: current path: update-modules (update-modules) -> ipkg-utils-native (ipkg-utils-native)
NOTE: dependencies for ipkg-utils-native are: quilt-native
DEBUG: providers for quilt-native are: ['quilt-native']
DEBUG: selecting /zaurus/openembedded-oz3.5.3/packages/quilt/quilt-native_0.39.bb to satisfy quilt-native
NOTE: current path: update-modules (update-modules) -> ipkg-utils-native (ipkg-utils-native) -> quilt-native
(quilt-native)
NOTE: dependencies for quilt-native are:
NOTE: package quilt-native-0.39: started
DEBUG: Executing task do_fetch
DEBUG: update_data()
NOTE: package quilt-native-0.39-r0: task do_fetch: started
DEBUG: update_data()
DEBUG: BUG init called with None as data object!!!
NOTE: package quilt-native-0.39-r0: task do_fetch: completed
DEBUG: Executing task do_unpack
DEBUG: update_data()
NOTE: package quilt-native-0.39-r0: task do_unpack: started
DEBUG: update_data()
NOTE: Unpacking /zaurus/sources/quilt_savannah.nongnu.org_VER_0_39_.tar.gz to /var/tmp/oetmp/work/quilt-native-0.39-r0/
tar: /zaurus/sources/quilt_savannah.nongnu.org_VER_0_39_.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
NOTE: Task failed:
NOTE: package quilt-native-0.39-r0: task do_unpack: failed
ERROR: TaskFailed event exception, aborting
NOTE: package quilt-native-0.39: failed
ERROR: Build of update-modules failed


Thanks for your time!
Sponge
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.