Help - Search - Members - Calendar
Full Version: Zaurus Package Naming Convention
OESF Portables Forum > General Forums > General Discussion
Storm
Hi,

As a Zaurus newbie but long-time Linux user (10 years using Linux, 5 years Debian maintainer), I have run into something that I think others might appreciate. In Debian, we use a naming convention of <package>_<version>-revision_arch.deb, for instance,

xscreensaver_4.21-1_i386.deb
xscreensaver_4.21-1_ppc.deb
xscreensaver_4.21-1_sparc.deb
etc...

I think that with all of the different ROMS and at least two or three sets of hardware (Zaurus, Ipaq, perhaps the new Archos), the Zaurus/ARM community should consider a similar convention. I have had a number of package/ROM/UI mismatches which have led to some heartache. I think that it would be cool if you could adopt a Debian-like naming convention, like <pkgname>_<version>_<ROM/hw>_<arch/UI>.ipk, e.g.

opera_7.55.7069_sharp_opie.ipk
konqueror_20040321_oz_opie.ipk
etc.

Thoughts?
--Storm
lareya
I second that! I think there are a lot of confusion in what runs what. But I am just a noob - so what do I know!?!

Lareya
Hrw
OpenZaurus packages are located in OZ feeds. When someone build software outside OZ then naming of package is his own decission.

In OpenEmbedded (so in OZ, Familiar and other OE based distros) we have simple naming:

<packagename>_<version>-<revision>_<arch>.ipk

it does not have sense to use "arch/UI" as some packages can be used under console or opie etc.. And each value in "arch" field must be added into ipkg configuration..

BTW - in OE we use "r<number>" for revision field.
Storm
QUOTE(Hrw @ Apr 13 2005, 04:21 AM)
OpenZaurus packages are located in OZ feeds. When someone build software outside OZ then naming of package is his own decission.

In OpenEmbedded (so in OZ, Familiar and other OE based distros) we have simple naming:

<packagename>_<version>-<revision>_<arch>.ipk

it does not have sense to use "arch/UI" as some packages can be used under console or opie etc.. And each value in "arch" field must be added into ipkg configuration..

BTW - in OE we use "r<number>" for revision field.
*

HRW,

I was suggesting a naming differentiation between packages of for platforms of different types. The specifics of this differentiation is not set in stone, this thread was meant to open discussion. Since the documentation is scattered and somewhat disjointed, and for someone coming to the Zaurus for the first time, especially a non-Linux person, it can be difficult to differentiate packages.

It was a suggestion, nothing more, nothing less. Obviously, as a package manager, the option is yours, but I think it would help.

--Storm
lardman
This has been being discussed for aeons. There are probably a couple of old threads in this forum and there were certainly some on the devnet.

Despite the ideas we had before, nothing has ever been done (and the main issue is that people just don't bother following the rules, or that people would have to re-name existing packages).


Si
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.