Help - Search - Members - Calendar
Full Version: Kernel2.6 And Syncing
OESF Forums > General Forums > Desktop Operating Systems Issues > Linux Issues
thechris
All the howtos are outdated and have been outdated for a while. How do i adapt the 2.4.20 stuff for the newer 2.6.12 kernel?

also, any links or info on howto set up the zaurus -- gentoo linux connection? i have the USB cradle plugged in. that is all so far.
Stubear
There have been reports of problems with the latest 2.6 kernels and usb support for zaurus.

Not sure if it effects 2.6.12, but it definetly effects 2.6.11.

I'm using gentoo with 2.6.10 currently and all I have to do is plug my zaurus (c760) into the desktop for my Z to show in dmesg.

I added
CODE
# Zaurus Usbnet
alias usb0 usbnet
to /etc/modules.d/aliases so that it automagically loads usbnet when I plug in the Z.

I also created a file called usbnet in /etc/hotplug/usb which calls ifconfig to bring up usb0 and adds the Z's ip address as a host

Then I just scp or ssh to the Z

Stu
bender647
QUOTE(Stubear @ Apr 21 2005, 08:20 AM)
There have been reports of problems with the latest 2.6 kernels and usb support for zaurus.

Not sure if it effects 2.6.12, but it definetly effects 2.6.11.


USB support for some Zaurii was broken in 2.6.11. The Sharp Rom and SL-5600 was definitely affected (usbnet no longer binds to ethernet adpater).

I submitted a patch that will fix at least SL-5600 with Sharp Rom in 2.6.12.
Hrw
my collie/2.4.18 and husky/2.6.11 both works with usbnet under 2.6.11-rc3, 2.6.11-rc4, 2.6.11, 2.6.12-rc2, 2.6.12-rc2-mm3 without tweaks in /etc/hotplug/ other places (I have usbnet in kernel not in module)
melee
QUOTE(Hrw @ Apr 26 2005, 07:53 PM)
my collie/2.4.18 and husky/2.6.11 both works with usbnet under 2.6.11-rc3, 2.6.11-rc4, 2.6.11, 2.6.12-rc2, 2.6.12-rc2-mm3 without tweaks in /etc/hotplug/ other places (I have usbnet in kernel not in module)
*

Stock Sharp ROMs

The problems encountered with kernel 2.6.11 continue in kernel 2.6.12rc4, despite a changelog that appears to say it is fixed.

I have compiled 2.6.10 , 2.6.11-6 and 2.6.12rc4 just recently and 2.6.10 is the only one which appears to work with my C860 with Sharp ROM

There is actually a specific driver under the USB section in 2.6.10 for Sharp ROM Zaurus 5600 etc.

However further testing of the 2.6.10 kernel showed problems too!
The usb0 interface came up bound to ethernet but ifconfig printout showed packet errors
Could ping the Z ok and ssh worked for browsing its directories.
When I tried sftp for file transfers it failed part way through each time.

The docs suggest that Sharp have used various proprietory lash ups to get USB networking which dont meet standards.

OpenZaurus have presumably written their code to the standards so dont have the same problems.

Back to the good old 2.6.3-7 kernel (MDK10) or flash the OZ ROM at present it seems

regards

Melee
melee
Hi - further to last

Done some more experimenting and things get worse.

Through a combination of factors, I do not use sftp for more than light transfers - say 1 - 2 MB max (a heavy .ipk file)

When I have transferred movies up to 260 MB in size for instance, I switch the Zaurus PC Link off and switch it to USB Storage then just mount it as a SCSI drive (/dev/sri on my system) and make transfers in seconds to CF or SD.

Because of the failures I experienced using sftp for transfers under kernel 2.6.10 I repeated the tests under 2.6.3-7

When I increased the file sizes above about 2MB I started getting failures, with the transfer stalling part way and never continuing.
The exact point at which the transfer fails is not uniform, try to tranfer 2MB and it might stop at 800K, try to transfer 250 MB and it might get to 82MB before failure

I have never been able to get the fish:// protocol working for large transfers despite installing perl on the Z, that always failed part way through.

I can attach usb0 no problem, use ssh and get full control of the Z for deleting, renaming, transferring data internally etc etc

sftp works fine in 'put' mode with smaller files and is very fast
I haven't tested the limits, but appears to 'get' much larger files from the Z without problems, than it will 'put'. sftp buffer size does not make any difference to failure.

So, kernel 2.6.10 is not defective, or at least not any more than 2.6.3-7

Does anyone have any ideas what is wrong

Do some tests, what can you transfer to your Z with sftp without problems and on which kernel and to which Z OS?

regards

Melee
melee
A POSTSCRIPT

All the previously reported problems regards sftp uploads are down to the USB I/O

As different ROM users do not report such problems :-
QUOTE
(Hrw @ Apr 26 2005, 07:53 PM)
my collie/2.4.18 and husky/2.6.11 both works with usbnet under 2.6.11-rc3, 2.6.11-rc4, 2.6.11, 2.6.12-rc2, 2.6.12-rc2-mm3 without tweaks in /etc/hotplug/ other places (I have usbnet in kernel not in module)

one has to conclude, that as suspected, the problem is Sharps flakey non-standard implementation of USB.

The proof came to me when I aquired Broadband and decided to buy a Netgear DG834G wired / wireless router with ADSL modem and firewall built in. I had a Netgear MA701GE WiFI card already which came bundled with my C860.

The difference is staggering.
The Z recognises the card and prompts to connect immediately.
I can use sftp to upload whatever size files I like.
I can load the Z directory structure from the commandline within Midnight Commander and make direct file transfers either way.
I can even open the Z in both panes and transfer between, which is actually a 2 way transfer with data returning to the workstation and then back to the Z again.
Konqueror works properly doing the same and doesn't fall over part way through.
The fish protocol works too.
Best of all I can connect on Broadband using Opera from anywhere in the house and half way down the garden! (its a big garden).

My advice to all you cable slaves, cut them and go wireless. There is no comparison.

regards

Melee
ev1l
I've had the same troubles with file transfers over USB when I used sftp. I use a wireless card now, and a USB 2.0 card-reader for really big files.
obergix
Running OZ 3.2.3 on a SL-C1000 and Debian testing with 2.6.11-1-k7 debian kernel on the PC.

When modprobing usbnet on the PC, no usb0 appears in ifconfig -a sad.gif

So I suspect I ran into the same bug...
7_feet_up
You're not the first one to notice. Please read this topic.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.