Help - Search - Members - Calendar
Full Version: Can't Connect To Internet?
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > X/Qt
ArchiMark
Got X/Qt with Debian up and running, except for one big problem....
I can't get connected to internet yet... blink.gif

I can connect when in Qtopia and can surf OK using NetFront browser....using Socket CF Ethernet card to connect to network.

I do get a message when I start up dillo in aterm window:

Gdk-WARNING**: Locale not supported by C library.
Setting locale to C.....

Then dillo opens up....

When I do try to connect with a webpage, for example;
I get message at bottom of Dillo browser window:

ERROR: Dns can't solve www.google.com

I do see a little tiny black square in lower right corner of iceWM statusbar at bottom of my display that 'pulsates' graphically when it's trying to connect, before I get error message.

Also, I did copy over 'resolv.conf' file to /mnt/card/debroot/etc.....

Do I need to change nameserver shown in that file?

If so, could someone explain what that is or is it the same as one of the items below?

IP Address: xx.xxx.xx.xx (DHCP)

Subnet Mask: 255.255.255.0

DNS Server: xx.xxx.xx.xxx xx.xxx.xx.xxx

Default Gateway: xx.xxx.xx.x

Thanks for any help with this!

Really need to get connect soon!


Mark
adf
hmmm
the resolv.conf copy has worked for me.

You are online with netfront...copy over reslov.con, and wile still keeping the connection open in qtopia, you can't connect from debian? Is this correct?

Have you tried ifup from a commandline in debian? (with the network down, of course)

Or have you typed in ifconfig in debian? That might give you useful info.
ArchiMark
Thanks for your help as always, adf!

Just thought it would be good to make a separate thread as the other was getting so long and this seems like a more specific topic within the overall subject... rolleyes.gif

Anyway.....

QUOTE(adf @ Apr 22 2005, 01:31 PM)
hmmm
the resolv.conf copy has worked for me.

You are online with netfront...copy over reslov.con, and wile still keeping the connection open in qtopia, you can't connect from debian? Is this correct?


-Yes, I can get online with NetFront OK.

-I already had copied over 'resolv.conf' to /mnt/card/debroot/etc.

However, do I keep the nameserver info as is, or do I need to change?

-I keep the connection open in Qtopia, BUT I can't connect from Debain...

QUOTE
Have you tried ifup from a commandline in debian? (with the network down, of course)


Haven't tried that, but will later....

QUOTE
Or have you typed in ifconfig in debian? That might give you useful info.


I think I tried that....I think....if I'm correct, I think I got:
ifconfig: not found

or something like that...but will try again later to make sure....


Thanks,

Mark
ArchiMark
OK, tried your suggestions....

Tried 'ifup' but don't understand what <ifaces...> it asks for:

CODE
ifup <options> <ifaces...>


Tried 'ifconfig' and got the following:
CODE
ifconfig Warning: Cannot open /proc/net/dev (No such file or directory). Limited output.


Any suggestions??

Also, what about my previous question about specifying correct nameserver in 'resolv.conf'?

THANKS,

Mark

QUOTE(adf @ Apr 22 2005, 01:31 PM)
hmmm
the resolv.conf copy has worked for me.

You are online with netfront...copy over reslov.con, and wile still keeping the connection open in qtopia, you can't connect from debian? Is this correct?

Have you tried ifup from a commandline in debian? (with the network down, of course)

Or have you typed in ifconfig in debian? That might give you useful info.
adf
Putting in the right nameserver might do it. smile.gif

you would be doing ifup "whatever your network device is called" --ie wlan0

try --in debian--doing ps -A (asking for a list of running processes)
debian will tell you to make a link (I think) and tell you exactly how to do it
ArchiMark
QUOTE(adf @ Apr 22 2005, 09:53 PM)
Putting in the right nameserver might do it. smile.gif


That did it, adf!

Got online right after that!!

QUOTE
you would be doing ifup "whatever your network device is called" --ie wlan0


Tried that, got message:
CODE
Ignoring unknown interface wlan0=wlan0


QUOTE
try --in debian--doing ps -A  (asking for a list of running processes)
debian will tell you to make a link (I think) and tell you exactly how to do it


Tried that, got message:
CODE
Error do this: mount -t proc none /proc
#mount -t proc none /proc
Warning: Can't open /etc/fstab: No such file or directory


Decided for better or worse, to press on, since I can get online now....so did
CODE
#apt-get update
after that finished...
#apt-get upgrade
preconfiguring packages
50MB dowloaded later........

usr/bin/locale: cannot set LC_TYPE to default locale: No such file or directory
usr/bin/locale: cannot set LC_MESSAGES to default locale: No such file or directory
usr/bin/locale: cannot set LC_TYPE to default locale: No such file or directory


Then Debian Config window popped up and got through about 6 items...then I seemed to have
hit wrong key and window closed, think there's still more to go....

Now, I see in aterm window, items are being unpacked then setup and then it goes on to next item.....

So on my way, right???..... rolleyes.gif

But if you have any suggestions...Please let me know!

THANKS!!!!

Mark
perseus
Could someone help me connect my wireless card with debian?

I have the same problem as ArchiMark. I cannot get connected. I edited resolv.conf with : nameserver (then my dns numbers).

It still does not work?

I am running cacko 3kb1, C3000, x/qt debian on hdd3 with loop and swap, per meanie's site, asus wireless card.

Thanks.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.