Help - Search - Members - Calendar
Full Version: Sync Problem
OESF Forums > General Forums > General Support and Discussion > Software
david_dahan
Dear All,

I am trying to establish synchronization between my Linux desktop (SuSe 9.2) and my Caco rom based SL-C750 PDA.
I have installed kdepim-pi in the desktop and in the C750 . I followed the 'Sync HowTo Zaurus <-> KDE' instructions in http://pi-sync.net/ .
I'm in the stage of creating the /etc/sysconfig/network/ifcfg-usb0 file (USB0 was registered) :
# usbX config for Zaurus
IPADDR='192.168.168.252'
NETMASK='255.255.255.0'
NETWORK='192.168.129.0'
BROADCAST='192.168.129.255'
STARTMODE='hotplug'

- My desktop IPAddress is 192.168.168.252 (DHCP assigned)

I do not know what addresses to put in NETWORK and BROADCAST , can you please guide me finding the right addresses .

(I tried the above addresses and the following : NETWORK='192.168.168.0' , BROADCAST='192.168.168.255' but failed )

--
thanks,
David
zenyatta
QUOTE(david_dahan @ Apr 22 2005, 06:03 PM)
IPADDR='192.168.168.252'
NETMASK='255.255.255.0'
NETWORK='192.168.129.0'
BROADCAST='192.168.129.255'
STARTMODE='hotplug'

Your desktop's DHCP-assigned address is not relevant here. When the USB connection to your Zaurus activates, an additional network interface is normally set up automatically. You can check this by running 'ifconfig' on the command line when Zaurus is connected to the PC. You should see three entries: lo, eth0 and usb0.

The usb0 interface will probably have an address in the 192.168.129.* range - hence the setup you describe is correct except for the IPADDR which should be 192.168.129.252.

Hope this helps,
z.
david_dahan
QUOTE(zenyatta @ Apr 23 2005, 08:29 AM)
QUOTE(david_dahan @ Apr 22 2005, 06:03 PM)
IPADDR='192.168.168.252'
NETMASK='255.255.255.0'
NETWORK='192.168.129.0'
BROADCAST='192.168.129.255'
STARTMODE='hotplug'

Your desktop's DHCP-assigned address is not relevant here. When the USB connection to your Zaurus activates, an additional network interface is normally set up automatically. You can check this by running 'ifconfig' on the command line when Zaurus is connected to the PC. You should see three entries: lo, eth0 and usb0.

The usb0 interface will probably have an address in the 192.168.129.* range - hence the setup you describe is correct except for the IPADDR which should be 192.168.129.252.

Hope this helps,
z.
*



Now I can ping the C750 from my desktop , but I can not ping my Linux desktop (192.168.129.200) from my C750.
I am able to synchronize the calendar only from my desktop and I'm not able to do it for KA/PI .

I have created /etc/sysconfig/network/ifcfg-usb0 file (USB0 was registered) as the following :
# usbX config for Zaurus
IPADDR='192.168.129.200'
NETMASK='255.255.255.0'
NETWORK='192.168.129.0'
BROADCAST='192.168.129.255'
DEVICE=usb0

The latest KDE-PIM/pi version were installed .

Thanks,
David.
zenyatta
That's strange. Pinging means you can route packages both ways, so it should work. Can you run 'netstat -rn' on Zaurus and post the output?

z.
david_dahan
QUOTE(zenyatta @ Apr 24 2005, 08:42 AM)
That's strange. Pinging means you can route packages both ways, so it should work. Can you run 'netstat -rn' on Zaurus and post the output?

z.
*


This is the output of netstat -n :
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.129.0 0.0.0.0 255.255.255.0 U 40 0 0 usbd0

thanks,
David.
speculatrix
QUOTE(david_dahan @ Apr 24 2005, 02:11 AM)
Now I can ping the C750 from my desktop , but I can not ping my Linux desktop (192.168.129.200) from my C750.
I am able to synchronize the calendar only from my desktop and I'm not able to do it for KA/PI .


sounds like you have firewalling enabled.

try, on the desktop, as root

"iptables -I INPUT -s 192.168.129.0/24 -d 0/0 -j ACCEPT"

and see if that fixed the ping and the sync.
david_dahan
QUOTE(speculatrix @ Apr 24 2005, 08:14 PM)
QUOTE(david_dahan @ Apr 24 2005, 02:11 AM)
Now I can ping the C750 from my desktop , but I can not ping my Linux desktop (192.168.129.200) from my C750.
I am able to synchronize the calendar only from my desktop and I'm not able to do it for KA/PI .


sounds like you have firewalling enabled.

try, on the desktop, as root

"iptables -I INPUT -s 192.168.129.0/24 -d 0/0 -j ACCEPT"

and see if that fixed the ping and the sync.
*



Thanks , Now it is woring . I have ping in both directions and able to sync KA/pi and KO/pi .
Appreciate your help .

cheers,
David.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.