Help - Search - Members - Calendar
Full Version: Pygtk2 For X/qt-debian On C3000?
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Python
ArchiMark
Posted something in the X/Qt section, but thought it might be good to ask here since this relates to Python (I think.. rolleyes.gif )....

Installed X/Qt - Debian on my C3000. Using IceWM. When I tried installing a GUI app for managing prefs and themes for IceWM, it said that I needed to install PyGtk2.

So is there a way to install PyGtk2 on my Z in the X/Qt-Debian setup?

Thanks for any suggestions!

Mark
Elleomea
Try: apt-get install python-gtk2
ArchiMark
Thanks a lot for pointing me in the right direction, Ellomea!

That did it!....

Although after installing PyGtk2 and then trying to install IceWMControlPanel, I get a bunch of error messages from PyInstallShield.... blink.gif

Oh well...

Mark
ArchiMark
Here's the error messages I get when I tried to install IceWMControlPanel:
CODE
zaurus:/INSTALL-ICEME# ./INSTALL-ME.sh
./PyInstallShield: 214: DepreciationWarning: use gtk.UIManager
itemf=ItemFactory(MenuBar,"<main>", ag)

./PyInstallShield: 249: Warning: unsupported arithmetic operation for flags type table1.attach( Label(_("Installation Directory:")) ,0,1,0,1,(EXPAND+FILL),(EXPAND+FILL),0,0

Traceback (most recent call last):
File "./PyInstallShield", line 1464, in ? Runbabel()

File "./PyInstallShield", line 1464, in runbabel mybabel=installwin()

File "./PyInstallShield", line 249, in __init__ table1.attach ( Label (_("Installation Directory:")) ,0,1,0,1,(EXPAND+FILL),(EXPAND+FILL),0,0

Type Error: flag values must be strings, ints or tuples


Do these messages relate to trying to install on a C3000 or ??

Any suggestions??

Mark
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.