Help - Search - Members - Calendar
Full Version: Guylhem Rom: First Qtopia 1.5 Release
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Guylhem Rom
Pages: 1, 2, 3
guylhem
Hello

The first "end user ready" release is being uploaded. It features a nice GUI and should work out of the box (no command line special knowledge should be necessary)

Get it on: http://externe.net/zaurus/guylhem-rom/

The only bugs I could find (and honnestly, they are not serious drawbacks) are:
- some remaining keyboard remapping (power/record are used like a jogdial, but should also be able to start applications - they can't yet)
- the network application refuses to add new interfaces. So I replaced the usual netsetup by a different one I compiled and I created a "Get online" icon, which can be used to create a new connection, before using the network application (that's the only if you really want to use the old one called netsetup.old). I have no idea why it doesn't work :-( Trolltech version works fine, Sharp doesn't. Any help would be welcome

If you feel like giving a try, your feedback would be very welcome. What you get :
- a polished qtopia 1.5 rom loaded with applications
- a cleaned filesystem (no symlinks everywhere)
- 24 Mb free to add your own applications (I doubt you'll need them - it's *loaded* with applications, basically every app I use is there, PIM, Hancom, Opera, etc etc.)

What's new since last version :
- added qtopia 1.5 interface
- made sure it worked well
- fixed the zoom/systemtime bugs reported in the standalone qtopia packages.

What's missing :
- special modules used by special card. If you have such a card, please tell me or adf so we can compile your missing module for you

To install it, simply restore the nandbackup. That's all. On reboot, you may see jffs2 errors - that's normal. It's just very verbose. You are presented with a login: if you log in, qtopia won't start. Press home twice to open another console. Press userkey/light to move between consoles. You must log out of every shell so Qtopia may start 30 seconds later. However the keyboard may not be usable if you didn't return to the first console. So if you want to use qtopia, simply don't log in.

Anyway, let's start the beta test ! I'm also preparing a dedicated feed for the ROM. If you have a .ipk that works fine and you think should be interesting to other people, please send me a URL where I can download it and add it to the feed.

If you think some application should be included by default, please tell me too. I'd like to create a "different" rom, very user oriented. Everything should be simple and work out of the box - the apps. I did choose tend to do that.

Guylhem
adf
Getting it now smile.gif this should be excellent.

XQT comes to mind as a much used app that will fit, if it isn't there already.

still messing w/ the pocketworkstation stuff, for those interested. Looks like maybe the fbvnc that I'm using isn't happy. People have sorted this out elsewhere..It shouldn't be too awful.

btw I have space and some badwidth, --I'll start compiling kernels and modules and do a little hosting if you like?
adf
killer splash screen
tree explorer? or advancedfm, maybe?
very snappy.
This is a definite improvement in the way the 6k works, thanks.

I need to go play with it for a while now....
eddiectc
Great rom!
Just tried, very usable!

Now planning to upgrade to Opera7.5
guylhem
Regarding the splash screen - believe it or not but *I* took the pic in the everglades. Really ! Guess why it's got such a big mouth ? I was *that* close :-)

If you have suggestion on opera, etc. [especially if you can provide me with an updated version .ipk where voice stuff works : I tried multiple times but never suceeded ] well I'm quite open.

Regarding treeexplorer, it's not GPL, I don't like it a lot -complex user interface. There must be better software out there.
rip
what a fuck...ing time it should took you for such a job.

great man, thanks for feeding our great 6000

i'll give it a try a soon a possible.

a good, "indispensable" ipk for me is "tipterm" also called "terminal" its a vt100 emulator really simple to use and i use it on a daily basis in my job.
if you don't like treeexplorer, why not a good mc, or all other double panel explorator?

i'll tell you if its really simple to install, if i manage to, so it will be. smile.gif

thanks again guylhem

also if you want to implement bt with cf, it would be great no?
adf
a small issue.

when trying to install packages, small ones go just fine, but big ones (like opera or tree explorer) crash with a no space error in tar. I'm guessing that this has to do with how tmp is allocated. you have a quick fix by any chance?
also,
cf does not seem to auto mount quite right in qtopia 1.5. I suspect tyhis is in fstab. I'll poke at it.. I think it shouldn't be a big deal. it mounts manually. I'll just change the vfat fstpe to auto

I see you have devinmg i.6 set for cf. this work ok if devimg is put there?
guylhem
Hello

rip- it tooks a long long time. A grand total may be ~ 2 to3 weeks, but selfishly I though I had to do it because every rom sucked. I wanted the tool for the job, so I created it myself.

I just hope everybody will like it. vt100? qkonsole should be fine - I tweaked it to use userdef button as a "alt tab". bluetooth shouldn't be a problem either. All my scripts are in /usr/local/bin BTW - adapt them to your needs. It's shipped with bluez 2.16 - the latest version available, and obexftp for cell phone operation (sync, pics...)

I just didn't compile every kernel module possible. Feel free to ask adf, he'll compile them for you (if you know which module your card needs)

adf - regading fstab - oops. I use ext2 on my SD. I will fix that. devimage is not working yet - I've got to fix its paths, etc. It should take a while. Regarding ipkg - oops again. To minimise flash wear, I put /tmp and /var in a ramdisk. It's only 1 Mb that's why it's exhauting. I'll fix that. Meanwhile simply replace /tmp link by a real /tmp when you do an install.
adf
fixed both easily. thnx. gott play around with the kernel this week. atm i'm getting errors in "tools". something unnecessary I thought was interesting, no doubt.

a small nagging issue with a qtopia applet..if you have any insight on it.
inputhelper (and probably, though I haven't tried it the usb mouse applet for the c3k) heeps the
"powerbar" of qtopia on top when using xqt. this seems to me to be something in the applet itself saying "stay on top"

It really needs to be fixed, I think. any ideas? It might just boild down to tweaking the applet a little....
anyone up to trying?

(I'll get to trying it myself eventually, though no guarntees of success..)
eddiectc
the link to get the opera 7.5 http://www14.software.ibm.com/webapp/downl...CBW71&S_CMP=&s=

actually if u untar the ipk, you can get the file opera_arm.ipk, which is actually the opera w/o rubbish, just around 2.3mb.
you can get them here if u like, but i'll remove them later:
http://www.syhk.net/temp/zaurus/opera/multimodal_arm.ipk
http://www.syhk.net/temp/zaurus/opera/opera_arm.ipk

i can install opera_arm.ipk using sharp rom, but failed with Guylhem rom.
maybe i'll test it later

QUOTE(guylhem @ May 8 2005, 01:07 PM)
Regarding the splash screen - believe it or not but *I* took the pic in the everglades. Really ! Guess why it's got such a big mouth ? I was *that* close :-)

If you have suggestion on opera, etc. [especially if you can provide me with an updated version .ipk where voice stuff works : I tried multiple times but never suceeded ] well I'm quite open.

Regarding treeexplorer, it's not GPL, I don't like it a lot -complex user interface. There must be better software out there.
*
gfdsa
opera_sl-5x00-7.30.9965_arm.ipk
installs cleanly, if someone needs it:
http://www.gfdsa.org/~gfdsa/opera_sl-5x00-7.30.9965_arm.ipk
systemparadox
WOW! A ROM for a 6k? I must be dreaming. Well, there is OZ, but I don't class it as usable on a 6k yet.

Are these instructions correct?
http://externe.net/zaurus/guylhem-rom/README
I'm not really very happy about NAND updating.
Why isn't it possible to just use the update menu (hold ok and power on), with initrd, zImage, updater.sh, and possibly a few other files on a cf/sd card?

Thanks
Simon
rip
done straight forward, all stuff works, wifi also with wep key 40 bits
sd formatted in ext 2 recognized fine

could you have a look into this ipk:
http://my-zaurus.narod.ru/memory.html
it works on normal rom and make a swap on ram, sd or cf available till 32 meg and give a status of memory.

thanks a lot guylhem, i'll test it in all possible ways.
kahm
QUOTE(gfdsa @ May 9 2005, 07:32 AM)
opera_sl-5x00-7.30.9965_arm.ipk
installs cleanly, if someone needs it:
http://www.gfdsa.org/~gfdsa/opera_sl-5x00-7.30.9965_arm.ipk
*


Does this version of Opera do the small screen formatting correctly? On every 7.xx version I've seen, save 7.25 from the Cacko feed, the small screen formatting is optimized for the 5x00 series, which just gives you a 240 pixel wide column down the left side of the screen.

I haven't got my 6k yet - but I'll probably be going for this rom when I get it.
rip
pb i think, i cant install anything to sd or cf, it just does not give me any choice. is there anything i missed?

the file manager see all files in cf and sd
and my sd is ext2formatted
ken
Guylhem,

Thought I'd clean up your README file a little. I didn't see an email address in there to send this, so I'm attaching it here.
ken
Bug List (Qtopia GUI):
------------------------------------------------------------
1 - unable to change the Time Zone to other than what's listed. a subsequent reboot then allows the new timezone to show up
2 - SD card not detected (Kingston 512M SD)
3 - note - all your connections/WEP keys etc are listed
4 - new wireless connections with a 128 bit WEP key unable to connect
5 - new wired connections aren't working (shows up, but can't connect)
6 - sharp PIM information is gone (no biggie, just didnt expect it)
7 - removing-inserting CF cards multiple times(ethernet, then modem) caused the Z to hang
8 - creating a new modem connection file complains "Can't create ppp setup file"

most of my data/ipks/etc is on my SD so I was unable to test anything else. On the bright side, it does appear to be snappier. I notice that there are quite a number of useful items on the list.

Observed boot errors:
-----------------------------------------------------------
blkmtd: error: missing `device' name
...
IrCOMM protecol (Dag Brattli)
cramfs: wrong magic
FAT: bogus logical sector size 45147
Eep. Child "ascii-xfr" (ino #1312) of dir ino #1301 doesn't exist!
(it complains zknights.desktop, codepages, p80211.o, QtEmbedded-0.spec, LAN.conf, VPN.conf PAN.conf, DialUp.conf, IRDA.conf, PPPoEW.conf, libpan.so, f, l)
(it also has quite a number of Inode #xxxx was a directory with children - removing those too...)
(then says a bunch of Cannot remove child "xxx", ino #4895, because it doesn't exist (zknights.desktop, ascii-xfr, codepages, QtEmbedded-0.spec, LAN.conf, VPN.conf, PAN.conf, DialUp.conf, IRDA.conf, PPPoEW.conf, libpan.so, f, l, p80211.o)
...
modeprobe: Can't locate module usb_ohci_tc6393
...
pxa_sd_stopclock: clock stop time out. (retries 2x10 times) then gives up
VFS: Can't find ext2 filesystem on dev mmcd(60,1).


Comments:
-----------------------------------------------------------
I suspect a number of those errors are because it can't find the SD card. I also observed that the SD card drivers loaded up just prior to the login prompt. I tried keeping the SD card in, and inserting it after it boots, but no icon for the SD card shows up at the bottom.

Creating a modem connection via the @ Tab, "Get Online" works
Creating a wired/wireless connection via the @ Tab, "Get Online" doesn't connect

rebooting to the console, SD card in.

When I remove the SD card:
pxa_sd_wait_response: card removed (cmd=12)
pxa_sd_wait_response: card removed (cmd=12)
pxa_sd_wait_id_response: card removed (cmd=12)
pxa_sd_wait_id_response: card removed (cmd=12)

When I reinsert the SD card:
pxa_sd_stopclock: clock stop time out. (retry count x) x = total of 10 times
give up!![SD]-clustsize = 4000
mmcda: mmcda1
mmcda:mmcda1
VFS: Can't find ext2 filesystem on dev mmcd(60,1).
mmcda: mmcda1
mmcda:mmcda1
VFS: Can't find ext2 filesystem on dev mmcd(60,1).

(I think it's because it thinks the SD card is ext2 rather than the default fat?)

note: If I drop down to the console, and su, then change the /etc/fstab entry to fat, I'm able to do a mount, but it won't unmount automatically. It will however allow me to read the sd, and the sd icon appears.

sharp's default fstab entres are as follows:

/dev/mtdblock2 / jffs2 ro,noatime 1 1
/dev/mtdblock3 /home jffs2 defaults,noatime 1 2
none /dev/shm tmpfs size=1m,noauto 0 0
/dev/mmcda1 /mnt/card auto noauto,owner 0 0
none /dev/pts devpts gid=5,mode=620 0 0

changing the /dev/mmcda1 line to match sharp's default one allows me to type in:
mount /dev/mmcda1 (upon which the SD card now shows up properly). The SD card icon will unmount properly if the card is pulled out, but I have to drop down to the console and mount it manually whenever I reinsert it (unfortunately, the GUI software install program only shows "Internal Flash" as the only location I can install anything to (the SD or CF card doesn't show up).
adf
You could just mount the sd card manually, or edit fstab and/or mtab

Things seem to install just fine. Loaded the camera software (and module) kino2, advanced fm, some libs wellenreiter, multimodal (couldn't find a 755 ipk and was too lazy to strip it)browser XQT (which runs very nicely from internal flash) qtopia mamory applet, the ffpe kernel etc.
can't find my belkin irk ipk though...(re did my sytem a few weeks ago..I seem to have kepth the targus version.


a question, though.
how does one set the processor speed from commandline?

also I can see the need for a few scripts eventually.(would you like tmp on cf or sd? etc) and maybe the inclusion of swapd in the basic part of the rom? (with a yes/no on boot or installaion)
gab74
i'm testing the rom...and things works well...
A strange thing....
SL6000 seems slow when i try to use some default apps....
i noticed that speed is set to slow.... so i try to select MAXIMUM after this may i have to reboot the ZAURUS or the new frequency is set without rebooting ???

if i want to put qtopia 1.5 on my SD may i use the SYS backup without gui and untar the qtopia1.5 tgz file ? Are theese files updated ?? I need more ram on my SL6000....
guylhem
ken,

Thanks a lot for the readme. I'll use it. Thanks for the bug report too. Regarding the bugs, as you guessed the SD problems come from fstab. If I use sharp defaults, it has problem with my ext2 card. I think I'll ship with vfat per default, and keep ext2 for me if I can't find a play to have both play nicely. I also tweaked the sdcontrol script IIRC from /etc/ to have ext2, so you need to edit it too.

For the Timezone, I just click on the globe item, replace the timezone, close the app, open the date appplication again and set it. How is it different from a stock sharp rom?

The network problems are strange. I'll see if I can test it more but I don't understand why such problems happends. Regarding my wep keys etc, guys please don't distribute them :-) I'll try to clean the next release better (I only have 1 6000 for both my personnal use and rom releases !- a second one would help, I'll consider purchasing a spare)

Most of the boot errors are normal (cramfs for ex.) I'm removing blkmtd and usr_ohci errors which I added.

adf, click on the battery for overclocking. Installation targets and the "filebrowser" tabs don't work for some reason. I'll try to fix it.

I guess the remaining important bugs are :
- network connections
- vfat SD card issues

I'll try to post an update soon.

PS: could someone please send me a .tar.gz of /opt/QtPalmtop.rom/lib/fonts? Deleted it by mistake while working on font issues.
gfdsa
very good job guylhem, tried yesterday, without mentioning the listed above issues, i can.t connect usb keyboard, the device is detected, but not claimed by a driver, i suspect it should be kbdsim? or i lack hid drivers?
ken
>for me if I can't find a play to have both play nicely. I also tweaked the sdcontrol >script IIRC from /etc/ to have ext2, so you need to edit it too.

I'm not sure what you tweaked, you might have to explain it to me later.

>For the Timezone, I just click on the globe item, replace the timezone, close the >app, open the date appplication again and set it. How is it different from a stock >sharp rom?

The sharp rom basically takes in the new settings as soon as you add it, no need to open and close the app again.

>The network problems are strange. I'll see if I can test it more but I don't

I'm not sure why either. It's probably something small that was overlooked. Possibly may have to do with your cleaning up all the symlinks. I agree that the sharp rom had a ton of weird symlinking.

>Most of the boot errors are normal (cramfs for ex.) I'm removing blkmtd and >usr_ohci errors which I added.

My guess on this is the device wasn't created in /dev. As for the ohci error, I think it's possibly a pathing or permission issue.

>PS: could someone please send me a .tar.gz of /opt/QtPalmtop.rom/lib/fonts? >Deleted it by mistake while working on font issues.

Not a problem. I just don't have your email to send it to ...
rip
wep key 40 bits entered and surfing ok,
qtopia destop restore ran fine from the craddle
rotation works fine but seems to need a recalibration.
i'll try my cf bt pretec later.

any help about installing things elwere than in internal memory?
ken
I suppose I could compare the network settings that you have with what Sharp produces and grab ifconfig and other info ...

Network settings for the Sharp rom are stored in /home/zaurus/Applications/Network/modules
rip
another little pb, the file browser after a reboot shows your sd files, not mine wink.gif
obliged to eject the sd and to plug it again, then its fine
rip
QUOTE(guylhem @ May 8 2005, 10:58 PM)
adf - regading fstab - oops. I use ext2 on my SD. I will fix that. devimage is not working yet - I've got to fix its paths, etc. It should take a while. Regarding ipkg - oops again. To minimise flash wear, I put /tmp and /var in a ramdisk. It's only 1 Mb that's why it's exhauting. I'll fix that. Meanwhile simply replace /tmp link by a real /tmp when you do an install.
*


hum hum, i don(t know what file to edit/change to change the /tmp path, could you help?

many thanks
adf
QUOTE(rip @ May 10 2005, 12:21 PM)
QUOTE(guylhem @ May 8 2005, 10:58 PM)


adf - regading fstab - oops. I use ext2 on my SD. I will fix that. devimage is not working yet - I've got to fix its paths, etc. It should take a while. Regarding ipkg - oops again. To minimise flash wear, I put /tmp and /var in a ramdisk. It's only 1 Mb that's why it's exhauting. I'll fix that. Meanwhile simply replace /tmp link by a real /tmp when you do an install.
*


hum hum, i don(t know what file to edit/change to change the /tmp path, could you help?

many thanks
*



it's simple, really. just su
and do mkdir /mnt/card/tmp (or mnt/cf/tmp if you prefer it on cf) and then do
ln -sf /mnt/card/tmp /tmp

and you are all set.
maybe the same should be done w/ var.
gfdsa
no unicode fonts btw, had to copy files from Qtopiarom.tar.gz previously installed
adf
I can click on the battery f i am in qtopia.

If not... what are the commands for the various clock speeds. Imagine qtopia was not at all installed... how would I change clockspeeds then?

(atm I'm thinking of how to change 'em in pocketworkstationvnc--though I still haven't figured out the keymap issue I think it haas to to with -hw specification in fbvnc, but I haven't had a lot of luck yet)
rip
it's simple, really. just su
and do mkdir /mnt/card/tmp (or mnt/cf/tmp if you prefer it on cf) and then do
ln -sf /mnt/card/tmp /tmp

and you are all set.
maybe the same should be done w/ var.
*

[/quote]
uhhhh , made the changes on tmp and the brick reboots itself and stuck on splashscreen for 30 minutes, ...
reset = same thing, had to reflash again, hihi
adf
[quote=rip,May 10 2005, 07:01 PM]
it's simple, really. just su
and do mkdir /mnt/card/tmp (or mnt/cf/tmp if you prefer it on cf) and then do
ln -sf /mnt/card/tmp /tmp

do it from a console in qtopia? This is exactly how I fixed the install issue.

you could remove /tmp first.
or do ln -s instead of ln -sf (though i expect you'll get an error)
rip
i appologize for my incompetence, but witch /tmp have i to remove?

and also is there any fix for the add/remove applet only showing internal memory as the only path for install?
am i the only one to have this pb?
gfdsa
add/remove applet ?
how to get there? i have all the panel filled with stuff i want to remove
rip
well, sorry, windows typology rests....

icon name under settings is "software"
when installing anything cliked, only one choice offered: internal.

also gulhem, i have an air cable, do you know how to configure that?
adf
if you are in a console in qtopia there is, effectively, only one /tmp...the one inside QtPalmtop.rom

as to the applet thing....if they don't come up in add/remove, you could try subapplet? a I don't know it that handles uninstalling, though.

the gui packagemanager internal only option is a kind of side effect of this setup, imho. because QtPalmtop.rom can be anywhere (any one try it over nfs yet?--might be an interesting soution to situational work/home/school demands) it is difficult to say it should definitely look outside itself. I suspect, though that you could edit ipkg.conf and do install -d from commandline.
Personally I prefer having all of th z-rom stuff onboard. it lets me mix and match cf and sd stuff freely without concern that i'm scrambling my sytem. (the tmp and var thing should probably be scripted, though) zright now, if I want something more than qtopia ioffers I use pocketworkstation on my sd--all self contained as well. (hmmmm the possibilites for cheap arm based desktops with mobile self contained os that can be transferred to other devices or used as thin clients.....)
adf
IRK.

the "a" key on my ir keyboard does not work. the other keys all do. the "a" key sends ???? to irk--which i take to mean that it sends something, but irk has no idea what. I suspect this is a by-product of the keymap fix. Any ideas for a fix for this? maybe a boot time thing that connects the ir kbd pre qpe? out of my depth here, obviously

USB

hid, usbmouse and usb kbd don't seem to autoload...and loading them after booting into Qtopia is a pain. (didn't bother w/ the mouse)

since no one seems to own 6k N models, at the very least both usb (with kbd mouse and storage support --including the toshiba module--don't know if you did that or not, just thought it should be mentioned)
and wireless should probably be compiled in. the extra kernel size isn't much and the result is good.


Qtopia 2.1
lpotter says 2.1 is sharp package compatible.. ( I was just pestering him about this... see the qtopia 2.1 available soon thread) and has a sane dir structure to boot. It warrants more investigation, maybe?
Maybe 2 rom versions? a qt2.1 "sharp" and a qt 2.1 "floating point" down the road?

Idle speculation
any possibility of a pdaX version?
adf
QUOTE(adf @ May 11 2005, 09:55 PM)
IRK.

the "a" key on my ir keyboard does not work. the other keys all do. the "a" key sends ???? to irk--which i take to mean that it sends something, but irk has no idea what. I suspect this is a by-product of the keymap fix.  Any ideas for a fix for this? maybe a boot time thing that connects the ir kbd pre qpe?  out of my depth here, obviously

USB

hid, usbmouse and usb kbd don't seem to autoload...and loading them after booting into Qtopia is a pain. (didn't bother w/ the mouse)

since no one seems to own 6k N models, at the very least both usb (with kbd mouse and storage support --including the toshiba module--don't know if you did that or not, just thought it should be mentioned)
and wireless  should probably be compiled in. the extra kernel size isn't much and the result is good.
though i seem to rmember problems compiling hid in the last kernel -- I skipped it and just did the lesser mouse and kbd options...

Qtopia 2.1
lpotter says 2.1 is sharp package compatible.. ( I was just pestering him about this... see the qtopia 2.1 available soon thread) and has a sane dir structure to boot. It warrants more investigation, maybe?
Maybe 2 rom versions? a qt2.1 "sharp" and a qt 2.1 "floating point" down the road?

Idle speculation
any possibility of a pdaX version?
*
guylhem
installating in other places besides internal flash: I'm working on that. I have no idea why the file manager tab doesn't show my SD card, but shows my CF card. The installation target could be set by editing /etc/ipkg.conf

too many apps by default: sorry, but I think they should all be included. most roms are just roo empty. remove if you want, but let other people who won't get apps by themselves take advantage of the already selected apps.

irk: you're right this is a byproduct. edit your driver to send keycode 125 for A, and 30 for the key you want to act like FN. Sorry, there is no other way. Sharp Qtopia 1.5 hardcoded that FN=30, even if for the rest of the keyboards in the world keycode 30 =A

usb : found the bug. Forgot to include stuff in my kernel compilation. Fixed.

I'll try to release an update soon.
ken
>installating in other places besides internal flash: I'm working on that. I have no >idea why the file manager tab doesn't show my SD card, but shows my CF card. >The installation target could be set by editing /etc/ipkg.conf

Tried that a while back, doesn't work.

>too many apps by default: sorry, but I think they should all be included. most >roms are just roo empty. remove if you want, but let other people who won't get >apps by themselves take advantage of the already selected apps.

There's just a few that I'm thinking you might want to exclude, mainly because they're actively updated. Otherwise not a biggie.
adf
I had wondered about the usb thing after I posted that. It looked like at least some of the stuff was laready compiled in as it loaded.

will do with the key thing... should be no big thing.

will try to get oe going in the next day or two,
adf
doing a fastffpe kernel with the usb fix btw?

and on oe.... do you want me to test it before tarring it? It will make the thing a good bit bigger, but will likely save time, and you'll get a cmplimentary copy of nano laugh.gif
guylhem
Hello

ken : if ipkg.conf doesn't help, I'll have to see where the problem is.
Regarding apps, which one should be updated? Updating them at each release is not a problem.

adf: just compile "USB support for HID devices" in Drivers/USB section. I compiled only a part, and that didn't really help.
For oe, I'm only interested in the toolchain. Just follow the instructions (I can't - I hate following instuctions. I have to try by myself) from oe website and you'll end up with many .ipk and a cross compiler.

I'm only interested in the cross compiler. Locate where it is (it features files such as arm-linux-gcc) and to a .tar.gz of the uplevel directory. Try to run arm-linux-gcc -v to see which version it reports. Then send me a list of the files in that tar (tar ztvf file.tar.gz > list) so I can quickly check is everything is there.

Guylhem
rip
this quick post to ask if its not a good idea to include zeditor and a pdf reader in rom apps coming with flash restore. i hate vi and i don't know other console editor.
adf
QUOTE(guylhem @ May 12 2005, 02:31 PM)
Hello

ken : if ipkg.conf doesn't help, I'll have to see where the problem is.
Regarding apps, which one should be updated? Updating them at each release is not a problem.

adf: just compile "USB support for HID devices" in Drivers/USB section. I compiled only a part, and that didn't really help.
For oe, I'm only interested in the toolchain. Just follow the instructions (I can't - I hate following instuctions. I have to try by myself) from oe website and you'll end up with many .ipk and a cross compiler.

I'm only interested in the cross compiler. Locate where it is (it features files such as arm-linux-gcc) and to a .tar.gz of the uplevel directory. Try to run arm-linux-gcc -v to see which version it reports. Then send me a list of the files in that tar (tar ztvf file.tar.gz > list) so I can quickly check is everything is there.

Guylhem
*

Will do.
You want the 2.95 kernel cross compiler stuff too? there isn't really much to that.. just a matter of taking the standard 2.95 xcompiler and changing a couple names -like arm-linux-gcc to arm-linux-gcc2.95, or something very close. it is just a naming thing to make bitbake.conf happy. It is the same cross compiler you are already using, i bet. I used the same cross compiler to do oz and the integrated version of your kernel last month... took about 10 characters to switch it back and forth.

I take it you are planning to patch an oz kernel, compile opie, pull opie, repartition, install the new kernel and put opie in place of the current Qtpalmtop.rom?

If so, want to give gpe a go? if gpe were done this way, and the Qt stuff run on it the way it has recently been done on pdXrom (so that qt apps can be run) this woud be real interesting--esecially if it were tweaked to run stuff from multiple feeds (like debian arm... ) The only real issue i saw with the last gpe was that the supplied minimo didn't quite work right--and of course the small feed.

this brings up something i've been wondering about... have you noticed that op and matchbox are both in debian? make the sd / and the nand /boot (?) and use the debconf and debtools and kdrive that oe builds and a native debian might be possible.

re the hid thing... i don't have a menuconfig in front of md, so I'll be a bit vague....
in usb under hid there are raw (?)? mouse and kbd support options. on the previous kernel version I could compile those, and they'd drive a usb mouse and keyboard, but not the hid option. Full hid never quite compiled... i always ended up hang ing on to the module, though it didn't get used, I don't think
gfdsa
speaking of multiple guis, one of the ideas that i did like in guylhem ideas was having guis on sd or cf, and leaving possibility of fbcon only device, then it could be brought to situation when you can manage the stuff similar to xdm, for example qingy, which is an DirectFB based login manager, which im trying to compile for arm now
for pdaXrom stuff - its simple, there should be only --prefix=/opt/pdaXrom added, and assuming you have a sym link or you mount your SD to /opt, it will run, may be with some light scriptiing for library pathes, for GPE, i should look how it's compiling system is implemented, but im pretty sure that its possible to have all gpe's stuff inside one directory
then it all can be packaged, or t least tarballed with some pre- and post- installation scripts, and distributed
adf
absolutely. i'd love to see this quingy working on this rom.

maybe a mount script can be added... so that new users will just untar a gui to a card.. pop in the card and get a "mount blohgui on your systm Y/n?" prompt? this gets more interesting smile.gif
gfdsa
thats the idea, adf, i did not advance lately, my wife took the device to read at home, so i cant try what i've compiled...
hbo
QUOTE(adf @ May 10 2005, 12:50 PM)
0
.0
it's simple, really. just su
and do mkdir /mnt/card/tmp  (or mnt/cf/tmp if you prefer it on cf) and then do
ln -sf  /mnt/card/tmp /tmp

do it from a console in qtopia?  This is exactly how I fixed the install issue.
*


That doesn't work when the new tmp is on cf. At least it doesn't when the cf is formatted with ext2. I got the "splash screen never goes away" symptom after making hhe change on my tosa. I was able to recover by using the "press / repeatedly after init starts" trick. When I got in to the text console, I saw that /mnt/cf wasn't mounted. Having /tmp pointing to nonexistent path makes some programs cranky, for some reason.

QUOTE
you could remove /tmp first.
or do ln -s instead of ln -sf (though i expect you'll get an error)
*


That won't give you an error. It will just symlink /tmp/tmp -> wherever you said.
bear426
Will this work on the SLC 3000? If it does, and since I'm a novice when it comes to Linux, will I be able to do this myself without having a clear understanding of the language? What exactly will this release do, if anything, for my 3000? Also, if your new release works with the SLC 3000, will it provide a better PIM? I think the one on this unit sucks, especially when it comes to synchronizing my contacts/calendar/tasks and notes from outlook. Also, will it be recognized and easily configured by my Socket Low Power WLAN CF card? It isn't recognized on the unit the way it is at present. As you can see, I am a complete novice when it comes to this product and its operating system. Also, could you guide me to where I might find books or such on how to operate the zaurus SLC3000? As I'm sure you know, all that information came from Japan and hence is written in Japanese, which I can neither read nor understand. Your help is greatly appreciated on all of this. Thanks.
adf
QUOTE(hbo @ May 12 2005, 08:19 PM)
QUOTE(adf @ May 10 2005, 12:50 PM)
0
.0
it's simple, really. just su
and do mkdir /mnt/card/tmp  (or mnt/cf/tmp if you prefer it on cf) and then do
ln -sf  /mnt/card/tmp /tmp

do it from a console in qtopia?  This is exactly how I fixed the install issue.
*


That doesn't work when the new tmp is on cf. At least it doesn't when the cf is formatted with ext2. I got the "splash screen never goes away" symptom after making hhe change on my tosa. I was able to recover by using the "press / repeatedly after init starts" trick. When I got in to the text console, I saw that /mnt/cf wasn't mounted. Having /tmp pointing to nonexistent path makes some programs cranky, for some reason.

QUOTE
you could remove /tmp first.
or do ln -s instead of ln -sf (though i expect you'll get an error)
*


That won't give you an error. It will just symlink /tmp/tmp -> wherever you said.
*



1). hence the parentheical /mnt/cf, and the other discussion about fstab and cf mounts
2). i wasn't sure if you did ln -s when something of that name existed where you were intending to put the link would not give you a "file of that name already exists" type of error.

woudn't it make more sense to use sd for tmp and var and that sort of system stuff, though... given that cf has both larger storage options (wads data and media) and is use as a kind of bus for other devices (lan modem camera bluetooth) and so is likley to be more susceptible to being swapped in and out? sd on the 6k is pretty much limited to 1 gig and under data storage.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.