Help - Search - Members - Calendar
Full Version: Ipkg Package Compatibility - Newbie Question
OESF Forums > General Forums > General Support and Discussion > Software
the2nd
Hi all,

just a simple question. are the ipkg packages available all over the net binary compatible?

if i install openzaurus with opie or gpe on a c3000 can i use the packages from e.g.

http://www.elsix.org/ or http://killefiz.de/zaurus/

regards
the2nd
zenyatta
If I'm correct, they are compatible but only one way. The older variant of the ipkg format uses tar compression while the newer version uses ar. OpenZaurus (OZ) can process both versions of the format but Sharp ROM only deals with the older one.

So you should be able to install any package on OZ but whether or not the software will run is another question. The Opie environment used in OZ is derived from Qtopia (what the Sharp ROM uses) but they are slowly diverging and compatibility is broken for many non-trivial applications. There is a Sharp compatibility package for OZ (sharp-compat-oz) that will help in many cases.

My advice would be to give it a try, you can always uninstall. And do check out OZ feeds - there are over 2000 packages there already.

Cheers,
z.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.