Help - Search - Members - Calendar
Full Version: Help! Bluez Install Failure On A C1000...
OESF Forums > General Forums > General Support and Discussion > Security and Networking
Ragnorok
- I just got an Ambicom BT2000CF, the one with the yellow label, which everyone says is supposed to work. It doesn't! (pout)
- I've spent the last three hours scouring the forum for information about resolving BlueZ problems, and found nothing that seems to fit my particular issue. I did install the packages listed in this thread:

http://www.oesf.org/forums/index.php?showt...837&hl=bt950_cs

which indicated I wasn't using the right ones. I had ver e, and he specifically says to use d, so I am now. (grin)
- But that avails me not. I finally found a post that reminded me I *could* run ipkg from the command line, which was done. Here's the result:
CODE
#ipkg install bluez-zaurus_arm.ipk
Unpacking bluez-zaurus_arm.ipk
Configuring bluez-zaurus...Starting Bluetooth... modprobe: Can't locate module rfcomm
modprobe: Can't locate module 12cap
Can't get port settings: Input/output error
Can't initialize device: Input/output error
Can't open RFCOMM control socket: Address faimily not support by protocol
Done.
Done.

- So I look for and find: /home/root/modules/2.4.18-rmk7-pxa3-embedix/kernal/net/buetooth/rfcomm/rfcomm.o
- So I look for and DO NOT FIND 12cap.o.
- The only reference to this module I found on the entire OESF Forum list referred to OpenZaurus. So I'm right good and stumped.
- All of my cardctl, settings, etc are the same as those listed on the above thread EXCEPT my /etc/bluetooth/uart file contains:
CODE
"Socket", "CF+ Personal Network Card Rev 2.5":/dev/ttyS3 bcsp 23400

THAT's not right!! However, updating to read what the above link contains, for the AmbiCom card, has no effect. When I "sudo /etc/rc.d/init.d/bluetooth restart", it still can't find module 12cap, or rfcomm.
- I am using and have verified using the "18d" version of BlueZ, plus sudo, susp_resume, and susp_resume_bluez.
- Any ideas all?? I'm LOST!...
Ragnorok
- Hurm. 12cap.o is there. Just some doofus was looking in the "drivers" directory instead of the "net" directory. (befuddled drool) This is still kickin' my butt, though ... the files are all there, plain as day, under /home/root/modules (softlinked to /lib/modules), in the 2.4.18-rmk7-pxa3-embedix/kernel directory, under either drivers or net. All the modules are just right there.
- I even renamed the bluez...ipk and gunzip'd it to a directory so I could see where it's putting everything, whic is how I found I was looking in the wrong place for 12cap.o (and i was not using "find" correctly [wry grin]).
- The modules.conf file has a bunch of aliases in it. Doing modprobe on the "normal" file instead of the alias (ie "net-pf-31" instead of "bluez") has no effect. Modules are still not found.
- I googled for module location issues and found a post on the sourceforge mail archive that listed the general loading sequence should be: bluez, 12cap, sco, rfcomm, bnep, hci_usb, hci_uart. I tried manually loading these, starting from the top, but it's the same thing. Can't find any of these modules anywhere.
- So ... just how *does* the Z find modules??
Ragnorok
- 12cap.o is GONE. When I rebooted, it couldn't find it any more. So I removed the bluez-zaurus package, recopied the "18d" version, renamed so ipkg wouldn't complain (wink), and re-installed. Same error on install ... can't find 12cap. BUT when I look in the bluetooth directory where it put the rest of the modules, there IS NO 12cap.o! Huh???
Ragnorok
- I'm thinking, after a lot of poking about on the web for modprobe issues, that this version of BlueZ just does NOT work with the C1000. From what I can tell, if modprobe can't recognize a module, even if it finds it, it still reports that the module could not be found. Given that it installs to a "2.4.18..." directory instead of "2.4.20" where the *rest* of the modules are, I have to wonder about the compatibility.
- The guy on the thread I linked to is using a 5500 with kernel 2.4.18, the same one as the BlueZ appears to be compiled for.
- Anyone else have BlueZ v "18d" running with an AmbiCom BT2000E on a C1000? Stock ROM from Sharp, the only "upgrade" is a little 256MB SD card. If you do have it running on a C1000, could you give me a little assistance? (grin)
- Barring that, what would I have to do to compile BlueZ for kernel 2.4.20?? I have a cross-compiler setup all newly done, or I could compile it right on the Z. BlueZ folks have any thoughts??
- Thanks for your time...
Ragnorok
- Everyone is ignoring me ... with GOOD reason! (smirk) I'm not using the RIGHT drivers, though a clue would have been convenient. (wink)
- So, now I have the alpha4 drivers, and I'm posting the latest issue in the thread for the C3000 BlueZ drivers. Noob, I!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.