Help - Search - Members - Calendar
Full Version: Media Players... why won't mine work
OESF Forums > General Forums > General Support and Discussion > Software
zen_cabbie
I am wanting to view the movies that I already have on my PC, most are MPEG (I am assuming level 4) or DiVX. I know the Sharp Media Player won't play anything but MPEG-1, and I have tried loading MPlayer, OPIE player, OPIE Player 2, XMMS with MPlayer... almost every combination that I can possibly think of. The problem is I cant get the programs to start up. I tap them and they look like they are opening up, but they don't... or they open up and I try and play a video and nada.

I think that I'm missing a library or some other component, but I don't know what I'm doing wrong.

If some one could please give me a suggestion as to which player I should use, and what components I need to run them, that would be wonderful.

Thank you in advance.
zen_cabbie
Anonymous
http://home.earthlink.net/~cresho/

the guy has a tutorial on converting to mpeg2 so you can view it using the default sharprom but has not posted it yet. maybee no time? but he has a tutorial for playing back divx files.

maybee you can email him and ask him what you want. its windows based so if you want linux, there is a link also somewere

this one is posted by another person.

http://www.cs.unc.edu/~hensley/zaurus/encode.html
avel
im using the sharp rom and the default player to play back MPEG-2 movies that I encode with tmpeg. But i'm pretty sure any mpeg2 movie will play on there.
Anonymous
the only problem playing with the default mediaplayer is you can't fastforward or rewind the movie.
Anonymous
ohh and files are much bigger
Anonymous
Use VLC
lardman
QUOTE
The problem is I cant get the programs to start up. I tap them and they look like they are opening up, but they don't... or they open up and I try and play a video and nada.  


Run from the terminal. See what the error is. Fix it or post for more help.

Regards,

Simon
zen_cabbie
Okay, I got it running from the Terminal and it loads up just fine, but when I try to play any media, MP3, video, etc., the program just closes down. I'm lost right now.
lardman
No error messages whatsoever in the terminal?
zen_cabbie
okay here is what the terminal says:

bash-2.05$ opieplayer
QPixmap::convertFromImage: Cannot convert a null image opieplayer
QPixmap::convertFromImage: Cannot convert a null image opieplayer

The program then loads up and I try and play a video/music and I am dumped back at the terminal.

I'm not 100% sure how to try and run a file from the terminal, so that is what I have so far.
lardman
Ah, opie media player. There are issues so I hear. Take a look at the mailing list (opie.handhelds.org).

Try mplayer (with xmms + xmms-mplayer-plugin if you need a GUI), this is what I use (mplayer is command line anyway, but also try starting xmms and see what it says).


Si
Anonymous
If you're willing to pay for it, tkcVideo (http://www.thekompany.com/embedded/tkcvideo/?PHPSESSID=a299de9133a68e23daae9478762af655) works perfectly. I had the same problems with the players you mentioned and just gave up (wimpy, I know). There's a page with instructions on how to convert video to divx using something called Vidomi, I'll post that later.
Anonymous
does xmms work for sharp rom? seems like its for open zaurus only...
anything with sharp that can play divx? or are you stuck with mpeg1 video? im also talking free not for pay product. Thanks
tumnus
Mplayer + MplayerShell (Java GUI) works fine for me on the Sharp ROM. Get the mplayer package and MplayerShell package from here: http://www.rothfuss-web.de/zaurus/index.html

If you have a SL-5500 with the 3.x make sure you have installed Jeode too.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.