Help - Search - Members - Calendar
Full Version: Sl 5500 Dead With No Charge Light
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
Hi people, I have a 5500 that refuses to show any signs of life, particularly in respect of the charge LED not lighting up when on mains adapter.
I have swapped the battery out for a known good one, fully charged, no joy.
There is current getting through to the motherboard, since it gets warm.
On which point, I'm suspecting the built in battery, since it gets pretty hot.
Perhaps impatiently(after a couple of hours on charge), I've unsoldered it in the belief that maybe it was that preventing any signs of life. No change!
I've read through all the posts here, so rest assured I've covered everything suggested so far.
Anyone got any relevant experience on this?
If not, then I'll cut my losses and break it for parts, I have another that works fine so it's no problem.
The LEDs are controlled by the kernel iirc, did you have a flash go wrong or something like that?

Thanks for the good info, I'd assumed the power LED would be a hardware thing.
afaik the machine died for no apparent reason (I got this one already dead!), except possibly being left unused for a while.
I've tried the key options for a ROM flash, and also for the diagnostics screen, but with no success. Also tried many hard resets as well.
I'm Leaving it to charge all today, not in much hope though!
Thanks for all the helpful past posts in the forum everyone, a good read but nothing worked,
so it's going as spare parts,
see the for sale / wanted forum.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.