Help - Search - Members - Calendar
Full Version: Serial Connector Pin-out
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Cxx0 Hardware
marshmn
Hi all,

I'd like to build a cable to connect my Z to a serial GPS device. I've been looking at the information on this page:
http://www.zaurususergroup.org/modules.php...name=SerialPort

That info is very helpful and includes a table giving relevant pins on the zaurus connector. What I can't figure out is which way round the pins should be counted?

If I'm looking directly at my Z, should I be counting the pin on the left as pin 1? or the pin on the right?

I understand that some models have the connector upside down from others? So I'm talking about a C860 here.

Thanks for the help,
Matt
marshmn
OK, so after some playing around with the USB cable and a multi-meter I've been able to determine that the pin on the left as you're looking at the connector on the Zaurus is pin 1.

Right, now that's sorted I can get on with making my Z to GPS connection cable smile.gif

Matt
zmiq2
Hi Matt,

can you please comment on how are you doing the cable? Where do you get the zaurus connector from ?

Thanks.
marshmn
zmig2,

I now built the cable and have it working with the Z after a bit of messing around. I think at some point I'll write this up as a mini-howto or something with photos etc to save others having to do the searching around etc... but anyway, for now, here is the basic info:

- I bought some Zaurus connectors from:
http://www.fivestarassoc.com/Z/index.html

- I bought some Garmin eTrex connectors from:
http://www.pfranc.com/

I then connected the pins as per a null-modem cable, so from the output pin of the eTrex connector to the "Recieve Data" pin of the Zaurus connector (Pin 4) and from the input pin of the eTrex to the "Transmitted Data" pin of the Zaurus connector (Pin 3). I connected the ground pin of the eTrex connector to the "Signal Ground" pin of the Zaurus connector (Pin 8). I left the power pin of the eTrex unconnected.

- Details of the pin outs of the Zaurus connector:
http://www.elsix.org/downloads/sio-specifi...030121_v100.pdf

- Details of the pin outs of the eTrex connector:
http://www.syz.com/gps/etrex2info.pdf

Then, I installed GPSBabel, which is already packaged up for the Zaurus:
http://www.killefiz.de/zaurus/showdetail.php?app=2895

I also needed to install libexpat to make it work, which is also available:
http://www.killefiz.de/zaurus/showdetail.php?app=2894

Right, now to do a test... plugged in the cable and turned on both the Zaurus and the eTrex. From a console, I first set the baud rate of the serial port:
stty 4800 </dev/ttyS0

Now I ran gpsbabel and told it to dump the waypoints stored on the GPS to a GPX format XML file:
gps -i garmin -f /dev/ttyS0 -o gpx -F /tmp/waypoints.gpx

And voila, all working.... for me at least smile.gif

Hope it helps...
Matt
donk0yote
Matt,
i have an 860 also, and i'm running cacko 1.23, your post has been helpfull as i was building my own cable.
i'm not able to connect to an external modem using minicom,
and "setserial /dev/ttyS0" is reporting "UART: undefined, Port:0x0000, IRQ :14"
i have also tried the cable on my old SL5500 and can get no connection either sad.gif any help would be appreciated
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.