Help - Search - Members - Calendar
Full Version: rc9 on a 3000
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
auauhiro
I'm using RC9 on SL-C3000 chrooted from Qtopia. I want to test your the binaries of RC10 for C1000. Please, upload the tar image of root partition of jff2 file sywstem, because I can not extract binaries from jffs2.
sashz
QUOTE(auauhiro @ May 24 2005, 05:13 PM)
I'm using RC9 on SL-C3000 chrooted from Qtopia. I want to test your the binaries of RC10 for C1000. Please, upload the tar image of root partition of jff2 file sywstem, because I can not extract binaries from jffs2.
*


its here http://212.10.30.205/rc10/Zaurus-C1000/roo...-rc10.1.tar.bz2
auauhiro
QUOTE(sashz @ May 25 2005, 01:26 PM)
QUOTE(auauhiro @ May 24 2005, 05:13 PM)
I'm using RC9 on SL-C3000 chrooted from Qtopia. I want to test your the binaries of RC10 for C1000. Please, upload the tar image of root partition of jff2 file sywstem, because I can not extract binaries from jffs2.
*


its here http://212.10.30.205/rc10/Zaurus-C1000/roo...-rc10.1.tar.bz2
*




Thank you very much.
ztep
QUOTE(auauhiro @ May 24 2005, 05:13 PM)
I'm using RC9 on SL-C3000 chrooted from Qtopia. I want to test your the binaries of RC10 for C1000. Please, upload the tar image of root partition of jff2 file sywstem, because I can not extract binaries from jffs2.


When you build/test RC10 on C3000, can you public the results/files/instructions for the other C3000 users?

Thanks
auauhiro
QUOTE(ztep @ May 25 2005, 04:50 PM)
QUOTE(auauhiro @ May 24 2005, 05:13 PM)
I'm using RC9 on SL-C3000 chrooted from Qtopia. I want to test your the binaries of RC10 for C1000. Please, upload the tar image of root partition of jff2 file sywstem, because I can not extract binaries from jffs2.


When you build/test RC10 on C3000, can you public the results/files/instructions for the other C3000 users?

Thanks
*



I tried RC10 for SL-C1000 on C3000 chrooted from linux console of PocketWorkstation.

The X-Server works very well, and the match box window manager was
launched, but some clients can not be launched. I tried to check
the reason from X-terminal, but both of rxvt and xterm can not be launched. I copied the /dev from RC9 working on C3000, but nothing was changed. Now, I'm using the Xfbdev of RC10 on C1000 as the X-server of RC9 on C3000.

The method for using RC10 for SL-C1000 on SL-C3000 is as follows.
1) Install pocketworkstation on SL-C3000
See http://www.eleves.ens.fr/home/leurent/zaurus.html
2) Reboot SL-C3000 in linux cosole mode of pocketworkstation and login as root.
3) Extract the pdaxrom root image http://212.10.30.205/rc10/Zaurus-C1000/roo...-rc10.1.tar.bz2
on /hdd3. You will need to decompress bz2 before extracting tar in C3000 or you need to install bzip2 on SL-C3000.
bzip2 -d root-akita*
tar xvpf root-akita*

4) Extract the /home, /var and /dev from /root and make /tmp.
cd /hdd3/root-akita
tar xvpf root/.var*
tar xvpf root/.home*
tar xvpf root/.dev*
rm -r tmp
mkdir tmp

5) mount /proc
mount -t proc /proc /hdd3/root-akita/proc
6) chroot to RC10
chroot /hdd3/root-akita
7) set enviroment variables.
source /etc/profile
export LD_LIBRARY_PATH=/usr/X11R6/lib:$LD_LIBRARY_PATH

8) start X-server
startx
The matchbox windowmanager can not be shutdown from menu.
You must stop X-server by alt(Address)-Ctrl-BS.

Please try and solves problems of launching X-terminals.
sashz
QUOTE(auauhiro @ May 25 2005, 01:13 AM)
The X-Server works very well, and the match box window manager was
launched, but some clients can not be launched. I tried to check
the reason from X-terminal, but both of rxvt and xterm can not be launched. I copied the /dev from RC9 working on C3000, but nothing was changed.


/dev/pts mounted?
auauhiro
QUOTE(sashz @ May 25 2005, 08:54 PM)
QUOTE(auauhiro @ May 25 2005, 01:13 AM)

The X-Server works very well, and the match box window manager was
launched, but some clients can not be launched. I tried to check
the reason from X-terminal, but both of rxvt and xterm can not be launched. I copied the /dev from RC9 working on C3000, but nothing was changed.


/dev/pts mounted?
*


I did not mount /dev/pts. The rxvt installed on RC9.1J may use /dev/pty??, thus
it works without /dev/pts.

I found more easy way to install RC10 for C1000 on C3000 without using chroot. But, this method is dengerous, it may completely break the system of your C3000. So, I will not write details.

I erased the instructions of this method wrtten here, because the filesystem of hdd3 on my C3000 was broken.
offroadgeek
QUOTE(auauhiro @ May 24 2005, 05:13 PM)
I'm using RC9 on SL-C3000 chrooted from Qtopia. I want to test your the binaries of RC10 for C1000. Please, upload the tar image of root partition of jff2 file sywstem, because I can not extract binaries from jffs2.
*

I split this into it's own thread, because for some reason you couldn't have started your own wink.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.