Help - Search - Members - Calendar
Full Version: Low Memory Message! - Debian On C3000
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > X/Qt
ArchiMark
Hi,

On the whole, got X/Qt/Debian running OK on my lil' C3000....

However, lately, often when doing 'apt-get upgrade' I get a 'Low Memory' warning message window that pops up on the Qtopia side of the Z. Gives me a button that says 'Reboot'....at that point X/Qt/Debian has quit....

I recently reinstalled X/Qt/Debian on my Z to the internal microdrive...

Any suggestions to avoid this problem??

Thanks for any help.

Mark
ArchiMark
Maybe some more detailed info will help someone to advise, please....

In Qtopia System Info app, here's what I see:

'Storage' Tab:

Program Area: 398,282 KB

Used: 58,425 KB

Available: 339,857 KB


'Internal Disk' Tab:

Total: 3,478,852 KB

Used: 1,311,184 KB

Available: 2,167,668 KB

'Memory' Tab:

Total: 62,036 KB

Used: 24,568 KB

Free: 37,468 KB


Also, just did 'df' in QKonsole and got the following:
CODE
Filesystem    1k-blocks     Used        Available  Use%   Mounted on
rootfs                5120       5120                  0  100%    /
/dev/root           5120       5120                  0  100%    /
/dev/mtdblock3  4096       2968             1128    72%   /home                  
/dev/ram1             44          30                 14    68%   /dev
none                  1024          00               944     8%   /dev/shm
/dev/hda1         99521    62005            32377   66%   /hdd1
/dev/hda2       398282    37862          339857   10%   /hdd2
/dev/hda3      3478852  1311184      2167668   38%   /hdd3
/dev/mmcda1  999040    877104        121936   88%   /usr/mnt.rom/card
/dev/loop0     1032088    299804        679856   31%   /hdd3/debroot
/dev/mmcda1  999040    877104        121936   88%   /hdd3/debroot/mnt/card


Also, using Cacko b1.23 ROM with Tetsu 18a kernel....

Would greatly appreciate any input on how to deal with the low memory warnings... if need other info, let me know...

Thanks for any help!

Mark
daemon1
QUOTE(ArchiMark @ May 26 2005, 08:01 PM)
Hi,

On the whole, got X/Qt/Debian running OK on my lil' C3000....

However, lately, often when doing 'apt-get upgrade' I get a 'Low Memory' warning message window that pops up on the Qtopia side of the Z. Gives me a button that says 'Reboot'....at that point X/Qt/Debian has quit....

I recently reinstalled X/Qt/Debian on my Z to the internal microdrive...

Any suggestions to avoid this problem??

Thanks for any help.

Mark
*


have you tried adding quite a large swap file? I had this setup running up until yesterday, made a 650mb debian loopback partition and a 200mb swap and it was fine. had to do a factory reset yesterday because i broke something when installing new tetsu kernel, not related to debian.
ArchiMark
Thanks for your input, daemon1!

Yes, I added a swapfile as per Meanie's install instructions on his webpage...don't remember off the top of my head the size of it...

Mark

QUOTE(daemon1 @ May 31 2005, 02:23 PM)
have you tried adding quite a large swap file? I had this setup running up until yesterday, made a 650mb debian loopback partition and a 200mb swap and it was fine. had to do a factory reset yesterday because i broke something when installing new tetsu kernel, not related to debian.


QUOTE(ArchiMark @ May 26 2005, 08:01 PM)
Hi,

On the whole, got X/Qt/Debian running OK on my lil' C3000....

However, lately, often when doing 'apt-get upgrade' I get a 'Low Memory' warning message window that pops up on the Qtopia side of the Z. Gives me a button that says 'Reboot'....at that point X/Qt/Debian has quit....

I recently reinstalled X/Qt/Debian on my Z to the internal microdrive...

Any suggestions to avoid this problem??

Thanks for any help.

Mark
ArchiMark
Thought I'd clarify a bit on my previous post....

FWIW, I installed X/Qt/Debian this last time per Meanie's webpage.

I installed Debian to hdd3 using a loopback (instead of SD card) as he described.

I created a loopback filesystem on /hdd3 with 1024MB. He suggested either 256MB or 512MB if you wanted to install OpenOffice. So I thought what the heck, make it 1024...

Was that a mistake to make it so big?

Also, I did setup a 128MB swapfile per his instructions on /hdd3.

HTH,

Mark
ArchiMark
Hey guys, it pretty lonely here all by myself... rolleyes.gif

77 views of these posts and only one reply....

Really would appreciate some more input from some of the gang here...

Thanks,

Mark
ArchiMark
Well, maybe I've figured what the *%$# is going on... rolleyes.gif

Here's what I got....

[CODE]
#cat /proc/meminfo
total: used: free: shared: buffers: cached:
Mem: 63524864 60510208 3014656 0 4165632 25546752
Swap: 0 0 0
MemTotal: 62036kB
MemFree: 2944kB
MemShared: 0kB
Buffers: 4068kB
Cached: 24948kB
SwapCached: 0kB
Active: 2944kB
Inactive: 26072kB
HighTotal: 0kB
HighFree: 0kB
LowTotal: 62036kB
LowFree: 2944kB
SwapTotal: 0kB
SwapFree: 0kB

So it looks like even though I thought I had setup swap space correctly, it seems that I have zero (0) right??

Thanks,

Mark
Meanie
QUOTE(ArchiMark @ Jun 3 2005, 06:39 AM)
Well, maybe I've figured what the *%$# is going on...  rolleyes.gif

Here's what I got....

[CODE]
#cat /proc/meminfo
                        total:      used:            free:    shared:      buffers:    cached:
Mem:        63524864      60510208    3014656        0      4165632  25546752
Swap:                    0                  0              0   
MemTotal:                        62036kB
MemFree:                          2944kB
MemShared:                            0kB
Buffers:                              4068kB
Cached:                            24948kB
SwapCached:      0kB
Active:                              2944kB
Inactive:                          26072kB
HighTotal:                                0kB
HighFree:                                0kB
LowTotal:                          62036kB
LowFree:                            2944kB
SwapTotal:                              0kB
SwapFree:                                0kB

So it looks like even though I thought I had setup swap space correctly, it seems that I have zero (0) right??

Thanks,

Mark
*


yeah, swap is not enabled.
to be certain, do a cat /proc/swaps as well, but it looks like its not enabled.
swap needs to be re-enabled each time you reboot.
where did you put your swapfile?
ArchiMark
Thanks for your help, Meanie!

You are right as usual...checked this last night and redid swap and voila!

It works well now....

Forgot that you had to re-enable each time you boot!

Well, live and learn.... rolleyes.gif

Thanks,

Mark
Meanie
QUOTE(ArchiMark @ Jun 3 2005, 11:22 PM)
Thanks for your help, Meanie!

You are right as usual...checked this last night and redid swap and voila!

It works well now....

Forgot that you had to re-enable each time you boot!

Well, live and learn....  rolleyes.gif

Thanks,

Mark
*


Are you using my startx-wrapper script (ie xlauncher) because it tries to enable the swapfile if it is /hdd3/swapfile and it has the priviledge to do so (sudo for swapon is enabled or run as root)
of course you can change the script to tell it to look for the swapfile somewhere else as well smile.gif
ArchiMark
Meanie, I am using your 'xqt-debian scripts'.

Is this the same thing?

Does this mean that I don't have to re-enable swap each time I reboot if I'm using your script??

Thanks,

Mark

QUOTE(Meanie @ Jun 3 2005, 06:45 AM)
Are you using my startx-wrapper script (ie xlauncher) because it tries to enable the swapfile if it is /hdd3/swapfile and it has the priviledge to do so (sudo for swapon is enabled or run as root)
of course you can change the script to tell it to look for the swapfile somewhere else as well smile.gif
*
Meanie
QUOTE(ArchiMark @ Jun 3 2005, 11:57 PM)
Meanie, I am using your 'xqt-debian scripts'.

Is this the same thing?

Does this mean that I don't have to re-enable swap each time I reboot if I'm using your script??

Thanks,

Mark

QUOTE(Meanie @ Jun 3 2005, 06:45 AM)
Are you using my startx-wrapper script (ie xlauncher) because it tries to enable the swapfile if it is /hdd3/swapfile and it has the priviledge to do so (sudo for swapon is enabled or run as root)
of course you can change the script to tell it to look for the swapfile somewhere else as well smile.gif
*

*



yes, xlauncher (startx-wrapper mods) is part of the xqt-debian-scripts package.

if you start debian by running
# xlauncher debian
or tap on the debian icon on qtopia it should enable the swapfile automatically for you provided it has the right filename and is in the right place (or you edit the file and give it the right info ie modify the line SWAPFILE=/hdd3/swapfile) and sudo has been configured to allow zaurus user to execute /sbin/swapon
ArchiMark
Thanks for clarifying, Meanie!

Usually, I start by tapping on the Debian icon and I think I've set it up OK (per your excellent webpage!), so sounds like I should be OK, but will check it.

Thanks,

Mark


QUOTE(Meanie @ Jun 3 2005, 07:16 AM)
yes, xlauncher (startx-wrapper mods) is part of the xqt-debian-scripts package.

if you start debian by running
# xlauncher debian
or tap on the debian icon on qtopia it should enable the swapfile automatically for you provided it has the right filename and is in the right place (or you edit the file and give it the right info ie modify the line SWAPFILE=/hdd3/swapfile) and sudo has been configured to allow zaurus user to execute /sbin/swapon
*
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.