Help - Search - Members - Calendar
Full Version: Usb Host Not Working
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
kckong
I bought a Kingston DataTraveler II USB Drive (256MB) Hi-Speed 2.0. When I plug into the usb host cable that connected to my C3k, the zaurus CANNOT detect any usb-storage!!

I tried to use other low speed USB drive, my zaurus can detect it and no problem at all.

I've tried to use this Hi-speed Kingston usb drive in window, no problem at all. It only giving problem at zaurus. I tried using mount command line or automount usb module also didn't work.

Please help and advice. thanks.
Stubear
From what I've read on a Japanese site, it seems that there are some usb flash drives that don't negotiate USB 1.1, they only work at 2.0 so the zaurus doesn't recognise them.

Supposedly older PC with only USB 1 have the same problem.

What does dmesg give when you plug the drive into the host cable? You may need some exta modules/drivers to get it working. Can a linux PC see the drive? If not then its probably a driver problem.

Stu
kckong
dmesg doesn't show any message when i plug in the usb drive. I have not try on linux pc yet but it work on window pc. the c3000 usb is version 1? or version 2? thanks. let me know if you know any driver/module install to make this work. Thanks.
omega
the usb host is only usb 1.1...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.