Help - Search - Members - Calendar
Full Version: Zbedic W/hentges Oz3.5.3
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
jnmonteiro
I am having a lot of trouble with zBedic finding my dictionaries. I have tried several of the suggestions from various newsgroups. From Settings & selecting the Dictionaries tab I select "Search for new dictionaries" and the search comes up empty. The manual suggests clicking on dictionary files in the FileManager - that does not work. One suggestion was to individually add each dictionary (with complete path) to zbedic.conf in the Settings directory (it works for one dictionary but for 2 this crashes). I have tried using the command line but that does not work. I tried using the 0.9.5 version with oz-compat & that does not work.

I keep my dictionaries in /mnt/card/home/root/Documents/applications/zbedic & I have linked to this directory in practically every directory older versions of zBedic searched for directory files.

What am I doing wrong???
tombraider
QUOTE(jnmonteiro @ Jun 6 2005, 04:47 PM)
I am having a lot of trouble with zBedic finding my dictionaries.  I have tried several of the suggestions from various newsgroups.  From Settings & selecting the Dictionaries tab I select "Search for new dictionaries" and the search comes up empty.  The manual suggests clicking on dictionary files in the FileManager - that does not work.  One suggestion was to individually add each dictionary (with complete path) to zbedic.conf in the Settings directory (it works for one dictionary but for 2 this crashes).  I have tried using the command line but that does not work.  I tried using the 0.9.5 version with oz-compat & that does not work.

I keep my dictionaries in /mnt/card/home/root/Documents/applications/zbedic & I have linked to this directory in practically every directory older versions of zBedic searched for directory files.

What am I doing wrong???
*



I know - very annoying that search for dictionaries doesn't work - works perfectly on my Sharp ROM.
So I had to add this extremely ridiculous long line to the zbedic.conf file. Just use something like Homesite or anything that does extended find and replace to change the path to YOUR path and, of course just the names of the dictionaries you use. I also have the wikipedia in a different path - on the cf card so change that or leave it out if you don't have wikipedia:

CODE
active-dictionaries = /media/cf/zbedic/wikipedia_en_20040610.dic.dz:/media/card/zbedic/en-0.8.3.dic:/media/card/zbedic/enfr-0.8.3.dic:/media/card/zbedic/enes-0.8.4.dic:/media/card/zbedic/fren-0.8.3.dic:/media/card/zbedic/laen-0.8.3.dic:/media/card/zbedic/esen-0.8.3.dic:/media/card/zbedic/wikiquote_20040424.dic.dz:/media/card/zbedic/textbook_20040611.dic.dz:


See if that works for you.
waalkman
QUOTE
See if that works for you.


Thanks! Just what I needed smile.gif
jnmonteiro
Thanks Tombraider!

It is long, takes time (to enter a bunch of dictionaries) but it works!

John
Hrw
try ~/Documents/application/bedic/
rafm
QUOTE(tombraider @ Jun 6 2005, 06:18 PM)
I know - very annoying that search for dictionaries doesn't work - works perfectly on my Sharp ROM.
So I had to add this extremely ridiculous long line to the zbedic.conf file.  Just use something like Homesite or anything that does extended find and replace to change the path to YOUR path and, of course just the names of the dictionaries you use.  I also have the wikipedia in a different path - on the cf card so change that or leave it out if you don't have wikipedia:

CODE
active-dictionaries = /media/cf/zbedic/wikipedia_en_20040610.dic.dz:/media/card/zbedic/en-0.8.3.dic:/media/card/zbedic/enfr-0.8.3.dic:/media/card/zbedic/enes-0.8.4.dic:/media/card/zbedic/fren-0.8.3.dic:/media/card/zbedic/laen-0.8.3.dic:/media/card/zbedic/esen-0.8.3.dic:/media/card/zbedic/wikiquote_20040424.dic.dz:/media/card/zbedic/textbook_20040611.dic.dz:


See if that works for you.
*


A new release (0.9.6), which is due in a few days, will fix this problem. One would be able to choose where to look for dictionaries.
rafm
QUOTE(rafm @ Jun 21 2005, 01:59 PM)
A new release (0.9.6), which is due in a few days, will fix this problem. One would be able to choose where to look for dictionaries.
*


Released!

Check http://bedic.sourceforge.net/
jnmonteiro
Thanks!

I will check it out.

John
Hrw
I will add it into upgrades feed.
Hrw
@rafm:

Could you check in zbedic does it have small or large screen available? Currently we will have to combine how to make package which will look OK on QVGA (collie, poodle, many ipaqs), VGA (c7x0, tosa etc), SVGA (simpad) screen.

Also input for enter dictionary path would be better if it will be filerequester... but then which one?

OPIE version of zbedic would be nice... smile.gif
rafm
QUOTE(Hrw @ Jun 28 2005, 12:14 PM)
Could you check in zbedic does it have small or large screen available? Currently we will have to combine how to make package which will look OK on QVGA (collie, poodle, many ipaqs), VGA (c7x0, tosa etc), SVGA (simpad) screen.

Also input for enter dictionary path would be better if it will be filerequester... but then which one?

OPIE version of zbedic would be nice... smile.gif
*


Re small/large screen: The only difference between SL5500 and Cx00 version is a set of icons. Under Sharp/CACKO ROM /opt/Qtopia/pics is for small screens and /opt/Qtopia/pics for large screens. Then Qtopia call Resource::loadPixmap automatically selects the proper set of icons. I guess a similar mechanism should be under OZ.

One more thing that may differ between devices is the keyboard shortcuts. But this is why I added keyboard customization dialog.

Re filerequester: I could not find any standard file requester for Qtopia. If there is one for OZ, fell free to add #ifdef OZ and a proper piece of code, then send me a patch so I include it in the distribution.
xamindar
This new version is asking for qpe-base as a dependancy. But I can't find it. Where is it?

*EDIT* Ok, so I forced it to install and am using it with the compat libs. Nice! But the config dialog acts kind of strange. blink.gif
rafm
QUOTE(xamindar @ Sep 4 2005, 11:27 AM)
*EDIT*  Ok, so I forced it to install and am using it with the compat libs.  Nice!  But the config dialog acts kind of strange. blink.gif
*

I don't have OZ, nor the whole develop. env. so I can not check it. It would be nice if there was somebody taking care of OZ releases of zbedic and fixing all those incompatibilities.

Does anybody know why OZ feed has an ancient version of zbedic (zbedic_20041227-r1_a..)? Hrw made an OZ binary for at least 0.9.4 but I can not find it.
Hrw
It's in upgrades feed:
http://openzaurus.org/official/unstable/3.....9.6-r1_arm.ipk
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.