Help - Search - Members - Calendar
Full Version: Firewall-settings For Os X Internetsharing Via Usb
OESF Forums > General Forums > Desktop Operating Systems Issues > Mac Issues
elwood151
Hi,

I'm trying to connect my Zaurus SL5500 (Sharp ROM 3.13 + Cacko Kernel patch) to the WWW and for the first step I want to use the USB/TCP-IP connection.

My Powerbook is connected via WLAN to our DSL router, I have internet sharing enabled on the PB and the Z can ping IP-numbers and urls like www.avm.de successfully.

However, the Z can only load a web page in Opera, if I disable the firewall on the PowerBook (OS 10.3.9).
I don't want to disable it completely - does anybody know how I have to configure the firewall for getting Opera on the Z working?

Best regards

Martin
jfv
You probably need to open port 80 on your powerbook's firewall. Open
System Preferences-> Sharing
On the "Services" tab (the first one), enable personal web sharing. This is for OS X.2, I don't know if it works on later versions.

Felipe
elwood151
QUOTE(jfv @ Jun 12 2005, 01:46 PM)
You probably need to open port 80 on your powerbook's firewall. Open
System Preferences->  Sharing
On the "Services" tab (the first one), enable personal web sharing. This is for OS X.2, I don't know if it works on later versions.

Felipe
*


Thanks! Now I can browse web pages on the Z with the Firewall enabled.

Bye,

Martin
qwerty
Hi,
I'm trying this too, but haven't gotten as far.
I installed the USB ethernet driver, gave my Z and my mac manual IPs (192.168.129.xxx). I can ssh back and forth between the two, but the Z can't find the internet (ping attempts give: address unreachable). I turned on internet sharing (of regular ethernet, to usb ethernet adapter) and my firewall is allowing port 80.
I've been hunting around and I think I might need to turn on ip forwarding on the z. (I found a page describing setting up a pppd on the usb and setting up a NAT using the iptables command which appearantly my Z doesn't have yet.)

The Z has OpenZaurus (really minimal, the person i bought it from flashed it) and the mac has 10.3 and is connected to a DSL modem.



QUOTE(elwood151 @ Jun 12 2005, 03:02 AM)
Hi,

I'm trying to connect my Zaurus SL5500 (Sharp ROM 3.13 + Cacko Kernel patch) to the WWW and for the first step I want to use the USB/TCP-IP connection.

My Powerbook is connected via WLAN to our DSL router, I have internet sharing enabled on the PB and the Z can ping IP-numbers and urls like www.avm.de successfully.

However, the Z can only load a web page in Opera, if I disable the firewall on the PowerBook (OS 10.3.9).
I don't want to disable it completely - does anybody know how I have to configure the firewall for getting Opera on the Z working?

Best regards

Martin
*

elwood151
QUOTE(qwerty @ Jul 7 2005, 04:07 PM)
Hi,
I'm trying this too, but haven't gotten as far.
I installed the USB ethernet driver, gave my Z and my mac manual IPs (192.168.129.xxx).  I can ssh back and forth between the two, but the Z can't find the internet (ping attempts give: address unreachable).  I turned on internet sharing (of regular ethernet, to usb ethernet adapter) and my firewall is allowing port 80.
I've been hunting around and I think I might need to turn on ip forwarding on the z. (I found a page describing setting up a pppd on the usb and setting up a NAT using the iptables command which appearantly my Z doesn't have yet.)

The Z has OpenZaurus (really minimal, the person i bought it from flashed it) and the mac has 10.3 and is connected to a DSL modem.


Hi qwerty,

I never tried OpenZaurus yet, so I'm not sure if it works the same way as the SharpROM concerning networking...

Try the following:

If the Zaurus and the Mac are connected and are able to ping each other,
open a terminal on the Z and type:

sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1

Then you should be able to ping a server on the web from the Z
(ping www.google.com ...)

Please try and give me feedback, if you were successful, and then we'll attack further steps. (I have some urgent work to do at the moment and for some weeks did not try to get further with my Z, so my memories what I tried and what helped for whatt aren't really "fresh" ;-( )

Best regards,

Martin
qwerty
thanks martin. I used those two commands and now the zaurus can ping other IPs. however, i can't ping names. I suppose i need to tell it where to find a dns server. My ethernet connection does not list a DNS in that TCP/IP pane.
elwood151
QUOTE(qwerty @ Jul 13 2005, 03:36 PM)
thanks martin.  I used those two commands and now the zaurus can ping other IPs.  however, i can't ping names.  I suppose i need to tell it where to find a dns server.  My ethernet connection does not list a DNS in that TCP/IP pane.
*


What I had to do in my SharpROM was adding in the file
/etc/resolv.conf

the line
nameserver 192.168.2.1

(with the IP-address of your router)

Hope that helps

Best regards

Martin
freizugheit
QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1


It should be su instead sudo.

The nameerver to be added in /etc/resolv.conf should be your ISP's name server.

Happy Surfing!
qwerty
thanks. I figured out su, although i'm running in root right now anyways (eep!).

How do I find my ISP's name server? DHCP isn't showing me a dns address in my mac's control panel.



QUOTE(freizugheit @ Jul 14 2005, 10:43 AM)
QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1


It should be su instead sudo.

The nameerver to be added in /etc/resolv.conf should be your ISP's name server.

Happy Surfing!
*

freizugheit
whois ispdomain
qwerty
thanks for being patient with my questions...still need more help...

so I got the IP for ns1.ameritech.net and added that as the first DNS. now "ns1.ameritech.net" seems to be the only address that I can ping by name. pinging any IP still works. tried a few other nameservers, but same problem.
what should /etc/resolv.conf look like at the end of the day?

This seems more like a general "using the internet" issue, than a zaurus problem, but hopefully someone can point me along.
samxiao
QUOTE(qwerty @ Jul 14 2005, 05:04 PM)
thanks.  I figured out su, although i'm running in root right now anyways (eep!).

How do I find my ISP's name server?  DHCP isn't showing me a dns address in my mac's control panel.



QUOTE(freizugheit @ Jul 14 2005, 10:43 AM)
QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1


It should be su instead sudo.

The nameerver to be added in /etc/resolv.conf should be your ISP's name server.

Happy Surfing!
*


*




try do that on your Mac terminal
QUOTE
$ cat /etc/resolv.conf
samxiao
where do i put those codes so everytime i reboot my Z, it will run them?


QUOTE
sudo route add -host 192.168.129.1 usbd0

and

sudo route add default gw 192.168.129.1
qwerty
/etc/resolv.conf on the mac (which can do all the web stuff fine) looks something like this (im at work right now):

domain no_domain_set.invalid
nameserver 192.168.0.1
nameserver 192.168.0.0


------------
EDIT: So, I think I fixed it. I added:
nameserver 192.168.0.1 to the /etc/resolv.conf file on the zaurus. thank you everyone.
sabes
I'm having a similar problem connecting my Nokia 770 via apple airport extreme to mac mini -- any ideas on the ports that should be open? nokia is clueless about this -- very pc-centric.
samot
Resuming what I did an worked (os sharp rom 3.1) was:

opening port 80 on the osx firewal

After geting good connection between the mac and the zaurus y started the internet sahring on the usb port.

On the zaurus:

sudo route add -host 192.168.129.1 usbd0

sudo route add default gw 192.168.129.1

if yo dont have sudo you can do "su -", root password and then: "route add..."
that shoud let you ping ip addresses. Yo still need to set the DNS

edit:
/etc/resolv.conf

and add your DNS server after nameserver, this is not your router server, its you ISP DNS.

(ie: nameserver 200.64.48.11)


Open Opera and voila!!!
icruise
I mentioned in this thread that I was able surf the Internet on my Zaurus using a bluetooth connection to my Mac. But somewhere along the line it stopped working (perhaps when I upgraded to Tiger). I could connect to the Mac and use things like FTP, but not surf the net. This thread made me realize that I had to open some ports in the firewall to get it to work again. I opened up ports 80 and 443 (for secure web sites) and now I am surfing with no problems.

(See the thread above if you want the bluetooth sharing scripts I used.)

Edit: After trying to enable this on another machine, I discovered that the port settings weren't really my problem, although they are helpful when setting up the firewall. By coincidence, the machine on which I was able to get this to work had Internet sharing (to its ethernet port from airport) enabled. It turns out that unless I have Internet sharing enabled, I can't use the Internet through the Zaurus, even though I have it set to an unrelated port. It's not a big deal to enable this, since I don't use the ethernet port anyway, but I was wondering if there was another way to do this.
freizugheit
samot,

I am glad to know that you enjoy surfing via Mac as your Internet gateway.

It further proves that those procedures that I have regularly used are correct.
samot
QUOTE(freizugheit @ May 3 2006, 01:55 AM)
samot,

I am glad to know that you enjoy surfing via Mac as your Internet gateway.

It further proves that those procedures that I have regularly used are correct.
*



Yes, what I wrote is basicly your instructions all in a same post to make it easier for reading. Thanks for your instructions. wink.gif
eji
Hey, this is great! Thanks. I got USB (en2) working in about thirty seconds. I'll fiddle with Bluetooth later on today.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.