Help - Search - Members - Calendar
Full Version: Zethereal-1.0-arm Not Compatible With Oz 3.5.3?
OESF Forums > General Forums > General Support and Discussion > Security and Networking
mcdelroy
Has anyone actually gotten Zethereal -1.0-arm to function on OZ 3.5.3? I attempted to follow the hints at http://www.irongeek.com/i.php?submenu=zaur...zaurus/sniffers

however they appear to contain huge gaps in the needed steps. With all libraries installed (apparently oz-compat is not sharp-compat-libs), when I click on the zethereal icon nothing happens. Running zethereal from a command link I get a message "undefined symbol: For _7QString.shared_null". When I try to install libqt-mt3_3.3.3-r5 I get a message unable to kill previous gunzip process message. I have rebooted and tried again.
mcdelroy
If it helps here are the steps I took in trying to get Zethereal up and running.

I installed the following in this order all using ipkdg –d ram

1. libpcap 0.8_0.8.3-r0
2. task-opie-minimal_1.0.3
3. opie-sh_0.5-20030824

4. I then tried to install oz-compat_0.5 but received messages that /etc/init.d/quickexec was not found. I thought that the install failed so I tried to install sharp-compat-libs_0.5-r2 which failed saying that many files were already supplied by oz-compat.

5. After running ipkg remove against oz-compat_0.5 I installed sharp-compat-libs_0.5-r2. However, during the install I received the /etc/init.d/quickexec not found errors.

5. I then tried to install oz-compat-opie_0.1 and received the /etc/init.d/quickexec not found errors.

6. libglib1.2_1.2.10-9
7. libglib_1.2.0
8. zethereal_1.0
9. I did not ipkg-link anything but zetheral_1.0
10. I created the links in /usr/lib mention at http://www.irongeek.com/i.php?submenu=zaur...zaurus/sniffers

ln -s /mnt/ram/usr/lib/libglib-1.2.so.0
ln -s /mnt/ram/usr/lib/libglib-1.2.so.0.0.10
ln -s /mnt/ram/usr/lib/libgmodule-1.2.so.0
ln -s /mnt/ram/usr/lib/libgmodule-1.2.so.0.0.10
ln -s /mnt/ram/usr/lib/libgthread-1.2.so.0
ln -s /mnt/ram/usr/lib/libgthread-1.2.so.0.0.10

11. Trying to open zethereal via the icon nothing happened.

11. Trying to run zethereal via the command link I received the _7QString.shared_null error zethereal.

12. I added LD_LIBRARY_PATH= "/media/ram/packages/usr/lib:/usr/lib/" to /etc/profile

13. Rebooted and tried zethereal from the command line again and received the same _7QString.shared_null error as before.


I am not averse to reflashing and starting my zethereal installs again so long as its clear what the sequence and required software/steps are.

Thanks for your help.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.