Help - Search - Members - Calendar
Full Version: Oz3.5.3 / 5600 / Linksys Wcf12
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
kmoorman
I'm OK with the default Sharp ROMs but what's the use of a having a linux driver PDA
like the Zaurus if you are only OK with it? Everything worked, including the
wifi card, but it just wasn't great. I tried the QTopia ROM upgrade that came out
recently---like the looks, everything works, but I cannot get Opera going. So, I installed
OZ3.5.3 (Opie) on my 5600. I like it a lot, especially after I found the comment on
how to keep the suspend problem from happening. My problem, though, is
that I cannot get the WiFi card to work.

When it comes up, it sees lo and irda as the only two interfaces. If I try
to start the wlan0 from the graphical, it errorrs. With ifup, I get a number of
errors about the device not being found. I have tried rebooting with the card in,
I've tried the initial boot with the card in---same result.

Any suggestions would be great---I have been trying various things on the
boards to no avail.

cardctl does report it as a linksys card so at the hardware level it is there.

Thanks,
Kenny
lardman
It ought to work (my wcf-12 always worked for me with 2.4.18).

What does lsmod show has been loaded?


Si
kmoorman
OK, so I guess I was just foolish but I did get it to work. I'd been reading a lot of postings about how incorrect kernels could lead to all sorts of problems :-). I'd never seen a warning about this when I booted, bit I had been using the 5600 PXA255 specific zImage file. I tried the other one and the card worked the first time.

Now, I just need to convince wellenreiter to run and not complain about a mismatch
of versions between the program and the interface :-)

Thanks,
Kenny
radioz
I saw this problem last night on my 3.5.3 Poodle.
Networking was working fine on either usb or my ethernet card. I don't remember the exact details, but I think I pulled out the enet card and installed my wireless card. The machine locked up, leading to a reboot.

Once it came up again, I had no interfaces defined in the list except lo and irda. Searching in /etc led to the discovery that the /etc/network/interfaces file had been blown away! I ended up re-installing (and making a backup copy of the interfaces file, just in case). I got my network connections back. I have not tried my wireless card yet.

Anybody else loose net connections when connecting/disconnecting?

radioz
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.