Help - Search - Members - Calendar
Full Version: Debian On Slc3000 With Cacko3kb1
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > X/Qt
perseus
Hello,

I know that there are already some x/qt debian topics on this forum. I have read through them but still have some issues. I decided to start this new topic in hopes that a more experienced Z user could help me through them. I am very new to Linux and Z, and no matter how much I read up on both - I can never learn fast enough.

So I installed X/Qt with Debian Script per meanie's site. Formatted my HDD3 to use a loopback and created a swapfile.

then to install I did this:

# zcat zaurus-debian-big-v0.17.tgz | tar xvf - -C /hdd3/debroot
# cd /hdd3/debroot
# pwd > /etc/debroot
# chown -R root:root etc
# chown -R root:root var
# chown -R root:root home
# mkdir -p mnt/card
# mkdir -p mnt/cf
# cp /etc/hosts etc
# cp /etc/resolv.conf etc
# vi startd

#!/bin/sh
### startup commands ###
export DISPLAY=0:0
/usr/bin/icewm-session
### shutdown commands
umount /mnt/card 2>/dev/null
umount /mnt/cf 2>/dev/null
umount /proc

# chmod 755 startd
# cd home
# ln -s ../root root
# mkdir zaurus
# cd ..
# cp -R INSTALL.d/debroot/root/.icewm home/zaurus
# cp INSTALL.d/debroot/usr/local/bin/* usr/local/bin
# cp INSTALL.d/native/bin/* /usr/local/bin
# cp INSTALL.d/native/debroot.conf /etc
# rm -r INSTALL.d

then this, because I could not get sudo to behave with cacko3KB1:

# su
# cp /home/zaurus/.xinitrc /home/root
# chown root:root /home/root/.xinitrc
# cd /hdd3/debroot/home
# cp -R zaurus/.icewm root
# cd /hdd3/debroot
# su -
# xlauncher debian

So here are the problems I am having after the installation....
perseus
I am unable to connect using my wireless card, connected and running under qtopia.

I have copied and modified the resolv.conf file wiht my correct DNS numbers.

I have removed and reinstalled about four times. The first time the internet worked but I had other error messages. The last 3 times, I cannot get the internet to work.

During the install process I have gotten some error messages that no matter what I do I cannot resolve. Could someone tell me what I am doing wrong?

so as per above everything goes well except:
# cd /hdd3/debroot
# pwd > /etc/debroot
# chown -R root:root etc
# chown -R root:root var
# chown -R root:root home

when I do chown -R root:root etc
and chown -R root:root var
I get a long list of files/directories with the message at the end: no such file or directory.

Sometimes one of them will work, not printing the error message, sometimes the other. I have never been able to get both of them to work.
I realized that if I spaced pwd>/etc/debroot etc, differently, I was able to get one of them to work.

Are these two issues why I cannot connect on line? What do these commands do?
Does anyone know how I can resolve this?

Thanks for taking the time.
omega
chown is change ownership... i think it changes the ownership of each of those directories to root.

in the command line have you tried pinging to see if the network connection is alive? also ifconfig...
perseus
Thanks for the info Omega.

Yes, I have tried ifconfig and it shows the wlan0 active:
if I do ifup wlan0 - I get an error message
I have also tried ifconfig wlan0 up and ifconfig wlan0
with no luck.

Anything else I can do?

Thanks again for taking the time.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.