Help - Search - Members - Calendar
Full Version: C1000, Annoying Rotation Problem
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
JohnX
I have OZ 3.5.3 flashed on my C1000. I'm very happy with it overall (much better than Sharp's ROM). I just have one nagging issue (which I suspect I caused):
Somehow I've managed to end up with the screen rotation 90° off from the screen rotation. For example: When I hit 'right' apps in Opie act like I hit 'up.' When I hit 'up' they act like I hit 'left.' Everything works correctly in a terminal (not a terminal window, but VT 1). So if someone can tell me how Opie keeps track of screen rotation in relation to keyboard orientation I would be eternally greatful. I don't need a step-by-step explanation. I'm perfectly happy to RTFM...I just couldn't find the FM in this case. wink.gif

-John
JohnX
OK, I just reflashed and I still have this problem. I deleted everything under /home/root before I reflashed. Is everyone having this problem? Is there something obvious that I missed?
jam13
QUOTE(JohnX @ Jun 20 2005, 07:59 PM)
I have OZ 3.5.3 flashed on my C1000.  I'm very happy with it overall (much better than Sharp's ROM).  I just have one nagging issue (which I suspect I caused):
Somehow I've managed to end up with the screen rotation 90° off from the screen rotation.  For example: When I hit 'right' apps in Opie act like I hit 'up.'  When I hit 'up' they act like I hit 'left.'  Everything works correctly in a terminal (not a terminal window, but VT 1).  So if someone can tell me how Opie keeps track of screen rotation in relation to keyboard orientation I would be eternally greatful.  I don't need a step-by-step explanation.  I'm perfectly happy to RTFM...I just couldn't find the FM in this case. wink.gif


If you are referring to the cursor pad being out by 90deg when the screen is in landscape, this is fixed by the latest version of the qt/e libs from the OZ feed (libqte2).

You might also want to update the kernel to the latest snapshot. This fixes the problems with certain keys (particularly the function key) not working. You'll get a warning when booting up, but it seems to work fine.

Both are located at:

http://www.openzaurus.org/official/unstable/3.5.3/upgrades/

--
Jamie
JohnX
Thank you! biggrin.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.