Help - Search - Members - Calendar
Full Version: X/qt Debian Icewm Questions
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > X/Qt
drnick
I've recently successfully gotten debian/Xqt working on my c3000with sharpROM. I used the pocketworkstation-big v18 eventhough most of the guides use v17 or earlier. I would like to change the font size of the icewm widgets. They show up HUGE. Ive read elsewhere that this is normal and I just need to edit my .icewm/preferences file and change the font size to .5. Ive looked through my preferences file and have found no mention of font size except for some lines that look like
CODE
Titlefont####-120-###
I know thats not exactly it because I'm at work without my Z. But it is similar. I tried changing the value from 120 to 12 and it still looks the same. I havent tried changing it to .5 yet. Can someone post their preferences from v17 or v18 so i can compare them or post a working preferences file with the fonts the appropriate size.

Also I tried to edit my startd file to use a different WM. I wanted to avoid icewm and just have a terminal show up. so i changed the entries that reference icewm to just launch a basic x-window setup (x-terminal-emulator & also x-window-manager &). I then launched debian from konsole in qt to read the messages. It prints messages about trying to load IceWM and then crashes. it printed something about not finding x-terminal-emulator and x-window-manager eventhough i checked to make sure they were available before i changed the startd file.

I changed my startd back to icewm and it launched normally with the HUGE text. So i tried out apt. i run apt-get update and it loads the repositories and stops at 98%. I know I can connecting to the internet because i can ping from within debian and most of the reposities load, it just stops at 98% on the last one. So I tried to edit my sources.list and change to repositories that I knew existed and work but I cant type a "/". Only a "," shows up weather I use shift or not. I changed my .xinitrc to fix the keymap. But perhaps I did it wrong. Maybe someone can post their working .xinitrc with the proper keymap? This would really help me fix the sources.list.

Thanks in advance for any help you guys can push my way.
Stubear
There is a bug in the X/Qt server 0.0.9 version which causes these problems.

You have 2 options - install 0.0.8 version of X/Qt or try the unstable 0.1.0 (0.0.10?) version.

Neither of them have the HUGE font issue. Much faster than spending hours trying to get your icewm preferences to work properly, cause then you'll have to change other app preferences too everytime you come across one with huge fonts.

Stu
drnick
Thanks Stubear.

I have everything working now. Here are my notes.

I added
CODE
ShowTaskBar=0
to my preferences file and edited my keys file so that Ctrl-t opened a new terminal. Now with a full screen terminal i edited my sources.list and removed the nonUS repository leaving only the debian testing repository. i then did an
CODE
apt-get update
and waited seemingly forever for it to complete. I then
CODE
apt-get install nano locales
. I chose nano because vi is a PITA for simple editing and i chose locales so that apt would stop erroring me about not finding the proper locale. (ive done this on my debian workstations for the same fix before). Since I didnt really want iceWM to begin with i installed xfce4 with an
CODE
apt-get install xfce4
. I exited debian from Qtopia using
CODE
killall Xqt
. Using the sharprom package manager i uninstall xqt-server .0.0.9 and rebooted. then I installed xqt-server .0.0.8 manually from an ipk. using the sharprom console i edited my startd file to add xfce4 to it.
CODE
/usr/bin/startxfce4
. I than ran debian from the terminal with
CODE
xlauncher debian
. and Viola! xfce4 starts with out a hitch with proper font sizes. To free up space i did an
CODE
apt-get remove icewm iceconf
and finished with an
CODE
apt-get clean
. Than from xterm i installed firefox with
CODE
apt-get install mozilla-firefox
.

Simply Awesome. Xfce4+firefox!
Leinadmx
Hi drnick !
Could you put an screenshot of your SL-C3000 desktop to see how looks:
Debian + xfce4 + Firefox ?

Best regards
drnick
QUOTE(Leinadmx @ Jun 29 2005, 03:36 PM)
Hi drnick !
Could you put an screenshot of your SL-C3000 desktop to see how looks:
Debian + xfce4 + Firefox ?

Best regards
*


I can tonight when I get back from work. But if you are curious now, it looks alot like this http://www.oesf.org/forums/index.php?act=A...ype=post&id=676 from the pdaX thread.
drnick
Here are two screenshots.
I took the screenshots by installing imagemagik with
CODE
apt-get install imagemagik

the imagemagick command is
CODE
import -window root screenshot.jpg
where screenshot.jpg is the name of the sceen saved.

With that out of the way here is my xfce4 desktop and firefox. also note that the xfce4 battery applet and wireless applet are installed and running. both work surprisingly enough. the battery says Zero because i had it plugged into the wall. I am using thunderbird with my SSL university mail, and Rox-Filer as my file manager.

I was going to just connect via VNC to take the screenshots but the 8bit color looked really bad. But imagemagik has done an excellent job. i couldnt get tightvncserver to work but x11vnc works just fine (albeit incredibly slow). both are available through apt.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.