Help - Search - Members - Calendar
Full Version: Installing Pdaxrom On Sl 5600?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
rockcat
I have been reading that most of the SL6000 users have had to install Guylhems ROM first, then pdaXrom (in order to resize the partition). However, the Guylhems ROM is only for the sl6000.

I tried to install pdaXrom (w/o resizing, using the SL6000 image, which recognizes my 5600) and got an error (a flash error I think). I then read the install guide on the website and used the NAND tools to resize the root partition to 45mb (before I read the post that told sl6000 users not to do this). I also tried a 47mb partition. The install eigther hangs when formatting the user partition, or, if I choose not to format the user partition it reboots. And it comes up with the OZ/GPE icon, but hangs indefinately. So it seems GPE is mostly gone, but pdaXrom has not fully/properly installed.

Any ideas what I can try - I am willing to experiment to figure this out, if anyone has suggestions.

Should I / can I attempt to undo the NAND resize?

Thanks for your time.

AJ Hines
rockcat
QUOTE(pgas @ Jul 7 2005, 03:51 PM)


Thats pretty much what I did. I tried it again, the install worked great, but it won't boot, just a flashing cursor with the OZ logo. "df" reported /dev/root as 6601 used, 921 free, and the only other partion on the device was /dev/shm. "uname -a" reports the kernel as 2.4.18-rmk7-pxa3-embedix.

I then tried to install the Wapaton ROM (sharp based), and the install was normal. However, the zaurus now sits on the Sharp "Please wait for approximately 2 minutes" screen. I reran df and uname -a and they appear the same as before.

Is it too late to ask the consequences of using the NAND utilities? Any ideas for my paperweight - I would really like to get pdaXrom working, it looks awesome.

AJ Hines

[EDIT]
Ok I got OZ/OPIE to install, I still have no /home partition. So is this caused by NAND (and how do I fix it) or is it an OZ issue?
pgas
hmm.
What are we talking about here?

The title says pdaxrom on 5600, the first post is about pdaxrom on 6000.
(my link is about pdaxrom on 6000)

And you are talking abbout OZ and watapon (on a 5600?) ???

Asking for oz/opie issued in the oz/common or oz/opie forum might be more effective.
rockcat
I see I was unclear, I did mean installing this on an SL-5600 (the SL-6000 flash recognizes my 5600, so I used that as the 2 are similar). However, since attempting to install pdaXrom, I've lost my home partition and can only get OZ to boot (perhaps it doesn't require a /home to fully boot), and I stil can't get pdaXrom to install.

So ...
1 - (prefered) How can I install pdaXrom?
or
2 - How can I restore my Zaurus to a "normal" partitioning scheme?

I've flashed OZ to Sharp and back many times, so I don't think this is OZ's problem.
pgas
hmm, i read the first post quickly sorry, it is about pdaxrom on 5600.

1- nobody has run pdaxrom on a 5600.
So no instructions wink.gif
at least you should avoid to put tools.tar (the kernel)

2- nand restore pretty uch is the only way to restore the partition scheme.
(well If you know the original scheme perhaps you could use the nand partion tool from the pdaxrom installer, but I 'm not sure if it allows to restore exactly the partitions.)
lanninmi
I was following this thread hoping that someone would find a way to install pdaXrom on a 5600. It does not seam like there has been much success. Is there support for the 5600 planned in near future?
mscdex
QUOTE(lanninmi @ Jul 13 2005, 12:27 PM)
I was following this thread hoping that someone would find a way to install pdaXrom on a 5600.  It does not seam like there has been much success.  Is there support for the 5600 planned in near future?
*


I was hoping someone would have gotten pdaxrom to work on the sl-5600 as well sad.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.