Help - Search - Members - Calendar
Full Version: Setting Up Wifi Problem/questions
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
Syrae
Okay. I flashed this SL5500 with the 3.5.3 and Hentages. It's all hunky-dory, but I can't figure out how to get the WiFi card to connect.

I have a WEP encrypted adhoc network, and I just can't seem to get the network settings happy. First off, it's confusing to me that there's both a wifi0 and a wlan0 device that are up and happy (my Zaurus is only connected to power at the moment.)

Okay, so I try to set wifi0. I set the mode, the ESSID, the channel, use encrypition with this key, and then set my static TCP/IP stuff. I try to ping another device on my network. It doesn't work, and I discover that the wifi0 device is getting no signal. I cannot stop it, because I get an error message saying it cannot be stopped. I try to configure the wlan0 device the same way as the wifi0 device. It does get a signal. (But it still cannot be stopped or restarted.)

What confuses me is that the signal is 64%, noise is 64%, quality is 0%, and the ESSID in the interface info window (under 802.11b) keeps refreshing every second with some weird set of characters appended onto the ESSID. For example, my ESSID is MYADHOC (very creative, I know.) the ESSID listed in this screen keeps showing the three ESSIDs:
MYADHOC2@
MYADHOCùe@Ì6
MYADHOCöÿ¿Ôöÿ¿Ôöÿ¿Ööÿÿÿÿ...

What the heck?

Anyhow, the ping reports no packets are received. The device I'm pinging is three feet away, and they're both away from any big EM producers. Something's up (because I could connect before I flashed) and I'm not entirely sure what's being unfriendly.
CoreDump
As a rule of thumb: Do not mess with "wifi0". Ever.
Trash /etc/network/interfaces or reflash the ROM and only touch the configuration of
"wlan0"
Syrae
QUOTE(CoreDump @ Jul 8 2005, 12:12 PM)
As a rule of thumb: Do not mess with "wifi0". Ever.
Trash /etc/network/interfaces or reflash the ROM and only touch the configuration of
"wlan0"
*

Mkay. I reflashed it, and set up wlan0 to be what it should be. Quality is now at 100%, and the funky ESSID is still happening. Ping reports that "sendto: Network is unreachable" I checked again... it's down. I try to start the interface for wlan0 and get "Starting interface failed." The info returned by iwconfig all looks fine. tongue.gif

Thanks CoreDump for helping. At least my quality is better now.
rrnwexec
QUOTE(Syrae @ Jul 8 2005, 01:48 PM)
QUOTE(CoreDump @ Jul 8 2005, 12:12 PM)
As a rule of thumb: Do not mess with "wifi0". Ever.
Trash /etc/network/interfaces or reflash the ROM and only touch the configuration of
"wlan0"
*

Mkay. I reflashed it, and set up wlan0 to be what it should be. Quality is now at 100%, and the funky ESSID is still happening. Ping reports that "sendto: Network is unreachable" I checked again... it's down. I try to start the interface for wlan0 and get "Starting interface failed." The info returned by iwconfig all looks fine. tongue.gif

Thanks CoreDump for helping. At least my quality is better now.
*



From the sounds of it, the settings that relate to WEP are wrong. The opie-networkapplet is notorious for creating bad config files.

My suggestion is that you post your /etc/network/interfaces file here so the net geeks can examine it and help you out. Please sanitize your WEP key in the posting first please. Change it to something different from your real one.

Best Regards,
Randall.
CoreDump
The newtork settings work alright, however, they sort-of expect a HEX WEP key, not an ASCIII one.

ASCII keys need to be prefixed with "s:". So if your WEP key is "rootme", you'd enter
"s:rootme" in the network settings, not "rootme".
rrnwexec
QUOTE(CoreDump @ Jul 9 2005, 08:40 AM)
The newtork settings work alright, however, they sort-of expect a HEX WEP key, not an ASCIII one.

ASCII keys need to be prefixed with "s:". So if your WEP key is "rootme", you'd enter
"s:rootme" in the network settings, not "rootme".
*



The network settings applet is definitely broken under OZ/Opie 3.5.3 on at least the SL-6000L, maybe on other models too.
Syrae
QUOTE(CoreDump @ Jul 9 2005, 07:40 AM)
The newtork settings work alright, however, they sort-of expect a HEX WEP key, not an ASCIII one.

ASCII keys need to be prefixed with "s:". So if your WEP key is "rootme", you'd enter
"s:rootme" in the network settings, not "rootme".
*

My key was the equivalent of 1234abcd1234abcd1234abcd12 (but using the real key and not a dummy hex one.) I assumed it wanted a hex key.

I used iwconfig to look at the settings, and they seemed sane enough to me....

Lemme grab the /etc/network/interfaces file...
Syrae
/etc/network/interfaces (Sanitized)
CODE
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo wlan0 usbd0
iface lo inet loopback

# Wireless interfaces
iface wlan0 inet static
    gateway 10.1.10.1
    netmask 255.255.255.0
    address 10.1.10.190
    wireless_key 1234abcd1234abcd1234abcd12 [1]  [2]  [3]  [4] open key [1]
    wireless_channel 1
    wireless_mode Ad-Hoc
    wireless_essid MYADHOC
iface atml0 inet dhcp

# Wired or wireless interfaces
iface eth0 inet dhcp
iface eth1 inet dhcp

# Ethernet/RNDIS gadget (g_ether)
# ... or on host side, usbnet and random hwaddr
iface usb0 inet dhcp

# Zaurus 2.4 Lineo net_fd; obsolete
iface usbd0 inet static
    netmask 255.255.255.0
    address 192.168.129.201

# iPAQ 2.4 mach-sa1100/usb-eth
# (192.168.0.202 is the iPAQ's IP, 192.168.0.200 is the host's IP)
iface usbf inet static
       address 192.168.0.202
       netmask 255.255.255.0
       network 192.168.0.0
       gateway 192.168.0.200

# Bluetooth networking
iface bnep0 inet dhcp
rrnwexec
Suggest that you try replacing your #Wireless Interfaces section as follows:

CODE
# Wireless interfaces
iface wlan0 inet static
       gateway 10.1.10.1
       netmask 255.255.255.0
       address 10.1.10.190
       wireless_essid MYADHOC
       wireless_type wlan-ng
       wireless_mode Ad-Hoc
       wireless_enc on
       wlan_ng_priv_key128 true
       wlan_ng_key0 12:34:ab:cd:12:34:ab:cd:12:34:ab:cd:12
       wlan_ng_authtype opensystem


Please let me know how it goes. Good luck.
Syrae
No dice. No change that I can see either.


Is there any way for me to see if it's working without having to ping the other device? I haven't touched the other device at all since I've gotten connections to it working with the Zaurus earlier, but I keep feeling like it randomly decided to change all its settings. Its wireless has a slightly different setup, and I'm trying to figure out how to make sure its settings are happy as well.

*looks at a few things...* Interesting...

Here's the result of me doing iwconfig on the Z:
CODE
wifi0     IEEE 802.11b  ESSID:"any"
         Mode:Managed  Frequency:2.422 GHz  Access Point: 44:44:44:44:44:44
         Bit Rate:2 Mb/s   Sensitivity=1/3
         Retry min limit:8   RTS thr:off   Fragment thr:off
         Encryption key:off
         Power Management:off

wlan0     IEEE 802.11b  ESSID:"any"
         Mode:Managed  Frequency:2.422 GHz  Access Point: 44:44:44:44:44:44
         Bit Rate:2 Mb/s   Sensitivity=1/3
         Retry min limit:8   RTS thr:off   Fragment thr:off
         Encryption key:off
         Power Management:off
         Link Quality=0/92  Signal level=-90 dBm  Noise level=-90 dBm
         Rx invalid nwid:0  Rx invalid crypt:5  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:527   Missed beacon:0


It says it's not configured at all... odd... huh.gif
rrnwexec
QUOTE(Syrae @ Jul 12 2005, 10:32 AM)
No dice.  No change that I can see either.


Is there any way for me to see if it's working without having to ping the other device?  I haven't touched the other device at all since I've gotten connections to it working with the Zaurus earlier, but I keep feeling like it randomly decided to change all its settings.  Its wireless has a slightly different setup, and I'm trying to figure out how to make sure its settings are happy as well.

*looks at a few things...*  Interesting...

<snip>

It says it's not configured at all... odd... huh.gif
*


I was under the impression that you were trying to do an Ad-Hoc connection (peer-to-peer). Is that the case?

If not, you will need to change the line that reads:
wireless_mode Ad-Hoc
to
wireless_mode Managed

and you will need to ensure that your ESSID's match.

I'll think this over a bit more, but in the meantime please give it a try.
Syrae
That's what I did try to do... what confused me is that I set things, and then... everything unset themselves back to default. No encryption, wrong frequency, wrong essid, wrong mode, everything. I'm manually updating everything using iwconfig at the moment. I'm going through the man page and changing everything that needs to be changed. I'm down to mode at the moment.

It seems like /etc/network/interfaces didn't stick or get used or something... If I look in the network settings panel on the Z, all the settings are there, but if I look at iwconfig, there is nothing set, so SOMETHING is not coherent here.
Syrae
Mkay... I set it with iwconfig. The results of ifconfig look good. I still can't say hello, though.

I tried restarting the device, and all the settings in iwconfig for wlan0 got wiped out again. huh.gif
rrnwexec
QUOTE(Syrae @ Jul 12 2005, 11:08 AM)
Mkay... I set it with iwconfig.  The results of ifconfig look good.  I still can't say hello, though.

I tried restarting the device, and all the settings in iwconfig for wlan0 got wiped out again. huh.gif
*



A couple of suggestions/observations...
The settings that you enter manually using iwconfig won't be retained between restarts.
The Network Settings applet should be avoided. I've seen it trample perfectly good config files.

I'd start by using a text editor to edit /etc/network/interfaces. Then use "ifup wlan0" to bring up and test. Check what happened with iwconfig and ifconfig. If things don't look right, then re-edit the interfaces file, issue "ifdown wlan0" and "ifup wlan0" and repeat...

Keep trying.... and let me know how it goes...

Cheers,
Randall.
Syrae
Okay, I didn't know that iwconfig changes weren't permanent. I'm just trying anything at the moment. tongue.gif

So... what I need to do is figure out the right syntax for the interfaces file because at the moment, it's not recognizing anything that has to do with the wireless as far as I can tell. Is there some good source pertaining to that?
Syrae
I just noticed two things....
CODE
wlan0     Link encap:Ethernet  HWaddr 00:05:5D:F9:C9:11
         inet addr:10.1.10.190  Bcast:10.255.255.255  Mask:255.255.255.0
         inet6 addr: fe80::205:5dff:fef9:c911/10 Scope:Link
         UP BROADCAST MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0 B)  TX bytes:720 (720.0 B)
         Interrupt:35

1. No where there does it say that it's "RUNNING"
2. My other device uses 10.1.10.255 for its broadcast IP, and I'm sure that discrepancy can't help.

...I changed the broadcast address in /etc/network/interfaces, so that's "fixed" now. I still don't know how to make it say "RUNNING" though.
rrnwexec
QUOTE(Syrae @ Jul 12 2005, 02:05 PM)
...I changed the broadcast address in /etc/network/interfaces, so that's "fixed" now.  I still don't know how to make it say "RUNNING" though.
*


What is the output of "iwconfig wlan0"? That should help verify that the wireless link (with WEP) is solid.

Can you ping the Zaurus itself, and the other device? What is the output of ping?

Seems that you are getting closer....
Syrae
Thanks Randall. I have no idea why I am having so many issues. Probably because I'm doing a non-standard set up, huh?



The settings in the /etc/network/interfaces file are exactly as you gave them to me (with the exception that I added a "broadcast 10.1.10.255" line).
CODE
# Wireless interfaces
iface wlan0 inet static
      gateway 10.1.10.1
      netmask 255.255.255.0
      address 10.1.10.190
      broadcast 10.1.10.255
      wireless_essid ADHOCTEST
      wireless_type wlan-ng
      wireless_mode Ad-Hoc
      wireless_enc on
      wlan_ng_priv_key128 true
      wlan_ng_key0 12:34:ab:cd:12:34:ab:cd:12:34:ab:cd:12
      wlan_ng_authtype opensystem


Those settings do not seem to be getting picked up.
CODE
root@zaurus:~# iwconfig wlan0
Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 17, therefore some driver features
may not be available...

wlan0     IEEE 802.11b  ESSID:"any"
         Mode:Managed  Frequency:2.422 GHz  Access Point: 44:44:44:44:44:44
         Bit Rate:2 Mb/s   Sensitivity=1/3
         Retry min limit:8   RTS thr:off   Fragment thr:off
         Encryption key:off
         Power Management:off
         Link Quality=0/92  Signal level=-90 dBm  Noise level=-90 dBm
         Rx invalid nwid:0  Rx invalid crypt:8  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:1569   Missed beacon:0


The Zaurus can see itself at least...
CODE
root@zaurus:~# ping -c 5 10.1.10.190
PING 10.1.10.190 (10.1.10.190): 56 data bytes
64 bytes from 10.1.10.190: icmp_seq=0 ttl=255 time=0.9 ms
64 bytes from 10.1.10.190: icmp_seq=1 ttl=255 time=0.3 ms
64 bytes from 10.1.10.190: icmp_seq=2 ttl=255 time=0.3 ms
64 bytes from 10.1.10.190: icmp_seq=3 ttl=255 time=0.3 ms
64 bytes from 10.1.10.190: icmp_seq=4 ttl=255 time=0.3 ms

--- 10.1.10.190 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 0.3/0.4/0.9 ms


Ping from Zaurus to other device...
CODE
root@zaurus:~# ping -c 5 10.1.10.24
PING 10.1.10.24 (10.1.10.24): 56 data bytes

--- 10.1.10.24 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss


Ping from my other device to the Zaurus...
CODE
nodedev-24:/root# ping -c 5 10.1.10.190
PING 10.1.10.190 (10.1.10.190) from 10.1.10.24 : 56(84) bytes of data.
From 10.1.10.24 icmp_seq=1 Destination Host Unreachable
From 10.1.10.24 icmp_seq=2 Destination Host Unreachable
From 10.1.10.24 icmp_seq=3 Destination Host Unreachable
From 10.1.10.24 icmp_seq=4 Destination Host Unreachable
From 10.1.10.24 icmp_seq=5 Destination Host Unreachable

--- 10.1.10.190 ping statistics ---
5 packets transmitted, 0 received, +5 errors, 100% loss, time 4027ms
, pipe 3
rrnwexec
QUOTE(Syrae @ Jul 12 2005, 02:46 PM)
Thanks Randall.  I have no idea why I am having so many issues.  Probably because I'm doing a non-standard set up, huh?


A couple of things I noticed...
Are you indeed trying peer-to-peer (ad-hoc), or is there an Access Point in the setup? If you have an Access Point, you'll need to replace:
QUOTE
wireless_mode Ad-Hoc
with
QUOTE
wireless_mode Managed

And you'll need to use the same ESSID, so replace the string in
QUOTE
wireless_essid ADHOCTEST
with your real string.

Also, what is the exact make and model of your wifi card? We may have some driver issues.

Cheers,
Randall.
Syrae
Yes, I am, in fact, doing Ad-hoc. The other device is one of many little "mote" like devices that are supposed to be apart of a larger sensor network. Frankly, I just want to say hello, and I'd be happy at this point. The ESSID is correct for the ad-hoc network that I have setup.

The card I'm using is a D-Link DCF-650W CF card. It's a bit older, but so is my Zaurus. tongue.gif

Do you know why my /etc/network/interfaces has the wireless stuff set but iwconfig shows it all as default? That is what's bugging me the most at the moment....
rrnwexec
QUOTE(Syrae @ Jul 12 2005, 03:14 PM)
Do you know why my /etc/network/interfaces has the wireless stuff set but iwconfig shows it all as default?  That is what's bugging me the most at the moment....
*


Thanks for clarifying. I have a couple of theories.

First, it might be that Hentges ROM uses a different network settings file... If you are not tied to that ROM, I've had good success with OZ/Opie 3.5.3, and know that it uses /etc/network/interfaces ... you could try a re-flash and go with Opie.

A second theory is that your D-Link DCF-650W CF card needs something other than wlan_ng drivers. I'll need to do some research on that one. If that turns out to be the case, some modifications to the settings file will be needed.

In a perfect world, we could find someone who's using your exact ROM and card to weigh in with their knowledge, but perhaps we can get this figured out...
Syrae
Really, I don't care what ROM I use as long as it works. I don't have anything on the Z at the moment, so I don't mind mucking with it. The reason I'm on Hentages at the moment is because OZ 3.5.3 (GPE and Opie) borks my Collie with anything other than Hentages. It gets stuck at start up after the initial flash. I know the first start up is supposed to take a while, but 3 hours stuck on the same screen gets annoying after a while. dry.gif

I could probably safely downgrade to 3.5.2, though.

Oh, and thanks. biggrin.gif I really do appreciate you sticking with this thread that won't get resolved. rolleyes.gif
rrnwexec
QUOTE(Syrae @ Jul 12 2005, 03:42 PM)
Really, I don't care what ROM I use as long as it works.  I don't have anything on the Z at the moment, so I don't mind mucking with it.  The reason I'm on Hentages at the moment is because OZ 3.5.3 (GPE and Opie) borks my Collie with anything other than Hentages.  It gets stuck at start up after the initial flash.  I know the first start up is supposed to take a while, but 3 hours stuck on the same screen gets annoying after a while.  dry.gif

I could probably safely downgrade to 3.5.2, though.

Oh, and thanks.  biggrin.gif I really do appreciate you sticking with this thread that won't get resolved.    rolleyes.gif
*



Hmm. If I were in your shoes, and had essentially no loyalty to your current ROM, I'd reflash to OZ/Opie 3.5.3 pronto!

I've tested it successfully on the 5500, 5600, 6000 and can vouch for its greatness wink.gif

I've heard of issues reflashing, but those seem to occur when the ROM files are only partially downloaded and/or corrupted. Be sure to check that your downloded ROM files are exactly the size they should be.

The ROM files are available at:http://www.openzaurus.org/official/unstabl.../sl5000,sl5500/.

There are excellent installation instructions at:
http://openzaurus.org/wordpress/installation/sl-50005500/.

A re-flash of your 5500 should take less than 5 minutes, once you have the ROM image ready on a CF card.

Once you have OZ/Opie up and running, go straight to the /etc/network/interfaces file and make the edits that you are now an expert on wink.gif ... beware the Network Settings applet. It has issues.

May the force be with you...

Cheers,
Randall.
Syrae
QUOTE(rrnwexec @ Jul 12 2005, 03:05 PM)
May the force be with you...

I respect you, like, 100x more now... laugh.gif

I'm gonna reflash tomorrow when I get into work. Did you test with the new release from June 30 or the older version of 3.5.3?
rrnwexec
QUOTE(Syrae @ Jul 12 2005, 04:13 PM)
QUOTE(rrnwexec @ Jul 12 2005, 03:05 PM)
May the force be with you...

I respect you, like, 100x more now... laugh.gif

I'm gonna reflash tomorrow when I get into work. Did you test with the new release from June 30 or the older version of 3.5.3?
*



Thanks. wink.gif

I tested with the original 3.5.3 release, not the June update.

Cheers,
Randall.
Syrae
Mkay. I reflashed with Opie and 3.5.3 (not June update).

I edited the /etc/network/interfaces file to set the info to be the same stuff I was using in the last post. I shut down wlan0 and used ifup wlan0 to start it up.

ifconfig shows everything is fine, but iwconfig still shows everything at its default settings.

I'm having the same exact problem with this as I did with the other ROM. Basically, if you want to see the current results of everything, they look EXACTLY like the stuff that I posted yesterday at 1:46pm. sleep.gif *sighs*

I feel so stupid and helpless. sad.gif

There has to be something stupid that I am doing.
rrnwexec
QUOTE(Syrae @ Jul 13 2005, 12:13 PM)
Mkay.  I reflashed with Opie and 3.5.3 (not June update).

I edited the /etc/network/interfaces file to set the info to be the same stuff I was using in the last post.  I shut down wlan0 and used ifup wlan0 to start it up.

ifconfig shows everything is fine, but iwconfig still shows everything at its default settings.

I'm having the same exact problem with this as I did with the other ROM.  Basically, if you want to see the current results of everything, they look EXACTLY like the stuff that I posted yesterday at 1:46pm. sleep.gif  *sighs* 

I feel so stupid and helpless. sad.gif

There has to be something stupid that I am doing.
*


I doubt that it's anything you're doing (or not doing).

Please power up your 5500 with the wireless card unplugged. Get a terminal prompt. Now type: dmesg. Insert the card and type dmesg again.

You should notice some lines of output that were generated as a result of plugging in the card. Copy them and send them here. Might provide us with some more clues about what's happening. My suspicion at this point is faulty card or wrong drivers.

Thanks,
Randall.
Syrae
QUOTE(rrnwexec @ Jul 13 2005, 12:44 PM)
<snip>

My suspicion at this point is faulty card or wrong drivers.

I do have two of these cards... I also have access to a few more if it's just the card. For the heck of it, I switched to the other card for this test. Since they should be identical, either it will work, or it'll still be stupid. (It appears that the latter is the case.)

Okay... I just noticed that the card icon at the bottom detects it as a "ZCOMAX AirRunner/XI-300". That's definately not the right card. I'm confused because on the older version of OZ/Opie, it worked just fine. (A year or two old version.)

The dmesg difference is:
CODE
hostap_crypt: registered algorithm 'NULL'
hostap_cs: 0.3.7 - 2005-02-12 (Jouni Malinen <jkmaline@cc.hut.fi>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: CS_EVENT_CARD_INSERTION
hostap_cs: ignoring Vcc=33 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
io->flags = 0x0046, io.base=0x0000, len=64
hostap_cs: Registered netdevice wifi0
hostap_cs: index 0x01: Vcc 3.3, irq 35, io 0xc4860000-0xc486003f
prism2_hw_init: initialized in 110 ms
wifi0: NIC: id=0x8002 v1.0.0
wifi0: PRI: id=0x15 v0.3.0
wifi0: STA: id=0x1f v0.8.3
wifi0: defaulting to bogus WDS frame as a workaround for firmware bug in Host AP mode WDS
wifi0: registered netdevice wlan0
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
  retry_count=0 tx_rate=0 fc=0x0108 (Data::0 ToDS)
  A1=00:00:00:00:00:00 A2=00:05:5d:f9:92:21 A3=33:33:ff:f9:92:21 A4=00:00:00:00:00:00
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
  retry_count=0 tx_rate=0 fc=0x0108 (Data::0 ToDS)
  A1=00:00:00:00:00:00 A2=00:05:5d:f9:92:21 A3=33:33:00:00:00:02 A4=00:00:00:00:00:00
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
  retry_count=0 tx_rate=0 fc=0x0108 (Data::0 ToDS)
  A1=00:00:00:00:00:00 A2=00:05:5d:f9:92:21 A3=33:33:00:00:00:02 A4=00:00:00:00:00:00
wifi0: TXEXC - status=0x0004 ([Discon]) tx_control=000c
  retry_count=0 tx_rate=0 fc=0x0108 (Data::0 ToDS)
  A1=00:00:00:00:00:00 A2=00:05:5d:f9:92:21 A3=33:33:00:00:00:02 A4=00:00:00:00:00:00
wlan0: no IPv6 routers present

It correctly identifies my card as a Prism/2 card. I went and looked up info on my card...

Kismet reports this:
Card: D-Link DCF-650W
Chipset: Prism/2
Description: D-Link Compact Flash
Driver: wlan-ng/hostap
Confirmed Working: Yes

The Zaurus user's group says:
Vendor Model: DLink DCF-650W
Chipset: Prism 2
Supported: Yes
Blocks Ports: Yes
Standby/rx/tx ma: 170/280/380

My card is a fairly common card, but having the system seem to misidentify it doesn't make me feel very good. In theory the XI-300 it misidentified as has the same chipset and drivers, so it shouldn't be so... irritable, but I don't rememeber seeing the misidentification before on the Hentages ROM. Whether it's because I just missed it, or if it's a new issue, I don't know.
Syrae
Oh! I found something!!! I looked through /etc/pcmcia/config and I found out that it doesn't have an entry for my card at all!!! That's probably a good thing to discover and something that doesn't help much. Assuming that /etc/pcmcia/config is the file used to identify devices, that would probably explain why it's not finding the right card. The XI-300 is in there.

CODE
card "ZCOMAX AirRunner/XI-300"
 #version "ZCOMAX", "AirRunner/XI-300"
 manfid 0xd601, 0x0002
 bind "orinoco_cs"


Since no one seems to use the prism2 stuff and all the prism2 cards are using orinoco_cs, that's probably what I should use. I can edit config.opts to add my card to the list, and hopefully, things would work better? I run cardctl ident and I get
CODE
Socket 0:
 product info: "D-Link", "DCF-650W", ""
 manfid: 0xd601, 0x0002
 function: 6 (network)
Socket 1:
 no product info available


It looks like it's misidentifying my card because the manfid is the same as the XI-300. I feel like adding this in, though, is just gonna change the text string identifier and not really make things any different in the actual operation. sleep.gif

I also noticed that I do not have a /etc/pcmcia/wlan-ng.conf file... Is that right? Is there a way for me to easily figure out if I have wlan-ng?
rrnwexec
QUOTE(Syrae @ Jul 13 2005, 03:01 PM)
Oh!  I found something!!!  I looked through /etc/pcmcia/config and I found out that it doesn't have an entry for my card at all!!!  That's probably a good thing to discover and something that doesn't help much.  <snip>



I've been noticing a lot of people using host_ap for your card. I've seen some reference to bugginess in the orinoco drivers. Still figuring out how to control what host_ap does, but that might be a starting point.

I concur that getting a good entry for your card in your config file is also a must. Perhaps there is a sample out there that can be copied.

Cheers,
Randall.
Syrae
Bah.. BAH! I SAY!

Okay, I added an entry to config.opts.
CODE
#Attempt to get the D-Link DCF-650W working
card "D-Link DCF-650W"
 version "D-Link", "DCF-650W"
 manfid 0xd601, 0x0002
 #bind "orinoco_cs"
 bind "host_ap"


I'm having odd problems, though, which highlight that I have no real idea of what I'm doing. When I first added the entry, I didn't have the host_ap line, and the orinoco_cs line was uncommented. I popped in the card after it started up and it recognized it fine. The output of dmesg, ifconfig, and iwconfig basically said that it was bound to eth0. I thought that was funky, so I edited config.opts to what you see above. At that point it started recognizing it as the XI-300 again. I got frustrated, and uncommented out the XI-300 lines in /etc/pcmcia/config and it still recognized it as the XI-300, so I rebooted the Z. More or less, I did a bunch of commenting and uncommenting, and it feels like it randomly detects the right card only about 25% of the time, and only when it's bound to orinoco. (Of course, there is the irritating problem that the Z only restarts properly about 25% of the time as well, and that seems to be completely random. I have to keep using the restart button in the battery compartment. dry.gif )

Okay... I am absolutely sure that it misidentifies the card as the XI-300 when I try to bind the DCF-650W to host_ap instead of orinoco. Fine. Tomorrow I will edit /etc/network/interfaces to define the eth0 adapter have the same info as the wlan0 adapter and hope it works that way. Sheesh. tongue.gif

I know if it's misidentifying my card as a card that I have COMPLETELY commented out, then there's some other file in the mix that I don't know about that's messing things up.
Syrae
Yay!!! I bent a pin inside the CF slot!!! dry.gif

I don't think I was meant to succeed... tongue.gif
Syrae
I unbent the pin (using this handy dandy plastic knife) and plugged in the card. Despite it being recognized and using the orinoco_cs drivers, it's still not pulling the wireless configuration info from /etc/network/interfaces. I really think that either the syntax is just plain wrong or it needs to go in a different file.
Syrae
For hostap_cs there is a .o file for it in /lib/modules/2.4.18-rmk7-pxa3-embedix/pcmcia/ but, there is no entry for the driver in the /etc/pcmcia/config file, which would explain why I can't use that driver. It's simply not defined. This is getting WAY too complicated.
Syrae
Just ignore me, I'm rambling now, and I think I have enough tools in my little mini Linux toolbox now to be able to track down my wireless problem... smile.gif

Okay, I tried using a totally different and newer wireless card I canabalized off a different device... (Mwahahahahaa... *rubs hands maniacally*) Unfortunately, it uses the default settings as well (for wlan0). Obviously whatever script that goes through and reads /etc/network/interfaces just doesn't like the syntax.

I dug around some more and I found this little Debian script over in /etc/network/if-pre-up.d/wireless-tools:
CODE
# Detect and do nothing for linux-wlan-ng interfaces;
# which are configured by thier own if-pre-up script.
if [ -n "$IF_WIRELESS_TYPE" -a "$IF_WIRELESS_TYPE" = "wlan-ng" ]; then
 exit 0
fi


Well, that probably doesn't help.... It could be that the script is just detecting that I'm trying to use wlan_ng and it just exits as soon as it sees that, and no other script takes over. Frankly, there are no other scripts in if-pre-up.d and no other pre-up stuff, so I think that there is nothing there to handle wlan-ng that I can see easily. Kay, I don't need to use wlan_ng, I just want it to work and get set properly.

The driver that my current test card uses appears to be hostap_cs, so that means it's a more advanced version of the prism2_cs driver. That means that I don't have to use wlan_ng to get it set up.



* * * * *


Update: I have WiFi working with this Linksys card. My conclusion is that:

1) The D-Link DCF-650W, though supported previously (or was just lucky to get set right previously), is not currently supported.

2) You have to manually set the /etc/network/interfaces file to get things right.

3) DON'T use wlan_ng. If the driver uses hostap_cs, then don't. Most cards use hostap over prism2 now, and prism2 is the one that used wlan_ng.

4) The syntax for the wireless is moderately simple. It's pretty much "wireless_<function> <value>" where the function is one of the parameters for iwconfig like essid or key. For a list of iwconfig parameters and valid values, see the iwconfig man page.

5) You can tell what cards are and aren't supported by looking through the files in /etc/pcmcia. An easy way to check is find the manufacturer of your card like Linksys or D-Link. You can look to see if it's generally supported by typing cat /etc/pcmcia/config | grep "Linksys", where Linksys is the name of your card's manufaturer (and it's case sensitive.) To see if it's supported by hostap, type cat /etc/pcmcia/hostap_cs.conf | grep "Linksys". If your exact card shows up on the list, then your card is supported. For example, I have a Linksys card with a model number of WCF12, and I see a line in the output of both commands that says card "Linksys WCF12 Wireless CompactFlash Card", so it's supported by both the general recognition as well as the hostap driver.



I fixed it! To bad I just didn't know it was because it wasn't supported and the script was broken, then the second script wasn't correct for this enviroment. tongue.gif
SteveConley
(Poodle, 1GB TopRam SD, 1GB SimpleTech CF, Socket LP Wlan CF)

Although in other forums I find reference to the fact that the Socket (Spectrum24) wireless drivers are "out of the box" in OpenZaurus - I can't find the box.

/etc/pcmia/config has no mention of the card which has this signature:
Socket
CF+ LP WLAN Card Rev A 1.00
MANFID 0x104 0x0001 function 6 (network)

when you do a cardctl ident.

I find no mention of the drivers in the feed.

When I insert (or boot) with the card in the CF slot, it say "unsupported device" on the eject bar.

This card worked under Sharp's ROM - although WEP didn't, of course.

Any clues?

Thanks.
djacco
yet another question,
I got a z860 secondhand it had pdaxrom on it and I flashed to cacko 1.22
my linksys wcf-12 is having trouble connecting to the open neighbourhood network ... Card is recognized bij de Z and I set everything the same as my laptop with connenction (win xp) but still no connection on the zaurus ... light is flashing for a few seconds and then dies out with the message connection was failed ...

these are my settings:
ssid: linksys
network: infrastructure
wep: disable
pppnoe: nothing set
web auth: nothing set
ip: automatic
dns: automatic
proxy: none


So HELP ! I have no clue where to start looking or what to do :-)
berte74
QUOTE(Syrae @ Jul 12 2005, 10:44 AM)
Okay, I didn't know that iwconfig changes weren't permanent.  I'm just trying anything at the moment.  tongue.gif

So...  what I need to do is figure out the right syntax for the interfaces file because at the moment, it's not recognizing anything that has to do with the wireless as far as I can tell.  Is there some good source pertaining to that?
*



I realize you have probably long since resolved the issue, but recently it was discovered that the Opie network config app basically lies and does not make setting changes quite often. We ended up simply using iwconfig in all cases and that seems to work properly.

Our project uses multicast and we have set the IPs static, would you happen to know how the route tables can be configured automatically? This is done manually for now, but is a hassle when a Zaurus is rebooted.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.