Like the title puts it, I have an SL5600 unit, running Watapon 1.6.1 (Sharp based ROM) along with a Socket / Symbol Low Power Spectrum24 LA-4137 wifi card.

This is all fine and good, until I try to add "kismet" (or wellenreiter) to the equation.

I've been searching this forum quite some bit, google some more bit.

So far I've concluded that:
a) The driver currently in use (from watapon/sharp rom) misses something to get the card into the proper mode for sniffing
cool.gif The kernel (Linux 2.4.18-rmk7-pxa3-embedix #1) supposedly misses wireless extensions.

I've found spectrum packages here and there on the web. Tried a few. Apart from messing up most of the networking ability, kismet (or the other one) would still not work.

From kismet, the errors spat out are referring to channel hopping, which makes sense. Documentation i've seen on the web indicate that the "upgraded" driver would be from the orinoco branch and would be the orinoco_hopper or something.

I've also gathered that this all works fine and dandy with OpenZaurus. Unfortunately, it's OpenZaurus that doesn't like to work with my 5600 (opie crashes a lot on it). (I've tred 3.5.3)

So I start this new thread in the hopes that someone, holding some pieces of information, could help me out a little here.

Any ideas?