Help - Search - Members - Calendar
Full Version: Blackdown J2se On Zaurus Sl-c3000
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Personal Java/Jeode/J2ME Personal Profile
daniel3000
Did anyone try this already?

I downloaded an IPK package which has been designed for the iPaq (from http://www.tml.tkk.fi/~jsantala/feed/ ).

It could not be installed to the SL-C300 with ipkg install, because ipkg tried to install files on on eof the read-only file systems. So I disassembled the package manually with tar.

What I got was mainly a directory

./j2re1.3.1/bin and
./j2re1.3.1/lib

Calling ./j2re1.3.1/bin/java I got
"Error: Can't find libjava.so".

libjava.so is in ./j2re1.3.1/lib/armv4l/libjava.so.

So I linked it to /usr/lib and called ldconfig. but still the same error.

Could anyone please guide me what to do in order to make blackdown J2SE work on the SL-C3000?

Thanks

daniel
smuelas
Well, I think I can give you some hints. The first one is "bad news": to my knowledge, you will not be able to run j2se, or, if you are able, please tell me a.s.a.p.
I've tried lot of times. Not with packages like the one you mention but downloading directly jdk1.3.1. I obtained excatly the same error message. I did it running Debian under Xqt.
I was able to eliminate this first problem and progress quite a lot, but finally I found a definite stop with some "libstdc++libc6-....." that had no solution of any kind.
Anyway, I am able to run almost the same Java using jdk1.8.1 and the swingZ.jar many times mentioned in this pages. Read them and you will able to have almost the same thing as jdk1.3.1.... :-)
Smuelas
Meanie
The java wrapper script needs some hacking to get it to work.

see http://www.users.on.net/~hluc/myZaurus/custom.html#java
daniel3000
QUOTE(Meanie @ Jul 15 2005, 02:06 PM)
The java wrapper script needs some hacking to get it to work.

see http://www.users.on.net/~hluc/myZaurus/custom.html#java
*


Hi Meanie,

tried it per your instructions, unfortunately still some problems. Java won't start.

What i did:

Using the blackdown-jre_1.3.1-RC1_arm.ipk:
Installing with ipkg didn't work, since it wanted to install to some read-only places.

* So I untarred the ipk and the data.tar.gz and got a j2re1.3.1 directory with bin and lib in it. Started from there.

* Copied the j2re1.3.1 to /usr/local (i.e. /hdd2/usr/local).

* Used your instructions:
# ln -s /usr/local/j2re1.3.1/bin/java /usr/bin/java
# ln -s /usr/local/j2re1.3.1/bin/armv4l /usr/local/j2re1.3.1/bin/armv5tel
# ln -s /usr/local/j2re1.3.1/lib/armv4l /usr/local/j2re1.3.1/lib/armv5tel
# ln -s /usr/lib/libstdc++-3-libc6.1-2-2.10.0.so /usr/lib/libstdc++-libc6.2-2.so.3

Had to do a chmod a+x /usr/local/j2re1.3.1/bin/java in addition.

Now, starting "java", I get the following errors:

/usr/bin/java: /bin/realpath: not found
(where can I get this tool?)

grep: /lib/jvm.cfg: NO such file or directory
(where does this file come from normally?)

java was not found in /bin/armv5tel/native_threads/java
(not even /bin/armv5tel exists - why does it think it should be there?)

Thanks for all further hints!

daniel
plcg
Hi Daniel,

I've tried this under Pdaxrom and it worked (I can't remember where i found it) :

"download blackdown's arm version of J2SE 1.3.1
decompress the blackdown archive in /home/root/usr/local
run 'uname -m' to determine the machine hardware name

Blackdown expects 'armv4l' as hardware name, in my case the one that
'uname -m' returned was 'armv5tel'. In order to fix that i had to add
the following symbolic links:

ln -s /home/root/usr/local/j2re1.3.1/bin/armv4l /home/root/usr/local/j2re1.3.1/bin/armv5tel
ln -s /home/root/usr/local/j2re1.3.1/lib/armv4l /home/root/usr/local/j2re1.3.1/lib/armv5tel
now you need to install the following additional libraries: libBrokenLocale.so libXm.so libXp.so libstdc++-libc6.2-2.so.3

the first 3 can be found in additional-ipaq-stuff.tar.gz on
blackdown's website I got libstdc++ from here (
http://intimate.handhelds.org/installer ... 6.2-2.so.3 )

you can copy the libraries in any directory, you'll have to add the directory path to /etc/ld.so.conf

then execute ldconfig
now you can add /home/root/usr/local/j2re1.3.1/bin to the path"

Tell me if it works for you,
plcg
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.