Help - Search - Members - Calendar
Full Version: Sd Card Fails On Insert
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > 5x00 Hardware
colm
UPDATE: Just tried OZ+opie, same thing from Dmesg

Hi Folks,

Just got a noname 1GB SD Card, seen on lots of posts that brand is quite important for zaurus, but chanced on a cheap (£40) ebay auction. Card is used - normal usage scoring on contacts.
When I insert the card, the SD card icon does not appear

dmesg reports:
SD read CRC error : ffff : d1d7
VFS : Disk change detected on device mmcd(60,1)
(9 times, presumably the retries)

#mkdosfs /dev/mmcda1
mkdosfs 2.8 (28 Feb 2001)
/dev/mmcda1: No such device or address

hardware: 2nd Hand Zaurus 5500 (£70 from ebay)

this is the first SD card I've tried, so I can't confirm that the slot works (only have CF and memory sticks in other devices...), but the "Disk change detected" reported in dmesg is promising that the hardware at least works. Can't confirm that the card works elsewhere until tomorrow...

running Sharp 3.1 rom, just about to try latest OZ+opie

Think reformatting the card via iPaq or PC might work?

--
Colm
macubergeek
Your post reminded me of something the salesman at the local Best Buys shop told me. He indicated that the maximum sd card pda's like the zaurus will take is 512megs. I was lusting after a 1 gig card myself...Can anyone substantiate this for us?
grog
QUOTE(macubergeek @ Jul 19 2005, 02:40 PM)
Your post reminded me of something the salesman at the local Best Buys shop told me. He indicated that the maximum sd card pda's like the zaurus will take is 512megs. I was lusting after a 1 gig card myself...Can anyone substantiate this for us?
*

Check my sig. FWIW 1g works fine for me, dual partitioned, 800mb vfat, 200mb ext2.
Mag1c
Hi,

same here, 1 GB Lexar SD ext2-formated works fine for me.

Try to check the SD cards on PC. Looks like the SD-port on your
Zaurus is dead.

greets
Mag1c
chrget
QUOTE(Mag1c @ Jul 20 2005, 09:07 AM)
Looks like the SD-port on your Zaurus is dead.
*
Gee, can I have a crystal ball just like yours? rolleyes.gif

It is widely documented across this and other resources across the 'net that the Z (possibly mainly Collie, wouldn't know about the others) is a picky little bugger when it comes to SD cards in general. This matches my personal experiences, and IMHO when buying an SD card one ideally should do a 'try before you buy' deal. Obviously having a local dealer can certainly help with that.

So it isn't a size issue wink.gif but rather a case of lousy compatibility (AFAIK on the Z side). I'm running my 1GB Extrememory just fine in my Collie (it was one of three I tried in my trusty dealer's shop, and the only one that worked -- go fig!) for quite a while now (would have to check, but should be almost a year by now).

So, even if the card runs fine in another device, it doesn't necessarily mean that the SD port of your Z is fried.

Best regards,
Chris.
macubergeek
One question I have:
Can you use the 1Gig card As-is formated vfat or do you have to reformat it ext2?

I'd rather keep it formated vfat if possible.
chrget
QUOTE(macubergeek @ Jul 20 2005, 11:34 AM)
Can you use the 1Gig card As-is formated vfat [...]
*
That's the way I'm running mine, for a variety of reasons.

Best regards,
Chris.
Cresho
i been using a PNY 1gb for a while now. It's now on my c1000.

works very good on the sl5500.

been wanting to get rid of it for 50 dollars but nobody wants it laugh.gif

im looking for a 4gb sd but i seen a 2gb at the moment for 217. it looks good.

if anybody still interested, i sell it for 45 plus shipping.

so email me at cresho@earthlink.net and post her that you purchased it. i live in california. los angeles area that is. the paypal thingy is the same as my email and well get things settled.

if interested...

best buy employes are mostly .....not knowledgable enough. especially when it comes to the z.
Mag1c
QUOTE(chrget @ Jul 20 2005, 08:28 AM)
QUOTE(Mag1c @ Jul 20 2005, 09:07 AM)
Looks like the SD-port on your Zaurus is dead.
*
Gee, can I have a crystal ball just like yours? rolleyes.gif


Uups, sorry. I thought, I had read that he tested two different cards.
So you are right. It could be either SD-Card or SD-Port or the combination of them.

greets
Mag1c
colm
QUOTE(Mag1c @ Jul 20 2005, 04:22 AM)
QUOTE(chrget @ Jul 20 2005, 08:28 AM)
QUOTE(Mag1c @ Jul 20 2005, 09:07 AM)
Looks like the SD-port on your Zaurus is dead.
*
Gee, can I have a crystal ball just like yours? rolleyes.gif


Uups, sorry. I thought, I had read that he tested two different cards.
So you are right. It could be either SD-Card or SD-Port or the combination of them.

greets
Mag1c
*




OK, tried the SD card, works a treat in a compaq laptop. So that means I can at least re-sell and try again.

Tried a 64MB Lexar branded SD in my Z and that works too, so it just looks like this particular card is not compatible

So Overall I'm happy, but wiser

I've seen some talk about another driver for SD but can't track down the details - think that's worth a pop before I get another card?

back to sharp rom again...

Thanks for the responses folks.
misterearl
FWIW the Kingston 512MB SD card (bought from Buy.com for $16.25 after rebates a week ago) works perfectly in my SL-5500 running Sharp ROM V3.13. A Kodak 64MB CF card functions perfectly as well.

Lee


Sorry, make that a Viking 512MB SD card...
colm
Hi Folks,

Got a Sandisk 1GB SD Card (£79.99 from ASDA (walmart) photo shop). Works a treat, so I'm a happy bunny!

FWIW, the other SD card also fails in an iPAQ 3600, so it's not just the Z being picky, works every other place I tried though.


Question now is - /root on /mnt/card - 64MB ram... LAMP on the Z... these are all my aims whilst also continuing to run hancom stuff, I'll report back with a howto when I get all this working, the info is spread far and wide out there!

--
Colm
niv
Sad to report its a no god for the Ridata 1Gb X66 SD :-)
Kingston 512Mb Works fine..

Need we add it to the wiki?
comcute
Hi
Has somebody tested Kingston 1GB ELITE PRO SECUREDIGITAL MEMORY CARD? http://www.kingston.com/digitalmedia/sdelitepro.asp
Does it work with collie?

Thanks

EDIT: Damn, seems not, dmesg gives me a lots of write errors. I have to return it.
telemetric_au
what about a 1GB Kingston Ultimate SD in the 5500 or any other Z ??
larrycow
I'm using a Kingston 1GB SD card without any problem on my Collie. I kept the original partition layout (one big VFAT partition).
telemetric_au
QUOTE(larrycow @ Mar 19 2006, 10:35 PM)
I'm using a Kingston 1GB SD card without any problem on my Collie. I kept the original partition layout (one big VFAT partition).
*



that would just be the standard speed card though ??

id be interested to know if anyone has had any of the faster sd types work ?
hakujin
Hello everyone I have an sl-5600 running the latest OZ(3.5.4 i think) + opie And I bought a 4GB mmc card (brand is pqi ) but it is not working at all in my Z. Every time I insert it the Z slows way down to the point of unusability . After a whille it starts running again but I still can't see the card. I tried reformatting it ext2 to no avail. I tried a 2GB card earlier but tha tdid the same thing. Does anyone know if the Z can handle a card this big? If not can it handle CF microdrives that big ? Thanks.
sdjf
I have a 1GB Kingston SD card running just fine as ext2 on my Collie.

Bought it from geeks.com a year ago. Don't know model name but etchings on the back give a product code "SD-MO1G" (blurry vision..could be an MQ but think it's an O). But it's normal speed.

It loads slowly as I have so many files on it, but it does work. I really prefer using 512MB cards as they load so much faster for me.

If you want speed, use CF cards, they're much faster even at normal speeds.

sdjf
telemetric_au
i know have kingston 50x elit pro 1gb cf and standard 1gb sd working fine for some time.
Antikx
If you guys wouldn't mind, could you put your successes and failures here:
http://www.tyrannozaurus.com/?q=wiki/SDCompatList
If not or you don't have time, no worries, I can do it (just give me all the info).
Thanks.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.