Help - Search - Members - Calendar
Full Version: Storage /dev/hda1
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Qt/Qtopia
jagrka
I have a JP Sharp ROM Zaurus SL-C760. In the file manager tab of Qtopia, which displays "My Zaurus", it lists the main memory, SD card, and CF card (all are displayed in Japanese since I am using the original ROM).
My problem is that in instead of displaying "CF Card" is now displays "Storage /dev/hda1". In addition, the pretty CF card icon has been replaced with the standard yellow folder icon. Everything works fine in terms of the files, but I want to fix the CF card name display and icon. Does anyone know where Qtopia stores this information? Any suggestions on how to fix this minor problem will be appreciated.
Meanie
QUOTE(jagrka @ Jul 22 2005, 10:52 PM)
I have a  JP Sharp ROM Zaurus SL-C760. In the file manager tab of Qtopia, which displays "My Zaurus", it lists the main memory, SD card, and CF card (all are displayed in Japanese since I am using the original ROM).
My problem is that in instead of displaying "CF Card" is now displays "Storage /dev/hda1". In addition, the pretty CF card icon has been replaced with the standard yellow folder icon. Everything works fine in terms of the files, but I want to fix the CF card name display and icon. Does anyone know where Qtopia stores this information? Any suggestions on how to fix this minor problem will be appreciated.
*


remove your CF, reboot your Z, put it back in and see what displays smile.gif
jagrka
QUOTE
remove your CF, reboot your Z, put it back in and see what displays smile.gif
*


Thanks Meanie for the suggestion. Unfortunately, it did not correct the problem. Any other suggestions?
melee
QUOTE
Unfortunately, it did not correct the problem. Any other suggestions?
*

Hi

The CF card icons are at /usr/QtPalmtop.rom/pics/CFDevice.png & CFDeviceS.png (S is for small)
Its not likely that the wrong icon is displaying or that you don't have them, but check anyway.

Check /dev to see you have hda1 with major 3 and minor 1

Look in /etc/fstab, does it show a line /dev/hda1 /mnt/cf auto noauto,owner 0 0
and does /mnt/cf exist ?

If not edit fstab, create /mnt/cf if necessary and do a full reboot.

If all above is correct, I note you say "it now shows Storage /dev/hda1", when did it stop showing "CF" and what did you immediately before?

regards

Melee
jagrka
Thanks Melee! I fixed the problem. My fstab file was fine. Coping the icon files from /usr/QtPalmtop.rom/pics to /home/QtPalmtop/pics seems to have repaired the problem. I appreciate your reminding me to try these steps. I had somehow conviced myself that the problem was not related to just the icon files.
bam
question: can ther be a specific icon for usbstorage device(other than the folder)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.