Help - Search - Members - Calendar
Full Version: Zaurus Sl-c3000 S/w Rotation Broken [solved]
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
zoxed
My SL-C3000 has screwed itself up (or maybe I did it :-).

When I open it (landscape) it displays in portrait mode, then decides to rotate *part* of the screen to landscape *upsidedown*.

When I start an app it starts in portrait mode (even thought the screen is still physically in landscape) and works OK apart from that. But no way can I get back to using landscape mode.

The following do not work:
- reboot
- the rotate menu option
- an combination of opening and closing the lid, and physically rotating it.
- uninstalling most of the new s/w I had installed

I have not done many changes to the system: I have not touched the ROM, I have just imported my data, and installed a few extra programs: mplayer, kino2, ltris, brickout...

I have looked around the config files in /etc but can not find anything.

/home/zaurus/Settings/display.conf looked promising but editing it seems to make no difference.

Any suggestions ?

Thanks, Simon
rebski
Exactly the same thing happened to my C1000. In the end I restored it to its original factory state and started again.
bam
what about qpe.sh, startup script maybe something in there? Just guessaing at this point
curiosity
Hi,
i had the same problems, after watching a movie with kino 0.42p20 + bvdd my qpe crashed and the screenrotation was broken.

It seems that the /home/zaurus/Settings/qpe.conf is damaged by the crash.
There are three possibilities.
- first you'll try to repair your qpe.conf
- second you restore your old qpe.conf
- third you try the qpe.conf in this message

The interesting value is:
[Rotation]
HReverse = 1

When you're using the qpe.conf in the attachement, you'll have to make changes in your system like ApplicationKeys and the fastload-option.

Good Luck!!!
zoxed
Firstly thanks to those who replied.

QUOTE(curiosity @ Jul 25 2005, 08:51 PM)
- third you try the qpe.conf in this message

The interesting value is:
[Rotation]
HReverse = 1


I tried this first and it worked :-)))

For the record: my qpe.conf had the [Rotation] section in, but it was empty. So I added the "HReverse = 1" and saved the file. It does not take effect immediatly, but when I physically rotated the screen to portrait it was read and took effect. I rotated the screen back to landscape and it works fine now :-)

(Feels strange: after a couple of weeks I had kind of gotten used to viewing the screen sideways as I typed.)

So it looks like a problem with kino2. I am off soon for a 3 week holiday soon (with my Zaurus :-) so I will not experiment yet to confirm this !!
rebski
My rotation problem has come back but this time it is frozen in portrait mode and the keyboard is locked.

I have checked for
[Rotation]
HReverse = 1
and tried the qpe.conf fix (thanks for that btw) but to no avail.

It looks like this device doesn’t like us tinkering with apps that are not optimised for it.
mbagsh55
Hi Rebski, is it only the physical keyboard that is locked, or the on-screen keyboard? If it is the on-screen keyboard check that it hasn't switched to Japanese input (mine suffered this problem).

Huge thanks to Curiosity, biggrin.gif
Kino2 messed up my qpe.conf file exactly as you explained and I was getting more than a little anxious. In my case it took two attempts at editing the conf file and I nearly blew it at one point by saving the conf file as Shift-JIS.

Any other newbie users, make sure you save it as UTF8 if you are using a GUI editor that performs code conversion.

I am now a happy bunny and can enjoy the rest of today's public holiday here in Singapore (Hari Raya).

Cheers,
Marcus
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.