Help - Search - Members - Calendar
Full Version: Connecting Zaurus As Client To Powerbook G4
OESF Forums > General Forums > Desktop Operating Systems Issues > Mac Issues
gojo07
Connecting the new Sharp SL-C 3100 as client to my PowerBook G4 (Mac OS X, 10.3.9) via USB takes a very long time (several minutes). The Zaurus will at last be mounted with an icon called "Untitled", "Untitled 1", "Untitled 2",... on the Mac desktop 47(!) times. Every mounted volume (of the 47) will show the internal Zaurus HDD correctly. The Mode Setting of PC Link on the Zaurus is "Storage Internal HDD".

Any idea what's going wrong?

One additional comment:
I have installed AJZaurusUSB.kext from Andreas Junghans (www.lucid-cake.net/osx_zaurus_usb/index_en.html) to get a network connection to my PowerBook (of course with PC Link Setting). That's working fine.

Thanks for any comment or help,
Goetz
dhns
QUOTE(gojo07 @ Jul 27 2005, 05:32 PM)
Connecting the new Sharp SL-C 3100  as client to my PowerBook G4 (Mac OS X, 10.3.9) via USB takes a very long time (several minutes). The Zaurus will at last be mounted with an icon called "Untitled", "Untitled 1", "Untitled 2",...  on the Mac desktop 47(!) times. Every mounted volume (of the 47) will show the internal Zaurus HDD correctly. The Mode Setting of PC Link on the Zaurus is "Storage Internal HDD".

Any idea what's going wrong?

One additional comment:
I have installed AJZaurusUSB.kext from Andreas Junghans (www.lucid-cake.net/osx_zaurus_usb/index_en.html) to get a network connection to my PowerBook (of course with PC Link Setting). That's working fine.

I have no longer a 10.3.9 system working but I remember there was a conflict between the Apple USB-disk driver and the AJZaurusUSB driver. Both compete in serving the Zaurus. This might be the reason why it gets mounted multiple times. Did you try to uninstall AJZaurusUSB?

The preferred way of communicating is either by SMB (which also has a limitation since /home/samba is exported and the Mac thinks that it is only 2 or 4MByte large even if you symlink to /hdd3).

Or using a memory card.

-- hns
Mac
do you guys found a solution for this 2 mb problem? I have the same problem, the zaurus mounts fine using USB/smb but the internal drive and inserted SD card both shom 2MB free space. I think this worked in the past?


QUOTE(dhns @ Jul 27 2005, 11:48 AM)
QUOTE(gojo07 @ Jul 27 2005, 05:32 PM)
Connecting the new Sharp SL-C 3100  as client to my PowerBook G4 (Mac OS X, 10.3.9) via USB takes a very long time (several minutes). The Zaurus will at last be mounted with an icon called "Untitled", "Untitled 1", "Untitled 2",...  on the Mac desktop 47(!) times. Every mounted volume (of the 47) will show the internal Zaurus HDD correctly. The Mode Setting of PC Link on the Zaurus is "Storage Internal HDD".

Any idea what's going wrong?

One additional comment:
I have installed AJZaurusUSB.kext from Andreas Junghans (www.lucid-cake.net/osx_zaurus_usb/index_en.html) to get a network connection to my PowerBook (of course with PC Link Setting). That's working fine.

I have no longer a 10.3.9 system working but I remember there was a conflict between the Apple USB-disk driver and the AJZaurusUSB driver. Both compete in serving the Zaurus. This might be the reason why it gets mounted multiple times. Did you try to uninstall AJZaurusUSB?

The preferred way of communicating is either by SMB (which also has a limitation since /home/samba is exported and the Mac thinks that it is only 2 or 4MByte large even if you symlink to /hdd3).

Or using a memory card.

-- hns
*

dhns
QUOTE(Mac @ Oct 9 2005, 03:28 PM)
do you guys found a solution for this 2 mb problem? I have the same problem, the zaurus mounts fine using USB/smb but the internal drive and inserted SD card both shom 2MB  free space.  I think this worked in the past?

It is a result of the Zaurus model specific Flash/Disk partitioning scheme and how SMB is configured. Generally, the size of the device /home/samba (or any subfolders - even if linked) is sitting on is reported (try "df /home/samba"). If this can be changed to hdd3, the size should be more than some MB.

I have not tried, but a solution could be to add /hdd3 explicitly to the exported directories (the line path = /home/samba in /home/root/usr/lib/samba/smb.conf) and link back there to /home/samba.

-- hns
ralphrmartin
I avoid using samba. I just use fugu and sftp to move files about between the Mac and my C860.
Mac
wow, thanks for the tips, esp. the fugu one, very nice application and better then to use samba!

@dhns, I tried what you wrote, but there is no smb.conf located in /home/root/usr/lib/samba/smb.conf
dhns
QUOTE(Mac @ Oct 12 2005, 03:56 PM)
there is no  smb.conf located in  /home/root/usr/lib/samba/smb.conf
*

Oops... try 'find / -name smb.conf -print'

It might be a special symbolic link on my machine or differ between models.

-- hns
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.