Help - Search - Members - Calendar
Full Version: Mounting An Sl-c3100 Nand
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
ShiroiKuma
I'm trying to mount the SL-C3100 NAND, but somehow can't do it.

I'm doing this from Knoppix. This is what I've tried:

modprobe mtdram total_size=109000

This is the biggest problem probably, because the size should be bigger, no? However when I specify any number that's bigger, I get:
CODE
FATAL: Error inserting mtdram...
Cannot allocate memory


And then I've tried:
modprobe mtdblock
modprobe jffs2
mkdir /dev/mtdblock
cd /dev/mtdblock
mknod 0 b 31 0
mknod 1 b 31 1
mknod 2 b 31 2
dd if=/tmp/SYSTC310.DBK of=/dev/mtdblock/0


And here I get:
CODE
dd: writing to '/dev/mtdblock/0': No space left on device


Which is probably due to the memory allocated being too little...

How can I make this work?
Stubear
Well as the SYSTC310.DBK file is around 130Mb then you will need to make the total_size of the mtdram at least 130MB.

You might still have trouble getting stuff of the mtdblock cause the NAND isn't just as JFFS2 image, it contains extra data - that's why it's bigger than the 128MB flash ram.

There are scripts available on this forum for extracting the jffs2 image from a NAND, they were a while ago but if you search by my username you'll find them. Some other people cleaned up my original script and added some more functinos to it.

Stu
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.