Help - Search - Members - Calendar
Full Version: Upgrade Packages Problem...
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus

I have just reflashed my Z SL-5500 with the last OZ release (zImage 64-0 and Opie 1.2) and then I have tried to follow the "Howto get r21 kernel on collie" news on OZ website, but ipkg stalls during upgrade procedure. sad.gif

Flash works fine and all the modules are upgraded to r21 version, the problem is raised during libqte2 upgrade, the last thing that ipkg print out is:
upgrading libqte2 on root from 2.3.10-r12 to 2.3.10-r14...

I have tried to upgrade under opie konsole and under Z console (logout from opie), obtaining the same result.

What could I do now? unsure.gif
I thought the HowTo said to just upgrade the kernel modules?

If you attempt to perform an upgrade of the entire image you'll almost certainly run out of space on the collie. I imagine this is what has happened to you (what does 'mount' or 'df' show?).

There are a couple of threads about how to recover from this - basically you need to remove some stuff by hand so that ipkg has enough space to run, then use ipkg to remove/upgrade individual packages.

I have tried to free space, I have freed 2.5 Mb, but ipkg stalls again on libqte2 (having 1320 Kb free).

Now I try to upgrade just modules...
Well, upgrading just modules works fine, now I have the last kernel working on.

thanks lardman.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.