Help - Search - Members - Calendar
Full Version: Gaim On C1000 Base Rom
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
robertcloud
I know there are alot of threads on here, but I am just having a persistant problem.

I have installed
libgaim version .73-1
libgaim-protocol-irc .73-1
libopie1 version 1.0.2
libpng12.so with the simlinks as documented on qpe-gaim sourceforge page.

I get gaim to start, but I still don't get the icons to show up so I can't select menus and start chatting.

could anyone please tell me what to do or know of any other chatting program?
Cresho
you should of done a previous search here!

i got a list going to get gaim working. gona post right now.

QUOTE
im gona list the files you need to run gaim

on the c1000 but still works for yours as well...all to main memory

after install, remove magnification by holding down on gaim icon (2sec) and remove magnification, reboot, then run program, create user (i tried msn cuz i hear others might have a problem), after you create your account, shut down program and restart. and log in. It takes time for you to get use to it. it works and when you log in, the only way you find out if you logged in is if you click on the right icons...it swings back between logged accounts and your friendly list. on the left, you can highlight the guy you want to chat with and then you click on chat icon and chat away. you can have multiple chat windows open within gaim.

here is the location of the downloads.
http://prdownloads.sourceforge.net/qpe-gaim

here is the files you need...nothing else and nothing newer.


gconv-tiny_2.2.4-2_arm.ipk
libgaim_0.71-1_arm.ipk
libgaim-protocols_0.71-1_arm.ipk (this one installs all of them or just install the one particular one that you want such as msn.i recommend protocols since it has all of the chat channel installers)
libgaim-ssl_0.71-1_arm.ipk
libgcrypt1_1.1.9-3_arm.ipk
libglib2.0_2.2.1_arm.ipk
libgnutls7_0.8.10-2_arm.ipk
libopie1_1.0.2_arm.ipk-this one you may need to look elsewere
qpe-gaim_0.3-1_arm.ipk
zlib_1.1.2_arm.ipk


that is all.


that was from a previous post a couple of notches down. it works. after you insta.., fiddle with it and it works.

all installed to internal only or it wont let you or may not work.
robertcloud
QUOTE(Cresho @ Aug 6 2005, 04:50 AM)
you should of done a previous search here!

i got a list going to get gaim working.  gona post right now.

QUOTE
im gona list the files you need to run gaim

on the c1000 but still works for yours as well...all to main memory

after install, remove magnification by holding down on gaim icon (2sec) and remove magnification, reboot, then run program, create user (i tried msn cuz i hear others might have a problem), after you create your account, shut down program and restart. and log in. It takes time for you to get use to it. it works and when you log in, the only way you find out if you logged in is if you click on the right icons...it swings back between logged accounts and your friendly list. on the left, you can highlight the guy you want to chat with and then you click on chat icon and chat away. you can have multiple chat windows open within gaim.

here is the location of the downloads.
http://prdownloads.sourceforge.net/qpe-gaim

here is the files you need...nothing else and nothing newer.


gconv-tiny_2.2.4-2_arm.ipk
libgaim_0.71-1_arm.ipk
libgaim-protocols_0.71-1_arm.ipk (this one installs all of them or just install the one particular one that you want such as msn.i recommend protocols since it has all of the chat channel installers)
libgaim-ssl_0.71-1_arm.ipk
libgcrypt1_1.1.9-3_arm.ipk
libglib2.0_2.2.1_arm.ipk
libgnutls7_0.8.10-2_arm.ipk
libopie1_1.0.2_arm.ipk-this one you may need to look elsewere
qpe-gaim_0.3-1_arm.ipk
zlib_1.1.2_arm.ipk


that is all.


that was from a previous post a couple of notches down. it works. after you insta.., fiddle with it and it works.

all installed to internal only or it wont let you or may not work.
*



Thanks for those tips. I got the program up and running, but I can't seem to get connected to the network. I press connect, it stays at 2% indefinately. I have proxy turned off like it should be, and I am using the default AIM oscar. Any ideas?
Cresho
It was smart of you not to go for the protocols. I spent the last .......5 hours figuring this out myself.

Your best bet was the oscar protocol .71 like you installed. I did bounce into a rather interesting conversation about pinging a server and then telnet a server to get the gaim working. Since i have no aim and icq is so old that i wonder if it was disabled, i cannot verify if this method works

here is the post.


http://ubuntuforums.org/archive/index.php/t-5483.html

and specifically this guys post
QUOTE
dataw0lf
11-19-2004, 10:38 AM
I've been trying to troubleshoot the problem. My boss has the same modem (Actiontec 701) and he mentioned that Linux, when setup as DHCP from it, will set the primary DNS as the actual modem, and the ISP's DNS as the secondary.. this could be part of the problem. But, just an update, now, when I login, I have to ping and telnet to the AOL login server before AIM will work. IE, when I login GAIM will sit, apparently trying to resolve it on 'Connecting' and timeout after a while. But once I grab a shell and issue a ping login.oscar.aol.com and a telnet login.oscar.aol.com 5190, and try to login again through AIM, it pops right up. I'm going to see if changing the port that GAIM connects to login.oscar.aol.com works when I get home. But I'm still weirded out by the whole business. ](*,)
dataw0lf


now ill remind you i tried this method and failed but of course my aim and icq account is dead so i assume

I do have msn messenger working but the problem here is also, which is very important, i do not get a ring or a light telling me who is contacting me. I need to double click on windows and open up chat windows to view posts.

when i use msn messenger, i just keep a window or windows open on people who i want to keep chatting with while browsing.

I remember in my sl5500 days, i had aim working and also icq with those ipks i posted. ...And i also remember that one day, people and myself complained and wondered how we lost icq or aim access through gaim.


here is a small update. i had gaim running. a window poped up within gaim with a message from one of my contacts...how nice.
robertcloud
Thanks Cresho for helping me out. I got it working, but I have to start it from the command like with sudo. Running it as zaurus won't work, and I can't start it with the icon even if I tell it to run with root enabled.

Also, there is a strange thing going on. I have two wireless networks in my house, one WEP encrypted and one not. I can only run Gaim from behind the unencrypted router. Also, If I change networks on my zaurus, I have to reboot and change it back before I can get gaim to work again. Just curiosities.

Thanks again for your help.

Cheers!
Cresho
you should post the command lines if you can. people might be interested and probably add some to it to get this working better.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.