Help - Search - Members - Calendar
Full Version: Samba - Does It Work In Rc10 ?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
phillvs
Hi All,

Am running RC10 on my C860. My connection via the serial cable doesnt work and I have given up on it (Win2K problem I think - works for XP).

Ideally I would like my WiFi connection (which works very well for internet connectivity, to allow me to browse the W2K shares.

I have installed samba from the feed and gone to the samba.org site for setup info. The site taks about two daemons which should be running smbd and nmbd. If I do a ps -all I can see smbd but no nmbd. Is this right?

I have opened the /etc/samba/samba.conf file and it is listed below. Zaurus does not appear in my W2K browser list. Does anyone know how to set up the zaurus for browsing please?


[global]
# workgroup is either a domain name or a workgroup name
workgroup = WORKGROUP
server string = zaurus
dns proxy = no
printer admin = @adm
load printers = yes
printing = cups
os level = 20
printcap name = cups
netbios name = zaurus
map to guest = bad user


[sd]
path = /mnt/card
public = yes
guest only = yes
guest account = root
writeable = yes
#
# encrypt passwords is required for Win98, NT and Windows 2000
#
encrypt passwords = yes
[all]
comment = Read only access to /
path = /
read only = yes
guest ok = yes
#[home]
# comment = read/write access to /home
# path = /home
# read only = no
# guest ok = yes

Phill
adf
for what its worth, I install all 3 of the non "codepage" samba packages.
all I do with it atm is to mount shares manually: smbmount //server.ip/share /mountpoint
works fine on my 6k.
Quino
Samba worked in my C1000 in both directions:
As a Samba server I can share my Zaurus Filesystem to Windows and Linux boxes
As a Samba client I can see the folders I shared in Windows and Linux boxes

I didn't touch any parameter in RC10.1, and it worked altough sharing the whole file system as read only.
phillvs
Thanks for those replies. I have managed to get the shares frm my Win2K box.listed and managed to mount them.

I wonder if there is a file that I can enter the mount command into so that it automatically mounts when I plug in the card. Please let me know. Thanks

I am also trying to print to a shared W2K printer. Cups and Samba are installed. I have looked all over the cups and samba site and but cant find out how to print to the shared printer. Please/ can someone direct me. Thanks in advance.

Phill
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.