Help - Search - Members - Calendar
Full Version: Ipk Forgot What It Installed
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
TheWalt
I just got a used SL-C860 and have started my journey into makeing it my very mobile workstaion.

I have partitioned the built in flash as one 121meg, installed pdaXrom rc10, and have formatted a 1gig SD card as exf2. So far so good.

I then wanted to install GCC and related files to the flash card, so downloaded the ipk's and all went well until after the 5th or so install I noticed the package manager no longer knew anything was installed on the SD card. It did for the first 3 because I checked but after that didn't bother.

I rebooted a few times, forced a rescan, but no luck. The programs work fine, and all links are there, but if I ever needed to remove or upgrade this could be a bother.

Anyone seen this before?
maxg
When you restart the Zaurus, you should wait 5 minutes or so until all packages on the SD are relinked by ipkg-link. gcc-headers takes several minutes beacause it las a lot of small files. Check with `ps` to see if all ipkg-link are done, and startx and see it there is any progress made. If the package still aren't seen by the manager, you could just use the command line ipkg -d sd and that will probably work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.