Help - Search - Members - Calendar
Full Version: Open1x / Xsupplicant
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
TheWalt
I just got a used SL-C860 and have started my journey into makeing it my very mobile workstaion.

I have partitioned the built in flash as one 121meg, installed pdaXrom rc10, and have formatted a 1gig SD card as exf2. So far so good.

Now I have an issue where my office only supports LEAP for wireless authentication.

I have used Xsupplicant in the past which works, but I am unable to successfully complie it for pdaXrom. I installed GCC locally to the pda as well as setup cross compile on my linux server. Both seem to fail at the same point where near the end of 'make' it starts to get many warnings about a 'null' character being ignored, eventually failing the compile. I am not knowledgeable enough to know why but with a nudge in the right direction could probably modify as needed to fix.

Has anyone gotten this, or any other LEAP wrapper working for pdaXrom? Google pointed me to a few ipk's for other zaurus versions but not the SL-C860, so it must be possible. Thanks in advance.
dominate
any chance you made progress on this? i have the same issue of leap being used at work....

ken
TheWalt
Unfortunatly I haven't looked at it again except for a little this weekend as my schedule got busy. From what I have seen reading googled chat logs, the project had been compiled successfully for the Zaurus a year or so ago, but always for the OZ rom.

There seems to be some pretty strict dependancies that pdaXrom just may not follow or have compatable libraries for just yet. I know there is a bug in the ./configure where it looks for a "i686" path for m4 even though it scans the system previously (easily solved by a quick link). I have to look through with a little more detail and see what exactally is causing the error.

This is attempting to complie v1.2 of the project.
dominate
cool.... keep the list up to date if you make any progress.... i will probably try to compile it also and let you know if i have any success.

ken
SolarX
I too have tried to compile Xsupplicant, and failed. I'm getting a bunch of
cardif/linux/cardif_linux_rtnetlink.c:1182: error: dereferencing pointer to incomplete type errors, which is probably what you are getting as well.
I've been looking for an alternative, and I may have found one: wpa_supplicant. It supports the same authentication methods, though I'm not sure if it supports authentication without actually using WPA (like I need for a network I want to connect to: it uses authentication but WEP encryption). I will try it to find out. WPA-supplicant is available from the pdaxrom feeds, specifically here
dominate
wpa_supplicant does support doing WEP also... check out it's config file example on it's webpage... there's an example config in there...

ken
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.