Help - Search - Members - Calendar
Full Version: Newbie Corner: How To Run Kphone
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
niv
I have : 5500, Hentges Roms OZ 3.5.3.
did:

root@collie:/etc# ipkg install -d sd http://ovh.dl.sourceforge.net/sourceforge/...i_1.0.0_arm.ipk


---> ran fine. then:

$ipkg-link add kphone-pi
---> good.
reset opie -> kp/Pi appear - but , doesn't run

running from the black screen:
root@collie:/media/card/opt/QtPalmtop/bin# kppi
kppi: symbol lookup error: kppi: undefined symbol: _7QString.shared_null

what now?
niv
1. I gather I can't try linphone -as I use Opie.. right?

2. thoght the problem would be solved by installing oz-compat , but it seem to colide with sharp-compat-libs.
(I reinstalled making more room at the / )

QUOTE
root@collie:/home/niv/music/Pat Metheny# ipkg install -d sd http://www.openzauru
s.org/official/unstable/3.5.2/upgrades/oz-compat_0.5-r1_arm.ipk
Downloading http://www.openzaurus.org/official/unstabl...rades/oz-compat
_0.5-r1_arm.ipk
Installing oz-compat (0.5-r1) to sd...
ipkg_conf_write_status_files: Can't open status file: //usr/lib/ipkg/status for
writing: No space left on device
ipkg_conf_write_status_files: Can't open status file: /media/cf//usr/lib/ipkg/st
atus for writing: No space left on device
ipkg_conf_write_status_files: Can't open status file: /media/ram//usr/lib/ipkg/s
tatus for writing: No space left on device
An error ocurred, return value: 23.
Collected errors:
Package oz-compat wants to install file /media/card/etc/init.d/quickexec
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/bin/chk
hinge
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/bin/mak
ecompat
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/bin/qes
erver
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/bin/qui
ckexec
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/bin/run
compat
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qpe.so.1.5.0
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qte.so.2.3.7
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qpe.so.1.5
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qpe.so.1
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qpe.so
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qte.so.2.3.2
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qte.so.2.3
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qte.so.2
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop.compat/lib/lib
qte.so
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/bin/chkhinge
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/bin/makecompat

        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/bin/qeserver
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/bin/quickexec
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/bin/runcompat
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/etc/quickexec.
libs
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/pics/libraries
.png
        But that file is already provided by package sharp-compat-libs
Package oz-compat wants to install file /media/card/opt/QtPalmtop/apps/Settings/
makecompat.desktop
        But that file is already provided by package sharp-compat-libs
root@collie:/home/niv/music/Pat Metheny# ipkg install -d sd http://www.openzauru
s.org/official/unstable/3.5.2/upgrades/oz-compat_0.5-r1_arm.ipk
root@collie:/home/niv/music/Pat Metheny# ipkg list oz-compat
oz-compat - 0.5-r1 -
root@collie:/home/niv/music/Pat Metheny# ipkg list_installed oz-compat
root@collie:/home/niv/music/Pat Metheny# ipkg install -d sd oz-compat
Installing oz-compat (0.5-r1) to sd...
Nothing to be done
An error ocurred, return value: -1.
Collected errors:
ERROR: Package oz-compat (parent oz-compat) is not available from any configured
src.
Failed to download oz-compat. Perhaps you need to run 'ipkg update'?
root@collie:/home/niv/music/Pat Metheny#


Any ideas how to Kphone?
lardman
sharp-compat-libs is the new name for oz-compat.

Have you run mkcompat on the binary in kphone-pi, etc.?


Si
niv
QUOTE(lardman @ Aug 15 2005, 04:32 PM)
sharp-compat-libs is the new name for oz-compat.

Have you run mkcompat on the binary in kphone-pi, etc.?


Si
*


how should I run mkcompat ? (googling mkcompat now...)

As always - thanks Si
acpkendo
QUOTE
how should I run mkcompat ? (googling mkcompat now...)


Or, select KP/Pi from the "Libraries" Settings application as you would any other program.
niv
no go with makecompat

QUOTE
root@collie:/media/card/opt/QtPalmtop/bin# makecompat /opt/QtPalmtop/bin/kppi
Not linked to compat lib
Not Linked, Linking
Make /opt/QtPalmtop/bin/kppi use compatibilty libs.
root@collie:/media/card/opt/QtPalmtop/bin# /opt/QtPalmtop/bin/kppi
/opt/QtPalmtop/bin/kppi
ln: /tmp/qtembedded-root/QtEmbedded-0: No such file or directory
QSocket::writeBlock: Socket is not open
QSocket::writeBlock: Socket is not open
QSocket::writeBlock: Socket is not open
QSocket::writeBlock: Socket is not open
No Qt/Embedded server appears to be running.
If you want to run this program as a server,
add the "-qws" command-line option.
niv
I tried the install from the OE 3.5.3 libs feed:
QUOTE
root@collie:/home/niv# ipkg install /media/card/more/kphonepi_1.0.0-r0_arm.ipk
Installing kphonepi (1.0.0-r0) to root...
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for kphonepi:
        libssl0.9.7 (>= 0.9.7e)
root@collie:/home/niv# ipkg install http://www.openzaurus.org/official/unstable/
3.5.3/feed/libs/libssl0.9.7_0.9.7e-r1_arm.ipk
Downloading http://www.openzaurus.org/official/unstabl...ed/libs/libssl0.
9.7_0.9.7e-r1_arm.ipk
Installing libssl0.9.7 (0.9.7e-r1) to root...
Configuring libssl0.9.7
//usr/lib/ipkg/info/libssl0.9.7.postinst: 4: ldconfig: not found
postinst script returned status 127
ERROR: libssl0.9.7.postinst returned 127


Answer:
QUOTE
root@collie:/media/card# PATH=$PATH:/sbin
root@collie:/media/card# ipkg install http://www.openzaurus.org/official/uns
table/3.5.3/feed/libs/libssl0.9.7_0.9.7e-r1_arm.ipk
Downloading http://www.openzaurus.org/official/unstabl...ed/libs/libssl0.
9.7_0.9.7e-r1_arm.ipk
Installing libssl0.9.7 (0.9.7e-r1) to root...
Configuring libssl0.9.7
Hrw
KPhone/Pi should be in OZ feed - no need to use sharp-compat-libs with it
nexxusone
I'm running Kphone/PI from the OZ 3.5.3 feed on my c860, w/ a standard cellphone headset and an adapter that makes it fit the Z's headphone jack. For some reason I get no sound.
I'm connecting to a Broadvoice account, which I still cant dial out from, but in cacko1.22 I could receive calls and talk for about a minute before kphone would break and go silent. Now it's silent the whole time, and I nothing I say makes it through to the other phone.

Opening kppi from the commandline reveals:
Opening OSS device /dev/dsp for Input
ERROR: Open Failed
** audioIn: openDevice Failed.

Anyone else having this problem? Any suggestions?

Thanks!
nexxusone
FWIW, I've decided to play with this again, and found that Cacko 1.23 and the latest KPhone/Pi from Add/Remove Software (1.0.0 built from KPhone 4.0.3) will let me receive calls using my Broadvoice account with no problems at all. Everything seems stable and responsive, but when I try to dial out, I still get a pop-up that says "Forbidden". I'm probably going to have to sniff a successful connection using X-Lite and compare it to an unsuccessful connection using KPhone/Pi to figure out what's going on...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.