Help - Search - Members - Calendar
Full Version: Wifi Connection Problems
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
apink
My c1000 arrived a couple of days ago. tongue.gif

I got an ambicom 1100c wifi card yesterday that worked right out of the package. biggrin.gif

The problem: The card connected to my neighbor's access point (netgear), which had no wep encryption. When I tried to connect to my wep-encrypted access point (lynksys) it wouldn't go through. huh.gif (I've checked the wep key several times, made sure I was spelling things right, tried several different configurations on the card setup.) Is there a trick to this I am not seeing?

I'm using the sharp rom off of the trisoft site.
icruise
I'm not sure I can really help you solve the problem, but I'm using a wep-enabled network at home, so it can definitely be done. I did have to change the name of my network to something that didn't have a space in the name, though.
apink
I forgot to mention: I tried to connect to my network in both encrypted state and with encryption off. Can someone steer me to the files that are involved so that I can try to troubleshoot this?
apink
Got somewhere. This page helped:

http://www.acroname.com/intel/xscale/howto/sg_wireless.html
apink
I seem to be hogging this thread. Hope I'm not offending anyone. wink.gif

An update on my progress with another plea for info:

I found iwconfig and ifconfig. These helped. I loaded pdaxrom and was able to get my ambicom card to talk to my lynksis access point, though intermittently, using the config commands. Sometimes removing the card and reinserting it seemed to help. Sometimes not. Once #ifconfig eth0 up did the trick but not consistently. I did not figure out what the magic was, only that it showed up now and again if I floundered enough.

So now I am back with the sharp rom and iwconfig does not seem to be working properly. In fact it is fairly up front about it when I enter # iwconfig:

QUOTE
Warning:  Driver for device wlan0 has been compiled with version 14 of Wireless Extension, while this program is using version 13.  Some things may be broken. . .


So I went to the /etc/pcmcia/wireless.opts file directly and put in some language about my card, commenting out the lines that they said to delete. Then I rebooted. # iwconfig showed no change. I had changed the essid and given a WEP key. Neither were changed after reboot.

And finally, when I say something like # iwconfig wlan0 essid myid, the Z comes back with
QUOTE
Error for wireless request "Set ESSID" (881A) :
SET failed on device wlan0:  Function not implemented.


The nerve!

Suggestions?

Do I have to somehow recompile a driver with a different wireless extensions packet? Recompile the wireless extensions packet? I don't know how to approach that task. Can I get around this by bringing up the wireless connection manually? I am trying to do this but not getting very far.
Cresho
sharp rom off the trisoft site.......

Them guys are great but for my point of view, modifying the original rom and not knowing what it consists of doesnt to it for me. I actually want to know what it has in its internals.

anyway, your wifi card works on your z? it works none encrypted and it doesnt work encrypted?

Maybee the card is not compatable with your wifirouter.

maybee you ought to change some settings on your wi fi router.
-------like reset your wi fi to stock defaults and then do an encryption.

do not forget to backup your original settings so you can restore the settings on your wifi.

try that. The reason why im telling you this is because my wifi router is a little troublesome for my z as well.

for example, my pretec wifi from z hates my netgear wifirouter running preamble long instead of short for some wierd reason. I just discovered it by screwing around with the settings. and of course i love the backup and restore features so i suggest you start off with defaults....backup wifi settings of course before you venture here.

i swear some of you guys are so high up there that i need to remind you to start off with the simple stuff.

biggrin.gif
apink
QUOTE
  start off with the simple stuff.

biggrin.gif


It looks like the z wasn't allowing enough time for the connection to go through. I set DHCP_TIMEOUT equal to 100 instead of 10 in /etc/pcmcia/network.opts and have been getting good connections for several hours now.
apink
QUOTE
  start off with the simple stuff.

biggrin.gif


Maybe I spoke too soon about the DHCP_TIMEOUT fix. It worked for about 16 hours then left me out in the cold.

Today's success occured when I changed the channel on my access point. My neigbor is using channel 6, I was using 5. I switched to 11 and got signal right away.

Maybe this time I'll get a little more than 16 hours of success.
Cresho
progress>? smile.gif

i purchased a signal booster for my home. It amplifies the signal through the house. You might be having signal issues?

I purchased mines for .....4 dollars on special. regular 29.99. anyway, it is a 7db boost signal.

you ever try connecting your zaurus while its right next to the wifirouter? if you have better results with this cheap method, you probably are gona need a signal antena booster.
apink
progress. smile.gif

The card is working well today again.

I have been doing much of the troubleshooting right next to the access point so signal strength was probably not the issue.

Yesterday when trying to connect one time I noticed that the connection was named as being my access point but the MAC address was that of my neigbor's AP. My AP was using channel 5 while they were using ch 6. I think the signals were getting confused during the connection protocol.
seinfield
I had similar problems using a wep key with a 2wire router. I changed the timeout to 100, but no luck. But i founded that the wep key was changed in the wlan0 file (weird, because every time i write it on the network manager, a number is always changed). I changed to the correct one modifying the wlan0 file, then changed the Authentication option to shared key and it is working now.

I am using a c700 with cacko.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.