Help - Search - Members - Calendar
Full Version: Please Help With Built-in Wifi Problem
OESF Forums > General Forums > General Support and Discussion > Security and Networking
tinyrooster
I've been using my built-in wifi for months and suddenly it won't work. The network program gets stuck when it's opening, I've lost the network applet, and I don't know whether I have a hardware or software problem. I've tried resetting and hard resetting, also check error menu. I've thought about reformatting but I'm not sure it would help. Does anyone have any suggestions that could help me identify the problem, or else fix it? sad.gif
adf
maybe a flash would be easiest?
if you are on sharp it might make a nice opportunity to try guyhem, Qtopia 2.1 OZ or pdax.
hopefully someone else has an ide what went wrong
cvmiller
QUOTE(tinyrooster @ Aug 18 2005, 08:22 PM)
I've been using my built-in wifi for months and suddenly it won't work. The network program gets stuck when it's opening, I've lost the network applet, and I don't know whether I have a hardware or software problem. I've tried resetting and hard resetting, also check error menu. I've thought about reformatting but I'm not sure it would help. Does anyone have any suggestions that could help me identify the problem, or else fix it? sad.gif
*


There are a couple of things you can try. From the terminal window (su to root) and try the following:

usbctl on 1

This _should_ turn on the green wireless light on the SL-6000. To turn it back off, type:
usbctl off 1

After you turn on the wireless card (assuming the green light comes on) you can determine if the wireless interface is "seeing" any wireless networks (for this, you need to have a wireless AP running in close proximity with NO WEP enabled, just disable it for the test). Type the following:
wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
wlanctl-ng wlan0 lnxreq_wlansniff enable=true channel=<AP channel>

Then you should be able to type the following to see your AP's Mac address:
iwconfig wlan0

If you see the MAC address of your AP, then the hardware is pretty much working.

Assuming you get this far, then you can go ahead and configure Linux to use the HW (again from the terminal) by typing:
ifconfig wlan0 up
ifconfig wlan0 192.168.1.100

Then try to ping your wireless router (which I am assuming is 192.168.1.1).

I hope this helps,

Craig...
tinyrooster
Thank you so much for offering some help! I really appreciate it. I was able to get a green light by typing:

usbctl on 1

I turned off WEP and typed:

wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
wlanctl-ng wlan0 lnxreq_wlansniff enable=true channel=<AP channel>

I got the reply: syntax error, newline not expected.

When I typed the first line only and enter, I got a message saying enable=success so I'm assuming the second line is the problem. Or else maybe I'm typing something in wrong?
slogan621
[quote=cvmiller,Aug 20 2005, 08:04 AM]
[quote=tinyrooster,Aug 18 2005, 08:22 PM]I've been using my built-in wifi for months and suddenly it won't work. The network program gets stuck when it's opening, I've lost the network applet, and I don't know whether I have a hardware or software problem. I've tried resetting and hard resetting, also check error menu. I've thought about reformatting but I'm not sure it would help. Does anyone have any suggestions that could help me identify the problem, or else fix it? sad.gif
*

[/quote]

I had problems with my 6000L when I first bought it; wireless didn't work, and the wireless light wouldn't activate. However, I figured it was a hardware problem because plugging in a CF wireless card worked. So, I contacted Sharp USA, sent them both the 6000L and the wireless card, and in a week or so, they sent me my unit back, fully repaired, and it has worked nicely ever since.

So, it could be hardware. It happened to me, at least.

Hope this helps.
cvmiller
QUOTE(tinyrooster @ Aug 21 2005, 05:31 PM)
Thank you so much for offering some help! I really appreciate it. I was able to get a green light by typing:

usbctl on 1

I turned off WEP and typed:

wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
wlanctl-ng wlan0 lnxreq_wlansniff enable=true channel=<AP channel>

I got the reply: syntax error, newline not expected.

When I typed the first line only and enter, I got a message saying enable=success so I'm assuming the second line is the problem. Or else maybe I'm typing something in wrong?
*


Yes, the second line is the problem. You need to insert the channel number of your AP. For example if your AP is on channel 1, you would type/see:
bash-2.05# wlanctl-ng wlan0 lnxreq_wlansniff enable=true channel=1
message=lnxreq_wlansniff
enable=true
channel=1
prismheader=no_value
wlanheader=no_value
keepwepflags=no_value
stripfcs=no_value
packet_trunc=no_value
resultcode=success

I hope this helps,

Craig...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.