Help - Search - Members - Calendar
Full Version: Samba And Cacko3k
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
terryleung83
In the readme file of cacko3kb1, it says that the samba is configured to start from inetd

is it means that i only need to start inetd and then i can access samba by typing //ip/home from the start-> run?

but the fact is that i cant get it running? anyone know the answer?
bluedevils
inetd is a traffic cop that redirects incoming service requests. samba requests to inetd will get samba to respond. Sort of like daemon on demand. I assume there should be an smb.conf for you to configure. That's where I would start.
terryleung83
I discover that the samba service is enabled at default(cacko3kbeta1)

AND ANYONE CAN ENTER MY MD AND DELETE MY FILE WITHOUT ENTER A PASSWORD!!
(sorry to shout here , but it is really surpise me)
just type \\Zaurus\home and anyone can access the hdd3! blink.gif

I want to ask how to make it possible to set a password for samba?

i try to set this in config file
CODE
null password=no
guest ok=no


and this in terminal
CODE
passwd zaurus //give a password to zaurus


now \\Zaurus\home dont work anymore
but \\Zaurus\home?zaurus still work!!!

I have read some here http://www.samba.org/samba/docs/man/smb.conf.5.html
but just cant get it mad.gif
bluedevils
there should be a command smbpasswd to set the passwd and account. This is separate from the system account.
CODE
smbpasswd -a <username>

the second smbpasswd is a file called smbpasswd that will store the password. You will have to make sure you edit the smb.conf file to make the user a valid usr.
terryleung83
i discover that with the above settings, i can no longer acess any files in the system after a reboot
at least the files are protected now

but about setting a password..
i type smbpasswd ....just got command not found...
bluedevils
ah yes I just had a look and you are right. I guess we need to find a working smbpasswd binary. We should also be able to specify the passwd file to use in smb.conf

BTW you could always just take samba out of inetd.conf (and other stuff) or add iptable rules
terryleung83
As it seems that it is not possible to set a password
My final solution is to redefine the path of the home folder in the config file
now, only the Shared_Files can be access through samba smile.gif
(I deleted the system folder)
bluedevils
I found smbpasswd here
smbpasswd

and implemented it. Works like a charm
bluedevils
woops the link was wrong...I fixed it, but you may have to run it through a translator
terryleung83
I installed it
but it doesnt work

su
smbpasswd -a zaurus

it said :
params.c:OpenConFile(0 - Unable to open configuration file "/usr/local/samba/lib/smb.conf":
No such file or directory
Can't load /usr/local/samba/lib/smb.conf - run testparm to debug it
bluedevils
my cacko rom already has a link to smb.conf

just make one

CODE
ln -s /home/root/usr/local/samba/lib/smb.conf /usr/local/samba/lib/smb.conf


where the s means to make it symbolic, the first smb.conf is the real one and the second smb.conf is the link smbpasswd is looking for.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.