Help - Search - Members - Calendar
Full Version: Help!
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus Distro Support and Discussion > Sharp ROMs
Having BIG problems updating to the new Sharp Rom through WinXP...

I can't find any mention of the particular problem I'm having. The SL series (WDM) driver installs AOK, but the second driver doesn't install at all (XP tells me that my new hardware is ready to use after the first wizard).

I can transfer files back and forth through Zaurus File transfer and can sync with Outlook (sort of) through the sync options, but when I run 'Update Rom' from the CD-v313(win upgrade), it gives me a 'FlashRom Update' (unable to connect to the Zaurus).

I've followed the recipe exactly and am well confused about now...

The FAQ at My Zaurus says

"3) Go to Start-control panel-Network Connections. Verify that there is a LAN CONNETION and that it is ‘enabled’ for SL SERIES NDIS 5

4) Right click on the SL SERIES NDIS 5 and go to Properties. Under the Advanced Tab ensure that Firewall setting is disabled."

Nobody, however, has anything to say on what you should do if the LAN connection doesn't exist (I'm assuming that this is my issue. I really don't know enough to say).

The only driver I have installed is my ethernet adapter (SIS 900-Based PCI Fast Ethernet Adapter).

Could someone clever please - in very small words - tell me what to do to update the ROM? (small words and an itiemized aproach are good... I'm on the 'new' end of the newb scale).

Thanks... smile.gif
OK... Tried the C+D Reset with the OSPack for Sharp 3.13 oin a brand new CF card (as per and had no joy whatsoever.

Reformatted to FAT (from FAT32) and tried again with exactly the same results...

I'm going to type vertabim what was on my Zaurus after restart both times (as I don't have a clue what it all means...)

INIT: version 2.78 booting e2fsck 1.19, 13 Jul-2000 for EXT2 FS 0.5b, 95/08/09.
ext2fs_check_if_mount: No such mining whether /dev/mtdblock1 is mounted.
Couldn't find ex2 superblock, trying backup blocks...

The superblock could not be read or does not describe a correct ex2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

e2fsck: Invalid argument while trying to open /dev/mtdblock1

I then goes on to tell me that an error occurred during the file system check and the system will reboot when I leave the shell...

/etc/passwd: root password garbled
Give root password for maintainence (or type Control-D for normal startup):

('Control-D' is not found, by the way... I have to reset and go back to the original ROM about now...)

AAAaaarrrRRrrGhhHHhh!!!! wacko.gif

Could someone please help me out here (Man, I'm WAY over my head!)
OK... Problem solvered (this problem anyway).

Will post new dramas in a separate thread (the only real connection between the issues is the twit who doesn't know what he's doing... blink.gif )

Still... If you're reading this and you know of a 'simple man's guide' to installing Japanese fonts on the SL-5500...
how did you fix this problem?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.